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Chapter 1 - Welcome

What QuicKeys Can Do for You

Although today’s computer operating systems behave well enough out of the box, computer users are 
individuals with unique tastes, jobs, and work styles. That’s where QuicKeys comes in; it lets you modify 
your work flow and the way you interact with your computer. These modifications can range from small 
tweaks to save a few seconds or relieve a sore wrist, to sweeping sequences of actions letting you grab a 
cup of coffee while QuicKeys goes to work on one of your routine morning tasks.

QuicKeys automates the repetitive jobs that take up too much of your day. It lets you create “QuicKeys 
Actions” to replace a task or series of tasks with a single “trigger” such as a keystroke, menu selection, or 
a timer. For instance, you could use QuicKeys to automate applying a series of filters to numerous images 
in a graphics program. Just open the files, hit the assigned trigger, and read a magazine article about tiling 
your floors while QuicKeys puts that graphics software through its paces. Once you learn the ins and outs 
of QuicKeys you can apply that knowledge and powerful new skill to any and all programs, whether or 
not they have their own macro system

Automate Daily Tasks

When you’re done brushing up on your home improvement skills (and QuicKeys is finished with its im-
age altering tasks), tap a key on your keyboard and watch your e-mail program, web browser, and chat 
program all launch automatically. Surf for a while, compose e-mail messages, chat, all the while making 
use of QuicKeys to assume the repetitive or mouse-intensive tasks. Store and retrieve boiler-plate text for 
e-mail, jump to your favorite web sites, change your chat status, all with the touch of a key! 

You can surely see the advantages of using QuicKeys even in these brief examples. Primarily, you’ll save 
time. Every shortcut, whether saving you 10 seconds or 10 minutes of attentive work at your keyboard, 
will give you back some of that most precious commodity. Accuracy is another bonus. Humans are prone 
to error, but with some care, QuicKeys Actions can be built to be bullet-proof, performing a task thou-
sands of times, each iteration exactly like the last.

The time savings are easy to measure, but a less tangible yet even more beneficial advantage exists. After 
you’ve installed and built a number of Actions, your computer and work flow will begin to glide along 
with less effort. The boundaries between individual applications will fall away, merging the various parts 
of your computing day into a more seamless whole. Once you’ve experienced this kind of power, you 
won’t want to use a computer without QuicKeys.

Chapter 1: Welcome To QuicKeys
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About This Manual

This section discusses how this manual is organized and contains information on the conventions used in 
this manual. Knowing how the manual is set up will help you use it more effectively.

Assumptions

This documentation assumes you have a working knowledge of the Windows XP operating system and 
accompanying hardware. For example, you should know how to use your mouse and how to open, save, 
and close files. You should also be familiar with Windows XP interface elements, such as buttons, menus, 
icons, and the system tray. If you need assistance with Windows XP usage or with Windows XP terms, 
consult the documentation that came with your computer, or check the help feature available in the Start 
menu of Windows XP.

Organization

• Chapters 1 & 2 of this manual introduce you to QuicKeys and provide basic instructions for installing 
and operating the software, ending in a tutorial for setting up a simple QuicKeys Action.

• Chapter 3 is an overview of the entire program, finishing with a more detailed tutorial to help jump 
start your QuicKeys experience.

• Chapter 4 covers QuicKeys Toolbars, giving details on how to build and use this flexible feature. 
• Chapters 5-13 describe each Action type and give point-by-point explanations of each feature and 

control. These chapters are organized to match the layout of the Create menu in the Quickeys Editor, 
allowing you to more easily use them as a reference.

• Chapter 14 covers the details of QuicKeys Sequences and step results logic.
• The Appendices cover various topics such as Tips and Troubleshooting, Custom Toolbar Icons, Re-

served Hot Keys, and more.

Conventions

• A “>” symbol indicates the hierarchy of menu and submenu options. For example: Create > Files > 
Open Items.

• A “\” indicates the hierarchy of a file or folder path on your hard drive. For example: <hard drive>\
My Documents\Marketing Data

• A “❖” symbol indicates a note that provides important supplemental information about the topic be-
ing covered.
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Contacting Startly Technologies

If you have questions about QuicKeys for Windows that are not addressed in the manual, use the resourc-
es listed in this section to learn how to find more information.

Sales and Customer Service

Sales Department

Hours: 9:00 A.M. to 5:00 P.M. Central Time 
Phone: 800-523-7638 or 515-221-1801 
Fax: 515-221-2258 
E-mail: sales@startly.com 
Web: http://www.startly.com/shop/

Customer Service Department

Hours: 9:00 A.M. to 5:00 P.M. Central Time 
Phone: 515-221-1801 
Fax: 515-221-1806 
Web: http://www.startly.com/company/contact.html 

Change of Address

To change or update your mailing or e-mail address online visit:
http://www.startly.com/forms/addresschange.html
Or send a letter including your old and new address to:
Startly Technologies 
Attn.: Change of Address 
PO Box 65580 
West Des Moines, IA 50265 U.S.A.



4

Chapter 1 - Welcome

Technical Support

Phone Support

Hours: 8:30 A.M. to 4:30 P.M. Central Time 
Phone: 515-221-1803
Your product serial number and credit card information will be required up front in the event that 
your support request isn’t covered under complimentary support.

E-mail Support

For e-mail support on the current version of QuicKeys, use our online support form at 
http://www.startly.com/support/contact/request.html

QuicKeys Community

Trade ideas with other QuicKeys users at: http://www.startly.com/qkcommunity

For more information on our support policies, visit http://www.startly.com/support

Product Feedback

We encourage you to submit feedback regarding the product and documentation. Please submit feedback 
using our Product Feedback Form at: http://www.startly.com/forms/productfeedback.html
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System Requirements & Installation

This section provides general installation instructions. For the most current installation information, 
always view the Read Me document that accompanies the QuicKeys application, be it on the CD or in a 
downloaded zip file.

System Requirements

Verify that your computer meets the following system requirements before installing QuicKeys.

• PC running Windows XP Home or Windows XP Professional
• A Pentium III or equivalent processor
• Internet Explorer 5.0 or greater
• 128 MB of RAM (256 MB recommended)
• A CD-ROM drive
• At least 20 MB of available hard disk space
• Certain features are enhanced by an Internet connection

Installing QuicKeys

Installation must take place while logged in as an administrator or as a user with administrative rights. 

1. Read the wizard dialog that appears when you start installation and click Next.
2. Read the terms of the Software License Agreement. Click Yes if you agree with the terms and want 

to install the software.
3. Read the Readme file and click Next.
4. Type your Name, Company, and Activation Key in the appropriate boxes and click Next. (Your 

company name is not required.)
5. Choose the directory where you would like to install QuicKeys and click Next. A status bar ap-

pears.
6. Read the final wizard dialog and click Finish. Startup QuicKeys Engine is selected by default so 

the QuicKeys Engine is running when you complete the installation.

After Installation

When you complete the installation wizard, the QuicKeys Engine and QuicKeys Editor are automatically 
started. What’s the difference? The QuicKeys Editor is the program in which you create and edit your 
Actions, Clips and Toolbars, while the QuicKeys Engine is the program that executes the Actions you 
created within the editor. The QuicKeys Engine is a background (hidden from view) application that runs 

Chapter 2: Installation & Starting QuicKeys
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automatically every time you launch QuicKeys from the Start menu, launch it by way of a shortcut, or 
when you restart your computer or log out/in.

When the QuicKeys Editor opens for the first time, users who are upgrading will be greeted with a list of 
the Actions they created in their previous version of QuicKeys. New users will be greeted with a list of 17 
pre-installed Actions installed by default to help get started using QuicKeys.

Figure 1-1: The QuicKeys Editor window.

❖ Note: See Appendix F for detailed descriptions of the pre-installed Actions.
❖ Note: These default Actions can also be found on and imported from the QuicKeys installer CD at 

the following location \\QuicKeys Installer CD\Extras\Default Actions.qkx.
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How To Use Your New Actions

You can trigger the default Actions listed in the QuicKeys editor by:

• Selecting an Action from the QuickReference Card (described below).
• Pressing the hot key combination assigned to the default Actions.
❖ Note: Hot key triggers separated by “->” need to be pressed sequentially to be activated. For ex-

ample, if the hot key is listed as “Shift+Ctrl+O -> I -> E” this means you must press ‘Shift+Ctrl+O’ 
then press ‘I’ then press ‘E’ to trigger the Action.

❖ Note: Each of these triggering methods and more are discussed in “Triggering Actions” on page 26 
in the next chapter. This section provides instructions only for using the QuickReference Card to 
trigger your default Actions.

Using The QuickReference Card

To trigger your new Actions using the QuickReference Card:

1. Press Alt+Ctrl+R to bring up the QuickReference Card window. Alternately you could right 
click on the QuicKeys Menu (the “Q” icon in the system tray down by the clock) and select 
“Open QuickReference Card”.

2. Click one of the Actions listed in the QuickReference Card to trigger it.

Figure 1-2: The QuickReference Card.
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More About The Default Actions

• If you want to edit an Action, double-click that Action in the Actions view of the QuicKeys Editor.
• The default Actions are all Universal in scope. This means that you can use these Actions in any of 

the programs you have open. See page 14 and 25 for more information on Action Scope.
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Starting QuicKeys

Upon installation the QuicKeys engine will be running. If you’ve exited the QuicKeys engine for some 
reason, you can restart it by selecting QuicKeys from the programs listed in your system’s Start menu. 
When the engine is running, QuicKeys Editor can be opened in several ways; use any of the following 
methods to open the QuicKeys Editor:

• Right click on the QuicKeys Menu in the Windows task bar tray, and select Open QuicKeys Editor.
• Double click on the QuicKeys Menu icon in the Windows task bar tray.
• Press the hot key assigned to an Open QuicKeys Editor action, Alt+Ctrl+E by default.

Figure 1-3: You can open the QuicKeys menu from the tray 
area of the Windows task bar.

Check for QuicKeys Updates

When you select “Check for new versions...” from the Help menu in the QuicKeys Editor, QuicKeys con-
nects to Startly Technology’s web server to see what the current version of QuicKeys is. If your version 
of QuicKeys is not current, an alert is displayed telling you how to get the latest. You can choose to go 
to Startly’s Web site immediately or you can choose to be reminded of the update in “X” days. If your 
computer is unable to connect to Startly’s web site, the attempt will time out. A connection failure may 
occur if you have no internet connection configured, if you have problems with your dial-up service, or if 
Startly’s server is not available.
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Tutorial – Your First Action

Feeling brave? Some users like to just jump right in and get their feet wet with a new product without 
reading much of the manual, and there is a lot to be said for having a look at how a product works before 
trying to digest a pile of technical mumbo jumbo. To this end, we’ll now present a short tutorial with step 
by step instructions on making a simple Action in QuicKeys.

The Problem

“I have to type my mailing address frequently, it would be really nice to be able to just hit a key and have 
it typed for me.”

The Solution

Build a simple Type Text Action in QuicKeys which types in your name and home address whenever you 
press Ctrl+Alt+H on your keyboard.

How To

1. In preparation, open your word processor, text editor, or any application that handles text docu-
ments, and create a new document. WordPad is a good choice if you don’t have a favorite.

2. Make sure QuicKeys is running (check for the QuicKeys “Q” in the Windows task bar tray) then 
open the QuicKeys Editor using one of the following methods:
• Right click on the QuicKeys Menu in the system tray, and select “Open QuicKeys Editor”.
• Double click on the QuicKeys Menu icon in the system tray.
• Press the hot key assigned to an Open QuicKeys Editor action, Alt+Ctrl+E by default.

3. Click the Actions button to ensure you are working in the right part of the QuicKeys Editor. (See 
Figure 1-4 as reference for steps 3, 4, and 5 of this tutorial.)

4. Click on the “Universal” scope folder. You want QuicKeys to be able to type your address into a 
text area in any program, thus we need this Action to be in the Universal program scope.

5. Go to the Create menu and select Text Tools > Type Text. This will create a new window as shown 
in Figure 1-5.

6. Click in the Name field and name this Action “Type Home Address”.
7. Click in the Hot key field and press “Alt+Ctrl+H” simultaneously to assign the hot key by which to 

trigger this Type Text Action.
8. Click in the Action-specific properties field and type in your mailing address.
9. Click the OK button in the lower right corner of the Action Properties window to save and close it. 

Your new QuicKeys Action is ready to use.
10. Switch to WordPad and press “Alt+Ctrl+H” to watch QuicKeys do its thing!
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Figure 1-4: Creating a Type Text Action.

 
Figure 1-5: Editing the properties of a Type Text Action.
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Alternate Solutions

As your knowledge of QuicKeys  grows, you will discover alternate and more powerful ways to use it. In 
the case of typing blocks of text, the Clipbook action is that alternate method. Clipbook actions allow you 
to collect text and graphics on the fly, and retrieve them from those collections when needed.

The Sky’s the Limit

Although this Type Text shortcut is quite simple, it illustrates many of the important aspects of QuicKeys. 
You’ll use the same basic procedure for every shortcut you create, and as you grow wise in the ways of 
automation, youʼll discover many variations on this basic theme. Whether your shortcuts are simple or 
complex, the only limit is your imagination.
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Chapter 3 - QuicKeys Overview
This chapter introduces the basics on how to use QuicKeys and provides an overview of the QuicKeys 
user interface. Reading this chapter will acquaint you with the capabilities of QuicKeys so you can take 
full advantage of the software’s power and flexibility.

Creating QuicKeys Actions and Sequences

QuicKeys is a powerful software tool you can use to automate your computer, but as a tool it is only as ef-
fective as you make it. Once you install QuicKeys, you need to make a mental note of the tedious, routine 
tasks you perform on your computer and earmark those tasks for some attention from QuicKeys. Each 
time you think of something that QuicKeys could make easier for you, create an Action or Sequence that 
automates that task or series of tasks.

When you create a QuicKeys Action or Sequence, you can choose the trigger that activates it. For ex-
ample, if you want QuicKeys to open a database program and enter the current date and time, you need 
to let QuicKeys know when to begin. You can use a hot key (such as F5), or a number of other available 
QuicKeys triggers (such as Toolbars, the QuicKeys menu, or Event triggers) to indicate to QuicKeys that 
you want to begin this Sequence.

That’s all there is to using QuicKeys: thinking of tasks to automate, creating QuicKeys Actions or Se-
quences that mirror those tasks, and triggering the Actions or Sequences. You need to spend a few minutes 
telling QuicKeys what you want, but from that point on you save minutes, hours, even days with the Ac-
tion or Sequence that only took a small time investment to set up.

QuicKeys Actions and Sequences

QuicKeys Actions and Sequences are the foundation of the QuicKeys program. QuicKeys Actions au-
tomate simple one-step tasks, such as choosing a network printer. QuicKeys Sequences automate multi-
step tasks, such as starting a database program, searching for a specific item, or printing out the selected 
database records. Actions can be built using Setup Wizards or the Action Properties dialog. Sequences are 
built using a collection of Actions that can be assembled manually or by using the QuicKeys recording 
feature. The recording feature enables QuicKeys to “watch” what you are doing and repeat your actions.

Triggers

A trigger is a signal that directs QuicKeys to play or activate a specific Action or Sequence. When you 
create an Action, you can assign one or more triggers to it. For example, you can assign Ctrl+Shift+F3 as 
a hot key trigger that launches Microsoft Word, or you can create a trigger to automatically launch your 
e-mail application at 7:30AM while you’re still brushing your teeth.
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Trigger types

• Hot Key - You assign a keystroke or key combination to play a particular Action.
• Menu - You can add Actions and Sequences to, and trigger them from the QuicKeys Menu.
• Date & Time - Lets you select the time and date for an Action to be played. Actions can also be set to 

repeat periodically.
• Event Trigger - Actions can be triggered automatically after your system starts up or after a program 

opens, quits, gains focus (moves to the front), or loses focus (is no longer front-most).
• Toolbar - Any Action or Sequence can be added to a QuicKeys Toolbar and activated from there.
❖ Note: Triggers are covered in greater detail later in this chapter on page 28.

Action Scope

Scope is the realm of operation for a trigger. You can specify the scope of an Action to limit the programs 
under which that Action can be triggered. Scope comes in two major flavors, Universal and Program-spe-
cific.

Universal - When scoped to Universal, an Action will be active no matter which program is in front. 
For example, your F1 key might be set up to hide the front program. If you scope it to, say, Word, then 
the F1 key would only hide the front program if it happened to be Word. You’d need to scope that hot 
key to Universal for it to work as desired for any program.
Program-specific - A trigger scoped to a specific program will only be active when that application 
is in front. You can duplicate an action and assign it to more than one scope if desired.
Scope interaction - Triggers scoped to a specific programs always take precedence over those 
scoped to Universal. This is useful for special case situations where you may not want your F1 key 
triggering the same shortcut in Word (for example) that it does in your other programs.

QuicKeys Components

Part of understanding any piece of software is understanding its different components. The following 
overview of the major components of QuicKeys will familiarize you with the program, making it easier to 
find things and use the software more efficiently.

QuicKeys Editor

When you select QuicKeys from the Start menu, the QuicKeys Editor appears. It is your control center 
for creating, editing, and deleting Actions. There are four separate views available in the QuicKeys 
Editor that each serve a different purpose: the Actions view, the Toolbars view, the Clipbooks view, 
and the Setup Wizards view. These views are selected by clicking on the buttons on the View Bar in the 
lower left of the QuicKeys Editor windows.
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Figure 3-1: Anatomy of the QuicKeys Editor Window.

QuicKeys Editor Anatomy

There are 4 major parts to the QuicKeys Editor Window:
• Control area - The top of the editor window contains 3 prominent control features:

• Menu Bar - A standard menu bar for accessing any/all of QuicKeys’ features. See Appendix D for 
detaileds on each menu item.

• Main Toolbar - A standard toolbar containing buttons (such as Save, Copy, Paste, Delete) for 
maintaining your collections of Actions, Toolbars, and Clips.

• Clips Toolbar - A text editing toolbar for editing your Clips when in the Clipbooks view.
• View Pane - The right half of the editor window is dominated by the View Pane. This region con-

tains the individual items that belong to whichever view you are in. Possible Views include:
• Actions - Lists the Actions and Sequences you’ve created, grouped by program Scope.
• Toolbars - Lists the Toolbars you’ve created with QuicKeys.
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• Clipbooks - Lists the Clipbooks and associated graphic and text Clips available to you. See Chap-
ter 8 for details on using Clipbooks and Clips.

• Setup Wizards - Displays buttons that initiate step-by-step setup wizards to help new users get 
started more quickly with QuicKeys.

• View Bar area - The lower left corner of the QuicKeys Editor window contains buttons to switch 
between views in the View Pane.

• Workspace Pane - Contains subsets or groupings of the items contained in whichever view you 
are in, listed in the familiar folder/hierarchy structure.

Action Properties Dialog

The Action Properties dialog is the editing window for any Action you create. The contents of this win-
dow can vary significantly depending on the type of Action you are working with; the features common 
to any Action Properties window are as follows:
• General tab - The upper portion of this tab is where you set the name and hot key of the Action. The 

lower portion of this tab changes depending on the type of Action you’re editing.
• Name field - Enter the name of your Action here.
• Hot key field - If the Action you are editing has a hot key trigger it can be found, cleared, and 

assigned in this field.
• Include in QuicKeys menu - If you check this box the Action will appear as an item in the 

QuicKeys menu (the Q found in the system tray down by your clock). Selecting an action from 
the QuicKeys menu triggers that Action.

 

  
Figure 3-2: The Action 
Properties dialog.

• Toolbars tab - This tab lists all toolbars you have created. You can add the Action you are editing to 
one or more of those toolbars in this tab.
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• Action Scope tab - Set the Scope of the Action you are editing, indicating whether that Action is to 
be universally active or only able to be triggered when a specific program is active.

• Event Triggers tab - Set timers to automatically trigger your Action at specific times and dates, at 
login, when a program launches or exits, and more.

Sequence Editor

The Sequence Editor enables you to assemble multiple Actions into a more complex Sequence that 
accomplishes a multi-step task. For example, you can create a Sequence that launches your e-mail 
program, types your user name and password, and clicks OK in the appropriate dialog. The Sequence 
would contain four separate Actions that are individually only capable of completing a single task until 
they are combined into a Sequence.
There are three different methods for opening the Sequence Editor:

• Go to the Actions view in the QuicKeys Editor and select the Create > Sequence menu item.
• Double-click an existing Sequence listed in the Actions tab.
• Record a Sequence and the Sequence Editor appears automatically when you are done recording. 

(See chapter 5 for more information on recording.)
 

 
Figure 3-3: The Sequence Editor 
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Major features of the Sequence Editor Window include:
• General tab - The upper portion of this tab is where you set the name and hot key of the sequence.
• Toolbars tab - This tab lists all toolbars you have created. You can add the sequence you are editing 

to one or more of those toolbars in this tab.
• Action Scope tab - Set the Scope of the sequence you are editing, indicating whether that sequence is 

to be universally active or only able to be triggered when a specific program is active.
• Event Triggers tab - Set timers to automatically trigger your sequence at specific times and dates, at 

system startup, when a program launches or exits, and more.
• Repeat tab - Lets you set the number of times playback of this sequence happens when triggered.
• Name field - Enter the name of your sequence here.
• Hot key field - If the sequence you are editing has a hot key trigger it can be found, cleared, and as-

signed in this field.
• Include in QuicKeys menu - If you check this box the sequence will appear as an item in the 

QuicKeys menu (the Q found in the system tray down by your clock). Selecting a sequence from the 
QuicKeys menu triggers that sequence.

Toolbars

QuicKeys Toolbars provide a quick and easy way of graphically organizing and triggering your Ac-
tions. You don’t have to remember as many hot keys and you won’t clutter your QuicKeys menu as 
much if you use toolbars as triggers for some of your Actions.
When you click a toolbar’s name in QuicKeys Editor (in Toolbars view), all the buttons that reside on 
that toolbar display in the Toolbar Buttons pane.

• Right-click a toolbar in the Toolbars tab to create a new toolbar or create a new toolbar button, 
delete the toolbar, or display the toolbar’s properties.

• Right-click in the Toolbar Buttons pane to create a new button, or delete the selected toolbar but-
ton.

• Double-click a toolbar in the QuicKeys Editor to display the toolbar’s Action Properties dialog.
• See Chapter 4 for more detailed information on toolbars.

Clipbooks

The QuicKeys Clipbook is a manager for bits of text and graphics called “Clips”. It can be used to 
store, edit and quickly retrieve snippets of text and images or combinations of the two. These Clips are 
not volatile like the data on your system clipboard, they are stored permanently within QuicKeys. They 
preserve stylized text, such as font and color information and can be easily edited within the Clipbooks 
workspace in the QuicKeys Editor. See the QuicKeys Clipbooks section in Chapter 8 for details on us-
ing Clipbooks.
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QuicKeys Engine

The QuicKeys Engine is a background program that is necessary for the QuicKeys Editor to function. 
Most of the time you don’t need to pay any attention to the Engine because it’s started whenever you 
turn on your computer. However, if you ever turn off the QuicKeys Engine, it’s important to know how 
to turn it back on because your Actions won’t work without it.
When you install QuicKeys, a shortcut to the QuicKeys Engine is placed in the Startup Items folder. 
The only time you may need to exit the QuicKeys Engine is when you install new programs that 
require you exit all programs. In such a situation, you can right-click the QuicKeys icon located on the 
task bar and choose Exit to quit the engine.
Use one of the following methods to restart the QuicKeys Engine:
• Restart your computer or log out and log back in.
• Select QuicKeys from the Start menu.

QuicKeys Plug-ins

A plug-in is a software component that adds functionality to QuicKeys. There are several plug-ins built 
into QuicKeys and third party plug-ins can also be added through this plug-in architecture. Administra-
tors may want to disable certain plug-ins for their users, so each plug-in can be turned on or off indi-
vidually. You can access the plug-in interface by choosing the View > Plug-ins menu in the QuicKeys 
Editor.

QuicKeys Menu

By default, a QuicKeys icon appears on your task bar after installation. When you right-click that icon, 
the QuicKeys menu appears. If the QuicKeys icon or QuicKeys hot keys are not displayed in your task 
bar, check to make sure QuicKeys is running. You might also have this icon shut off in the View > 
Options menu of the QuicKeys editor, so check there if QuicKeys is running but the menu icon is not 
showing in the task bar.
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Figure 3-5: Right click on the QuicKeys icon in the 

Windows task bar to access the QuicKeys Menu.

Structure of the QuicKeys Menu

The major features of the QuicKeys Menu include (from bottom of the menu up):
• QuicKeys information - About QuicKeys, QuicKeys Help, and Version checking information.
• Editor and Variables - Open the Editor, Exit QuicKeys, show/hide the QuicKeys Variables or Equa-

tion Tester windows.
• Recording control - Start or Stop Recording or a single or multiple Actions.
• Sequence control - Abort a Sequence during playback.
• Toggle Toolbars - Turn toolbars on/off individually, or create a new toolbar.
• Debug Actions - Turn Action/Squence debugging during playback on/off.
• Trigger QuicKeys Actions - Any Action created with the option of being in the QuicKeys Menu ap-

pears at the top of and can be triggered from this area of the menu.

Setup Wizards

QuicKeys’ Setup Wizards guide you through the process of setting up Actions. This is a good place to 
start if you are new to QuicKeys and especially if you are an inexperienced computer user.
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Figure 3-6: QuicKeys Editor displaying a filtered list of Setup Wizards. 

The Setup Wizards can be accessed from within the QuicKeys Editor, just click on the Setup Wizards but-
ton in the lower left corner of the editor window. Each of the dozens of setup wizards will present several 
steps to lead you through creation of Actions.

All Setup Wizards work basically the same, stepping you through the following processes:

• You determine what type of Action you want to create and click on the appropriate Setup Wizard but-
ton. The wizard will open and present an introduction to that particular Action type.

• Next you choose between Creating a new Action and Editing or Deleting an existing Action of the 
same type as the wizard you are working with.

• Each wizard typically has multiple Actions it can set up for you; the third step is where you tell the 
wizard which Action you want to create.



22

Chapter 3 - QuicKeys Overview

• Next you must give the Action a name, and as desired set its scope, assign a hot key or other trigger, 
or place it on a toolbar or in the QuicKeys menu.

 

 
Figure 3-7: Using the Advanced Text Tools Setup Wizard.



23

Chapter 3 - QuicKeys Overview

Setting Up Multiple Actions

If you don’t want to go through the Setup Wizard 5 times for 5 very similar Actions, you can create all 
5 Actions simultaneously using the Create/edit multiple Actions option. The Create/edit multiple Ac-
tions option is available for the following Actions:

•  Advanced Text Tools   •  CD/DVD
•  Folders     •  Choose Printer
•  Instant E-mail    •  Open
•  QuicKeys Clipbook   •  QuicKeys Controller
•  Screen Settings    •  Set Audio Volume
•  Type Date/Time    •  Dial-Up Networking
•  File Handler    •  System Specials
•  Window Handler   •  Zip Files
•  Screen Saver    •  Quick Type
•  Screen Capture

To create multiple Actions simultaneously:
1. Select an Action in the Setup Wizards tab that offers the Create/ edit multiple Actions option.
2. Read the Introduction page and click Next.
3. Select Create/edit multiple Actions and click Next.
4. Read the Multiple Action Introduction page and click Next.
5. Select the check box for each Action you wish to create.
6. Choose whether you want to trigger the Actions using hot keys or the QuicKeys menu. If you 

want to use a hot key, position your cursor in the Hot key column and press a hot key. If you 
want to use the QuicKeys Menu, click the Menu column.

Creating QuicKeys Actions

When you create a QuicKeys Action, you can use the Setup Wizard (shown in Figures 3-6 and 3-7) or the 
Action Properties dialog (shown in Figure 3-2) to specify how the Action behaves. The Setup Wizards 
present you with several screens of settings, stepping you through the setup process. The Action Proper-
ties dialog puts all of these settings in one window with several tabs. This interface is more efficient once 
you become familiar with it. The method you use to create QuicKeys Actions is completely dependent 
upon your comfort level with QuicKeys. Because the Action Properties method is not as self-explanatory 
as the Setup Wizards, using it to create Actions is described in more detail in this section.
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Action Properties In Detail

To create a new Action using the Action Properties dialog you need to open the QuicKeys Editor and click 
on the Actions button in the workspace pane, then simply select the desired Action from the Create menu.

  

Figure 3-8: The Create menu is 
contextual, its contents change 
depending on what part of the 
QuicKeys Editor you are in. To 
access the list of Actions shown 
in this figure, the QuicKeys Editor 
must be in Actions view.

The Action Properties Tabs

General tab - Supply the name of the Action and the hot key that triggers it in this tab. You can also 
select the “Include in QuicKeys menu” check box to list the Action in the QuicKeys menu or click the 
“Clear hot key” button to clear the contents of the hot key field.
Toolbars tab - Click the Toolbars tab to reveal a list of the toolbars you have created with QuicKeys. 
You can then click the check box beside a toolbar to display this Action on that toolbar. An Action can 
be added to or removed from multiple toolbars. 

 
Figure 3-9: The General and Toolbars tabs of an Action Properties dialog. 
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Action Scope tab - Specify the range of operation for the Action. In other words, choose whether 
the Action works at any time, or whether it can only be triggered from within a specific program, re-
stricted to work only in the desktop or from a particular hardware profile.

Available Action Scopes
• Universal - Universal is selected by default for each Action you create. Use Universal when you 

want to be able to trigger the Action at any time, regardless of what program you are in.
• Desktop - Select Desktop when you only need to trigger the Action from the desktop.
• Program - When you select Program, a Program drop-down list appears where you can choose the 

program in which you want to use the Action. Click the Browse button and navigate to the pro-
gram you want to use if the program is not listed in the drop-down list. This scope option is useful 
if you have Actions you want to restrict to a specific program, such as Microsoft Word.

• Hardware Profile - A hardware profile is a set of instructions specified within your operating sys-
tem that tell your computer which devices to start when you turn on your computer. In other words, 
hardware profiles enable you to categorize QuicKeys Actions under different hardware identities.
For example, you can set up the F5 key as the hot key that tells your portable computer to switch 
to Standby mode when your computer is using a Docked Hardware Profile. Additionally, you can 
use the F5 key within the Undocked Hardware Profile scope to shut down your computer when 
your computer is undocked. The same hot key works differently depending upon the “state” of 
your computer.

❖ Note: When you press a hot key trigger QuicKeys first checks to see if you have any Actions using 
that hot key that are scoped to the program you are currently in; if so, that Action is triggered. If not, 
QuicKeys checks to see if that hot key is assigned to an Action scoped to the current Hardware Profile; 
if so, that Action is triggered. If not, QuicKeys checks for any Actions using that hot key as a trigger in 
the Universal scope.

 
Figure 3-10: The Action Scope and Event Triggers tabs of an Action Properties dialog.
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Event Triggers tab - This tab lets you configure additional triggers for your Action. Options include 
triggering your Action a user-defined number of seconds after your computer (or a specific program) 
starts up, triggering your Action at a specific date and time, and triggering your Action repeatedly every 
second, minute, hour, day, week, or year.
Action-Specific Properties - The bottom half of the Action Properties dialog is occupied by the 
Action-specific properties pane. The contents here vary depending on what type of Action you are edit-
ing. Discussion of the Action-specific properties for each Action type can be found in Chapters 5 - 13.

Triggering Actions

QuicKeys provides a variety of ways to trigger Actions so you can use the methods that make sense to 
you. QuicKeys makes customizing the way you work easy. You can set your triggers in the various tabs 
of the Action Properties dialog or in the Triggers page of the Setup Wizard. You can use any or all of the 
following triggers for each QuicKeys Action:

Hot key triggers

Nearly any key or key combination can be assigned as a hot key trigger. Pressing these keys or key 
combinations will trigger the associated Action. In addition, hot keys can be “chained” together so that 
pressing a series of keys and/or key combinations triggers an Action.

Example hot key triggers:
F9 : A simple, single-key hot key trigger. Pressing the F9 key triggers the Action.
Ctrl + Shift + C : A key combination hot key trigger. Pressing the Control Shift and C keys at the 
same time triggers the action.
Ctrl + Shift + O > A > B : A chained hot key trigger. Pressing Control Shift and O, releasing them, 
then pressing and releasing “A”, then pressing and releasing “B” triggers the Action.

Assigning hot key triggers

To assign a hot key trigger to an Action do the following:
1.   Open the desired Action by locating it in the QuicKeys Editor “Actions” view pane.
2.   Click on the General tab.
3.   Click in the hot key field.
4.   Press the desired key or key combination, they keys you pressed should appear in the hot key field.
❖ Note: A hot key trigger will appear in red if you have assigned that hot key to more than one Action. 
❖ Note: Certain keys such as “tab” “esc” and “enter” require that you hold down your left mouse but-
ton when assigning. 
❖ Note: If you assign the same hot key to multiple Actions in the same scope, pressing that hot key 
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will trigger all of those Actions simultaneously.

Toolbars as triggers

Actions can be placed on QuicKeys toolbars for easy access. Simply click an icon on a toolbar to trig-
ger that Action.

Event Triggers

Event triggers can be set to a specific date/time, time of day, or repeating interval when QuicKeys Ac-
tions are automatically triggered. In addition, if your Action is scoped to a specific program the option 
“Trigger xx seconds after startup” changes to a pop-up selector containing the following triggering 
options:

• Trigger Action xx seconds after a program starts up. 
• Trigger Action xx seconds after a program shuts down. 
• Trigger Action xx seconds after a program gains focus (becomes front-most). 
• Trigger Action xx seconds after a program loses focus (is no longer front-most).

 
Figure 3-11: The contents of the Event Triggers tab changes depending on whether the Action 

is scoped to Universal (left image) or scoped to a specific program (right image).

QuicKeys Menu

Actions you have set to “include in QuicKeys menu” will appear as choices in that menu when it is 
accessed. The QuicKeys menu appears when you right click on the QuicKeys “Q” icon in the Windows 
task bar. Trigger your Actions by selecting them from the QuicKeys menu.

QuickReference Card

The Quick Reference Card is dynamic; as you create new Actions they appear on the Quick Reference 
Card automatically. To trigger an Action with the Quick Reference Card, simply press the designated 
hot key to bring it up (or select it from the QuicKeys Menu) and click an Action listed in the resulting 
QuickReference Card window.
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Figure 3-12: The Quick Reference Card; click a listed Action to run it. 

The main purpose of this feature is to jog your memory if you forget which hot key performs which 
Action. You can launch Actions by clicking them in the QuickReference Card, or you can simply use 
the QuickReference Card to quickly view the Actions and hot keys you have created.
By default, QuicKeys uses the Alt+Ctrl+R hot key to open the QuickReference Card. When triggered, 
the QuickReference Card opens to the tab representing Actions in the most restrictive scope. For 
example, if FileMaker is open and in front when you press Shift+Ctrl+Space, the Actions scoped to 
FileMaker appear in the QuickReference Card. If there are no Actions scoped to FileMaker, the Uni-
versal tab is shown.

Shortcut on desktop

Actions can be turned into clickable shortcuts on your desktop. Simply drag-and-drop an Action from 
the QuicKeys Editor onto the desktop or Start menu to create a Windows shortcut to that Action.

Managing QuicKeys

This section discusses standard procedures, such as printing and saving QuicKeys Actions. It also pro-
vides information on turning individual Actions on and off, resolving hot key conflicts, and importing/ex-
porting Actions.
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Printing Actions

If you want to print a list of your Actions, select Print from the File menu. The same Action list is printed 
regardless of which QuicKeys Editor tab is in the foreground. The following information is printed:

• Action names
• Action descriptions
• Hot keys assigned to Actions
• Whether or not Actions are displayed in the QuicKeys menu.

Renaming Actions

To rename an Action, open the QuicKeys Editor and select the Action you want to rename. Click the Ac-
tion name a second time to display a blinking text cursor. Then, make your changes to the Action name 
and press the Enter key.

Saving Actions

Your Actions are automatically saved whenever you click Finish in the Setup Wizard or click OK in the 
Action Properties dialog. When working with a Sequence, clicking Save & Exit saves the Action, or if 
you try to close the Sequence window after you’ve made changes you’ll automatically be prompted to 
save those changes.

Clearing Hot Keys

When you no longer want a hot key assigned to an Action, click the Clear hot key button in the Action 
Properties dialog. Do not try to clear your hot keys with the Delete or Backspace keys because QuicKeys 
will assign those keys as triggers.

Enabling/Disabling Plug-ins

If you find that you have no need for some of the Actions installed with QuicKeys, you can disable the 
associated plug-ins so they no longer display in the QuicKeys Editor. For example, if you use a PC that 
does not have a sound card and if you don’t use your CD-ROM drive for audio CDs, you probably don’t 
need any of the multimedia Actions, such as CD/DVD or Set Audio Volume. While it is not necessary to 
disable unused plug-ins, some clutter can be removed from the Create menu by doing so.

To enable/disable Actions:

1. From the within the QuicKeys Editor, select View > Plug-ins.
2. In the QuicKeys Plug-in Manager dialog, click the + and - icons to expand and collapse the various 

Action categories.
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Figure 3-13: You can disable unwanted plug-in types with the QuicKeys Plug-in Manager. 

3. Select the Actions types or categories you no longer wish to view and click the Disable button. Or, 
simply click the checkbox next each Action type to enable/disable it.

4. Click Close when you are finished.
The Plug-ins you turned off in the Plug-in Manager are no longer loaded and their associated Actions 
are no longer displayed in the Create menu in Actions view.

Deleting QuicKeys Actions

Deleting Actions is as simple as opening the QuicKeys Editor to Actions view, clicking on an Action, and 
pressing your delete key. Another way to delete and action is to right click on it and select Delete from the 
contextual menu. You can delete multiple Actions simultaneously from the QuicKeys Editor as well. To 
do so, Ctrl+click or Shift+click the Actions you want to delete and then right-click the selected Actions, 
selecting Delete from the context menu, or just press your delete key.

Exiting QuicKeys

When you want to close the QuicKeys Editor, simply click the QuicKeys Editor close box or select Exit 
from the File menu. However, if you select Exit QuicKeys from the QuicKeys menu, the QuicKeys En-
gine is turned off. To turn it back on again, you must click the Windows Start menu and select QuicKeys 
from the Programs submenu.

Resolving Hot Key Conflicts

Hot key conflicts occur when a hot key in one Action Set conflicts with a hot key in another set or a hot 
key that is built into another program. For example, let’s say the F5 hot key is assigned to two QuicKeys 
Actions. One hot key opens Photoshop and is Universal in scope. The other hot key changes the layout of 
a document and can only be triggered in a specific database program. What happens when you press F5?

QuicKeys follows rules of priority to resolve hot key conflicts. When the same hot key is used for several 
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different tasks, the resulting Action depends upon where the hot key falls in the following hierarchy:

A. Program-specific hot keys
B. Universal hot keys
C. Hot keys defined by a particular program

Applying this information to the above example, if the database program is open, F5 formats a database 
document. If the database program is not the active program, F5 starts Photoshop.

Now imagine you have F5 assigned to a universal Action that launches Photoshop, but you also run a 
spreadsheet with a built-in hot key of F5 that you use frequently. In this situation if you press F5 while in 
your spreadsheet program it will launch Photoshop.

However, you can inoculate your spreadsheet program against this occurrence by creating a QuicKeys 
Action to remap the F5 key back to itself when you are using your spreadsheet software; here’s how:

1. Open the QuicKeys Editor and select Actions view.
2. Select Create > System Tools > Type Keystroke.
3. Click in the hot key field and press F5 to assign it as the trigger.
4. Click in the “Key(s) to type” field and press F5 to assign it as the keystroke to be sent.
5. Switch to the Action Scope tab and set the scope to the program you wish to inoculate against 

QuicKeys’ hijacking of the F5 key.
Now when you are working in your spreadsheet program and you press F5, QuicKeys will trigger a your 
new shortcut which simply sends an F5 keystroke to your spreadsheet program. That key’s functionality 
within the spreadsheet program is no longer overwritten by QuicKeys!

Enable/Disable Hot Keys

If hot key conflicts occur in programs you use infrequently, the best way to circumvent the problem 
is to turn your QuicKeys hot keys off temporarily using the QuicKeys Controller Action. This feature 
enables you to instantly toggle QuicKeys hot keys on and off to avoid hot key conflicts. 
For example, you may want to disable QuicKeys hot keys while working in Microsoft Excel™ if Excel 
uses Ctrl+1 to insert cells, but you have directed QuicKeys to use Ctrl+l to change selected text to ital-
ics. Turning off QuicKeys hot keys temporarily might be the best quick answer to the problem.
Here’s how to create this QuicKeys Controller Action using the Setup Wizard:

 1. Open the QuicKeys Editor and select Setup Wizards.
 2. Click the QuicKeys Controller button.
 3. Read the introduction page and click Next.
 4. Select Create a new Action and click Next.
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 5. Select Set status of QuicKeys and click Next.
 6. Select Toggle status and click Next.
 7. A name is automatically assigned to the Action. You can use the assigned Action name or type 

a different one.

 
Figure 3-14: The Setup Wizard for QuicKeys Controller Actions. 

8. Select the Assign hot key check box and click Next.
9. Click in the Hot key box and press the F11 key.
10. Click Next.
11. Click Finish.

Now simply press F11 whenever you need to turn QuicKeys hot keys on and off.

Reassigning Built-in Program Hot Keys

If hot key conflicts occur in programs you use on a daily basis, you need to change either the hot keys 
QuicKeys assigned or the hot keys (or shortcuts) your programs use. You can change your QuicKeys 
hot keys simply by going through the QuicKeys Setup Wizard and pressing a different hot key when 
you see the wizard page with the Hot key field. To change your built-in program hot keys, you can use 
the Type Keystroke Action. For information on using the Type Keystroke Action, see page 115.
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Importing Action Sets

You can import Action Sets when you receive QuicKeys Action Sets from other QuicKeys users or when 
you want to restore from a backup set. When you import Actions, you import all the attributes originally 
assigned to the particular Actions. For example, you import the triggers, icons, and scope selections for 
the Actions. If the scope of the Action is invalid in the new environment, the scope is automatically reas-
signed to Universal.

To import your Action Set:

1.   Open the QuicKeys Editor and select File > Import.
2.   Navigate to the location of the Quickeys Action Set you want to import and select the file with the 

.qkx extension.
3.   Click Open. The Action Set is imported into your collection of QuicKeys Actions; you can find 

them in the editor’s Actions view.
❖ Note: You can also double-click a .qkx file to import it into your collection of QuicKeys Actions.

Importing Duplicate Hot Keys

If you import QuicKeys Actions that use hot keys already assigned to existing Actions, You will be 
alerted to this fact by QuicKeys. You can choose to import new Actions without hot key assignments to 
remedy this. This option removes hot keys for imported Actions that duplicate existing hot key triggers. 
Imported Actions that do not use existing hot keys retain their hot key trigger after import.
The other option is to import new Actions and remove existing hot key triggers. All imported Actions 
retain their hot keys, while Actions that already exist in the Actions tab are stripped of their hot key 
assignments.

Exporting Action Sets

You can export Action Sets when you want to share your QuicKeys Actions with other QuicKeys users 
or when you want to back up your Actions. When you export Actions, all attributes are exported. These 
attributes include the triggers, icons, and scope assignments for the Actions being exported.

To export your Action Set:

1. From the list of actions in Actions view of the QuicKeys Editor, select the Actions you want to export.

2. Select Export Selection from the File menu.

3. Choose where you want to save the exported file and click Save. Your Action Set is saved to the loca-
tion you specified.
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Setting QuicKeys Options

You can customize what you see when you run QuicKeys in the Options dialog. Select Options from the 
View menu to open the Options dialog. You choices include:

Show icon in task bar - Displays the QuicKeys icon in your task bar. You can right-click the 
QuicKeys icon to display the QuicKeys menu. You can disable this option if you do not want to trigger 
Actions from the QuicKeys menu.
Show hot keys in QuicKeys Menu - Displays the hot keys assigned to your Actions in the QuicKeys 
menu. Show Icon in task bar must be selected for this option to be available. You may want to disable 
this option if you only want Action names to display in the QuicKeys menu.
Show Setup Wizard introduction page - Displays the introduction page in the Setup Wizards when-
ever you create or modify an Action from the Setup Wizards tab. When you become familiar with what 
each Action does, you may want to disable this option to go through the Setup Wizard more quickly.

 
Figure 3-15: The View > Options dialog. 

Always use Setup Wizards for editing - Displays a Setup Wizard each time you modify an Action. 
When this check box is checked and you attempt to modify an Action from the Actions tab, the appro-
priate Setup Wizard appears rather than the Action Properties dialog.
Show sequence recording toolbar - Displays the QuicKeys recording toolbar after you select the Start 
Recording option so you can control recording with a click of your mouse.
Show sequence playback toolbar - Displays the QuicKeys playback toolbar when you are running a 
Sequence so you can track and control the playback of a Sequence.
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Using Online Help

You can access QuicKeys Help from the Help menu, from the QuicKeys menu, by pressing F1, or by 
clicking the Help button. The Help system allows you to browse or search topics using the Contents, 
Index, or Find tabs. Use the Contents and Index tabs as you would use the table of contents or index in a 
standard manual. Use the Find tab as you would use the Find feature in a standard software product.

The Help system installed with QuicKeys is different than the printed manual in that it is written to an-
swer specific questions you may have as you use the QuicKeys software. In contrast, this printed manual 
is written to teach you about QuicKeys using detailed explanations and examples.
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Tutorial - Your First Sequence

It’s time for another break from the reading. Let’s create another Action, making use of some of the new 
things we’ve learned. This tutorial will provide an example of building a Sequence from several Actions.

The Problem

“I frequently transpose characters when typing, sometimes entering ʻwrokʼ instead of ʻworkʼ, or ʻthierʼ 
instead of ʻtheirʼ. It would be great if QuicKeys provided a way to quickly swap characters that are out of 
order.”

The Solution

Build a short Sequence in QuicKeys that swaps adjacent characters in a text editor whenever you press 
Control+Shift+Up Arrow on your keyboard. This sequence will consist of four steps, all of which will be 
Type Keystroke Actions. The first step selects the character to the right of the insertion point. The second 
cuts that character. The third moves the insertion point in front of the left character. The fourth step pastes 
in the character that was cut earlier, swapping their positions. Simple!

How To

1. Open the QuicKeys Editor and select the Actions view.
2. Select Create > Sequence, a new Sequence editor window will appear. Inside this window we will 

create four steps made up of Type Keystroke Actions. 

 
Figure 3-16: Creating a new Sequence.
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3. From the menu bar in the Sequence editor, select Insert > System Tools > Type Keystroke. This cre-
ates the first step of the Sequence; the Action Properties dialog for Type Keystroke will appear.

 
Figure 3-17: Inserting a Type Keystroke Action into the Sequence. 

4. Configure the Type Keystroke step by clicking in the “Key(s) to type field” so that it highlights 
then press your keyboard’s shift and right arrow keys at the same time. “Shift + Right” should ap-
pear in the “Key(s) to type” field. Click the OK button to close the window.

 
Figure 3-18: Configure the first Type Keystroke step. 
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5. Let’s create the second Type Keystroke step a bit differently. Right click with your mouse some-
where below the first step in your Sequence editing window; a contextual menu will appear. 
Choose Insert > System Tools > Type Keystroke from this contextual menu.

 
Figure 3-19: Using a contextual menu to create the second Type Keystroke step. 

6. Configure the Type Keystroke step by clicking in the “Key(s) to type field” so that it highlights 
then press your keyboard’s Ctrl and X keys at the same time. “Ctrl + X” should appear in the 
“Key(s) to type” field. Click the OK button to close the window.

7. The third step will be created using yet another method. Click on one of the Type Keystroke steps 
and press Ctrl+C on your keyboard to copy it.

8. Now make sure the insertion point (thin red line) is below the second Type Keystroke step (click 
it and drag it down there if not), and press Ctrl+V to paste. You should have three Type Keystroke 
shortcuts now.

9. Configure this third Type Keystroke step by clicking in the “Key(s) to type field” so that it high-
lights then press your keyboard’s Left arrow key. Nothing happened! The arrow keys (among oth-
ers such as Tab Esc and Enter) are navigational keys that need special treatment to be assigned. The 
solution is to hold down your left mouse button, press Left arrow, then release your mouse button.

10. Create and configure a fourth Type Keystroke step using whatever method you like. The key to 
type needs to be Ctrl+V.

11. Your Sequence should end up looking like Figure 3-20 below. Click in the Name field and type a 
suitable name like “Swap Characters”. Give your Sequence a hot key trigger by clicking in the Hot 
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key field and pressing the key combination you want, such as Ctrl+Shift+Up arrow.

 
Figure 3-20: The completed “Swap Characters” Sequence. 

12. Click the Save & Exit button to save your work and close the Sequence window.

Test your sequence:

Open WordPad or Notepad or another text editor and type “wrok”. Now put your cursor between the 
“r” and the “o” and hit the hot key for your new Swap Characters shortcut. QuicKeys transposes the 
letters for you in a flash!

Alternate Solutions

There are a couple of alternate ways to make this Sequence. For instance, rather than having to move 
your cursor back between the transposed letters before triggering your swapping Sequence, it may be 
more efficient to work from the right-hand side of those transposed letters. To use this method, you 
would need to change your first step to a Shift+Left arrow keystroke.
Another use for this type of shortcut is putting quotes around a block of text. If you have a bit of text 
highlighted, the easiest way to put quote marks around that block is to have QuicKeys do Ctrl+X to cut 
the text, enter a quotation mark, press Ctrl+V to paste the text, and enter another quotation mark. This 
technique will work for bracketing highlighted text or data in other ways, such as adding parenthesis or 
opening and closing HTML tags.
You name it, QuicKeys will streamline it!
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QuicKeys Toolbars provide convenient access to your Actions without having to remember the hot key 
that triggers them. In fact you can place all of your QuicKeys Actions on toolbars if you are visually-ori-
ented. You can even choose to Auto-hide your toolbars to preserve space on your screen. And, if you find 
the built-in program toolbars you use on a daily basis a bit limited in their functionality, supplement your 
program toolbars with QuicKeys toolbars.

QuicKeys toolbars have three components: the toolbar itself, the buttons on the toolbar, and a possible hot 
key trigger Action to toggle showing/hiding them.

Toolbar Styles

This section discusses each toolbar style and provides examples of when to use one style over another. 
There are four toolbar styles available for QuicKeys toolbars:

• Click-N-Go  • Dockable  • Floating  • Pop Out

Click-N-Go

A Click-N-Go toolbar closes immediately after you click a button on the toolbar. This type of toolbar 
is useful if you want to preserve screen real estate. For example, if you don’t want to memorize which 
Action starts one of the 15 programs installed on your computer, you can create a Click-N-Go toolbar 
that enables you to start each of these programs by clicking the appropriate button on the toolbar. All 
you have to remember is the hot key that opens the Click-N-Go toolbar. You can then click the ap-
propriate program icon on the toolbar and watch as the toolbar disappears just as the selected program 
opens.

  

Figure 4-1: Click-N-Go Toolbars appear when 
you press their associated hot key and disappear 
as immediately after you click one of the toolbar 
buttons.

Dockable

A Dockable toolbar attaches to an entire side of your screen. This type of toolbar is 
useful when you want to keep your toolbar in the same position whenever you start a 
specific program. For example, if you have several Actions for Microsoft Word, you 
can place them on a program-specific, Dockable toolbar so they are accessible when-
ever Microsoft Word is open. Figure 4-2 at left shows a of a portion of a Dockable 
Toolbar anchored to the right side of the computer screen.
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Figure 4-2
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Auto-hide Dockable Toolbars

You can choose to hide Dockable toolbars by selecting the Auto-hide check box in the Toolbars Setup 
Wizard or Action Properties dialog. When Auto-hide is selected, the Dockable toolbar is hidden from 
view until your cursor is placed near the side of the screen where the toolbar is located.
Each side of your screen supports one Dockable toolbar that uses the Auto-hide feature. By default, 
Dockable toolbars dock to the top of your screen. Consequently, if you try to create a second Dockable/
Auto-hide toolbar without moving your first Dockable/Auto-hide toolbar to a different side of your 
screen, you get an error message.

Moving Dockable Toolbars

You can drag Dockable toolbars from one side of your screen to another. If you drag Dockable toolbars 
away from the side of the screen, they become Floating toolbars.

Floating

A Floating toolbar can be moved anywhere on your screen. This type of toolbar is useful for Actions 
you’ve created to work inside a specific program; you can augment the program’s built-in toolbars with 
your own. For example you could create several Actions to quickly change font and font size in Word 
and place these Actions on a QuicKeys Toolbar.

  

Figure 4-3: Floating Toolbars can be placed 
anywhere on your screen and moved at will. 
They can be shown/hidden via hot key trig-
ger or QuicKeys Menu selection.

Moving Floating Toolbars

You can move Floating toolbars anywhere on your screen. However, if you move them near the side of 
your screen they become Dockable toolbars.

Pop Out

A Pop Out toolbar enables you to save on desktop real estate by popping out from the side of the screen 
only when your mouse moves near the toolbar. Unlike Auto-hide toolbars, multiple Pop Out toolbars 
can be placed on the same side of the screen. When you click a button on a Pop Out toolbar, the toolbar 
retreats back to the side of the screen where it doesn’t interfere with your work.

Moving Pop Out Toolbars

You can move Pop Out toolbars to any edge of your screen by clicking and dragging them.
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Figure 4-4: Pop Out Toolbars show as a 
sliver along the side of your screen until you 
pass your mouse over them, at which point 
they pop out so you can click a button.

Creating Toolbars

Toolbars are created within the Toolbars view of the QuicKeys Editor. You can either select New Toolbar 
from the Create menu or you can right-click in the Personal Toolbars pane and select New Toolbar from 
the resulting contextual menu.

 
Figure 4-5: Two ways to create a new toolbar from the Toolbars view of the QuicKeys editor; 

either select New Toolbar from the Create menu or right click to access a contextual menu.

The Toolbars view of the QuicKeys Editor consists of 3 important areas. The workspace pane in the up-
per left quadrant of the window contains a list of scopes or contexts for any toolbars you have created. In 
Figure 4-5 the Universal scope plus four additional program-specific scopes are apparent. The next impor-
tant area is the Personal Toolbars pane. This displays any toolbars you have created that are in the scope 
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selected in the workspace pane. Finally, the Toolbar Buttons pane shows any buttons you’ve assigned to a 
toolbar that is selected in the Personal Toolbars pane. In Figure 4-5 a toolbar named “Web Site Launcher” 
has been selected and its four buttons are listed in the Toolbar Buttons pane.

Adding Buttons to Toolbars

There are three ways to populate your toolbars with buttons. Obviously you need to create a toolbar be-
fore you add buttons, but once that’s accomplished you have several options for adding them.

Using Action Properties

Every Action you create has a set of tabs at the top of its Action Properties, one of which is the 
Toolbars tab. By switching to this tab you can choose a toolbar or toolbars on which to place a button 
for that Action.

  

Figure 4-6: Switch to the Toolbars 
tab in the Action Properties dialog of 
an action to access a list of existing 
QuicKeys toolbars. Check the box 
next to a toolbar(s) to place a but-
ton representing this Action on the 
toolbar(s).

Using the Toolbar’s contextual menus

Right-clicking on a toolbar reveals a contextual menu with a New Button option.

  

Figure 4-7: Right-click anywhere on a toolbar (except 
on a button!) to reveal the New Button contextual menu. 
This is a quick way to add new buttons without even 
opening the QuicKeys Editor.

❖ Note: Make sure you are right-clicking on the toolbar itself and not on an existing button as this 
activates a completely different contextual menu.

Using Drag and Drop

QuicKeys Actions, files and folders can be added to a toolbar with a simple drag and drop. Just locate 
the Action you want in the QuicKeys Editor and drag it onto an open toolbar and release it. Files and 
folders in the Windows filing system can also be dragged onto an open toolbar and released to create an 
Open File shortcut on the fly as a new toolbar button.
Once you’ve populated a toolbar with buttons you can drag and drop files onto those buttons for added 
power. For example:
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• If you have a File Handler Action on your toolbar that changes the file extension to .doc, you can drag 
a .txt file to the File Handler button to quickly change the file extension.

• Create a Microsoft Word “Open” button. Drag files to this button to open documents in Microsoft 
Word.

Rearranging Toolbar Buttons

You can rearrange toolbar buttons on a toolbar by holding down the Alt key and dragging them to the 
area of the toolbar where you want them displayed. If you want to move an Action menu button, you 
must press the Alt key as you drag the button.

Types of Toolbar Buttons

When you add buttons to a QuicKeys toolbar, you can choose from three different types of toolbar but-
tons: Open File buttons, QuicKeys Action buttons, or Action Menu buttons.

Open File Buttons

Use Open File buttons to open any file you select. For example, you can create an Open File button 
that starts Acrobat Reader. Open File buttons adopt the icon of the file you have chosen to open. There 
are two ways to add an Open File button to a toolbar, using the New Button contextual menu and using 
drag and drop:
• Contextual Menu - Right-click an empty area in a toolbar that is visible and select Open File from 

the New Button submenu that appears. Navigate to the desired file or folder and click Open. The new 
button now appears on the toolbar.

• Drag and Drop - Locate the desired file or folder on your desktop or in your filing system, then click 
and drag it onto a visible QuicKeys toolbar. Release the mouse and the new button appears on the 
toolbar.

QuicKeys Action Buttons

Use QuicKeys Action buttons to trigger QuicKeys Actions you have already created. For example, if 
you have created a QuicKeys Action that reformats selected text, you can put a button that triggers that 
Action on the toolbar.
To add a QuicKeys Action button to your toolbar:
1. Right-click an empty area in a toolbar that is already open on your desktop.
2. Select QuicKeys Action from the New Button submenu that appears.
3. Select an Action from the list that appears and click OK; the toolbar displays the new button.
❖ Note: You can also drag and drop a QuicKeys Action from the Actions view of the main editor win-

dow onto any visible toolbar to add it as a button.
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Action Menu Buttons

Action Menu buttons place special functions on a toolbar in the form of a drop-down menu. QuicKeys 
provides Action Menu buttons so you can access a set of related Actions from a single toolbar button. 
For example, if you add an Advanced Text Tools Action button to your toolbar, you will see a list of 
advanced text formatting options when you click it.

 
Figure 4-8: Place Action Menu buttons on QuicKeys toolbars for quick access to certain types of Actions.

❖ Note: Some types of QuicKeys Actions are not available as Action Menu buttons.
To add an Action Menu button to your toolbar:
1. Right-click an empty area on a QuicKeys toolbar and select Action Menu from the New Button 

submenu that appears.
2. Select an Action from the Add Menu to Toolbar window and click OK. The toolbar displays the 

new Action Menu button with a black triangle in the corner indicating the button displays a menu 
when clicked.

3. To use the Action Menu simply click on its button and select one of the Actions displayed in the re-
sulting list. The Defined Actions and Recent Actions submenus are convenient groupings of related 
Actions you’ve created or used recently. 

Displaying Toolbars

You can display, or trigger, toolbars using one of the following methods:
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• Press the hot key you assigned to an associated Toggle Toolbar Action.
• Use the QuicKeys menu located in the system tray to select the desired toolbar from the Toolbars 

submenu.
• Right-click a toolbar in the Toolbars view of the main QuicKeys Editor and select Show Toolbar from 

the context menu.
• Direct the toolbar to display at a certain time using the Timed Triggers tab in the Action Properties 

dialog.
• Place a Toggle Toolbar button on one of your toolbars that opens another toolbar.

Customizing Toolbars

You can customize the way a toolbar looks by right-clicking it and selecting one of the options that ap-
pears in the context menu. Right-click an empty area of the toolbar to edit the toolbar properties:

Small/Large Buttons - Displays the toolbar icons at either 32x32 or 64x64 pixels.
Show/Hide Button Names - Displays the names of the buttons on a toolbar. This option is only avail-
able if the button size of toolbar is set to Large.
Change Background Color - Changes the background color of the toolbar.
Change Name Color - Changes the text color of the button name if the Show Button Names option is 
selected.
Restore Default Colors - Restores the colors of both the background and the button names to the 
default colors.

Changing the Toolbar Style

• Change Dockable toolbars to Floating toolbars by dragging the Dockable toolbar away from the edge 
of the screen.

• Change Floating toolbars to Dockable toolbars by dragging the Floating toolbar to the edge of the 
screen.

• All other toolbar styles can be changed from the QuicKeys Editor Toolbars view. Right click the 
desired toolbar in the Personal Toolbars pane and selecting Properties from the resulting contextual 
menu. Click the radio button for the desired toolbar type.

Sizing Toolbars

You can resize all but Dockable toolbars by clicking on the corner or edge of the toolbar and dragging. 
You can make toolbars as big or as small as you want. You can even size them so your toolbar buttons ap-
pear in multiple rows.
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❖ Note: If a toolbar is too small for the buttons it contains the toolbar frame becomes a dotted line 
indicating that some buttons are hidden from view. Make the toolbar bigger or user smaller icons to 
rectify this.

Changing Toolbar Scope

Toolbar Scope is the range of operation for a toolbar. For example, you can choose whether a specific 
toolbar displays in only one program, or in all of your programs. You can change the scope of a toolbar 
using the Properties for that toolbar.

Using the Toolbar Properties Dialog

To change the scope of a toolbar using the Toolbar Properties dialog:
1. Go to Toolbars view in the QuicKeys Editor.
2. Right-click one of the toolbars listed on the Personal Toolbars pane.
3. Select Properties from the context menu that appears.
4. In the Toolbar Properties dialog, click the Toolbar Scope tab.
5. In the Scope drop-down list, choose when you want the toolbar to display.

   

Figure 4-9: The Toolbar Properties 
dialog includes a Toolbar Scope. This 
tab allows you to change the scope of 
your toolbar (is it always available or 
only when a certain program is run-
ning?) in the same manner you would 
change the scope of any Action.

Closing Toolbars

There are a variety of methods for closing QuicKeys toolbars, depending on the toolbar’s style.

Dockable

• Use the Auto-hide feature to tuck Dockable toolbars out of the way.
• Right-click the toolbar in the My Toolbars tab and select Hide Toolbar from the context menu that 

appears.
• Right-click the QuicKeys menu in the status area of the task bar and select the toolbar from the 

Toolbars submenu. The check mark that was next to the toolbar name disappears.
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Floating

• Click the close box in the title bar of the Floating toolbar.
• Right-click the toolbar in the My Toolbars tab and select Hide Toolbar from the context menu that 

appears.
• Right-click the QuicKeys menu in the status area of the task bar and select the toolbar from the 

Toolbars submenu. The check mark that was next to the toolbar name disappears.

Click-N-Go

• Click anywhere outside the Click-N-Go toolbar.
• Right-click the toolbar in the My Toolbars tab and select Hide Toolbar from the context menu that 

appears.
• Right-click the QuicKeys menu in the status area of the task bar and select the toolbar from the 

Toolbars submenu. The check mark that was next to the toolbar name disappears.

Pop Out

• Right-click the toolbar in the My Toolbars tab and select Hide Toolbar from the context menu that 
appears.

• Right-click the QuicKeys menu in the status area of the task bar and select the toolbar from the 
Toolbars submenu. The check mark that was next to the toolbar name disappears.

Deleting Toolbars

There are three methods for deleting toolbars:

• Right-click a toolbar and select Delete from the context menu that appears.
• Select a toolbar listed in the Toolbars view of the QuicKeys Editor and select Delete Toolbar from the 

Edit menu.

Adjusting Toolbar Button Size

To change the size of your toolbar buttons, right-click the area of an open toolbar that does not contain 
any toolbar buttons. Choose whether you want to use Small Buttons or Large Buttons from the context 
menu that appears.

Changing Button Icons

QuicKeys uses different button icons for each button type. For example, Open File buttons use the icons 
of the files they open, while QuicKeys Action buttons use the icons of the QuicKeys Actions they trigger. 
If you want to change any of the button icons on your toolbar, you can substitute the default icons with 
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your own custom icons or bitmaps.

Using Custom Icons

There are two types of custom icons: icons present in your other computer programs (such *.exe files, 
*.dll, and *.ico files) and icons you create. The following instructions provide general information on 
selecting any of these icons for your QuicKeys toolbar buttons. For information on creating custom 
icons to add to your toolbar icon collection, see Appendix B near the end of this user guide.
To select custom icons:
1. Right-click a button on an open QuicKeys toolbar.
2. Select Set icon from file.
3. Click the Browse button and navigate to the icon file you want to use.
4. Choose the icon file you want to use and click Open. The contents of the icon file you selected ap-

pear in the Select Icon window.
❖ Note: Once you make use of a custom icon file, that icon displays permanently as an option on the 

Icon File drop-down list.
5. Select an icon from your new icon file and click OK. The new icon appears on the toolbar you 

selected.
❖ Note: If you delete, rename, or move custom icons that are used in toolbars, the toolbar button that 

used that icon displays the default icon.

Using Bitmap Images

Bitmap files use the .bmp file extension, and, unlike icon files, they cannot be sized. Bitmap buttons 
must use the same dimensions that were specified when the bitmap was originally created. The ability 
to add bitmaps to your toolbars enables you to choose from a wide variety of graphics for your toolbar 
buttons, as long as the graphic is proportional to your screen. To select a bitmap file:
1. Right-click a button on an open QuicKeys toolbar.
2. Select Set icon from bitmap.
3. Navigate to the bitmap graphic you want to use. The graphic must use the .bmp extension in the 

file name.
4. Choose the graphic you want to use and click Open. The new icon appears on the toolbar you se-

lected.

Restoring Toolbar Icons

QuicKeys offers a Restore default icon option to remove custom icons from your toolbar buttons. Just 
right-click a button on an open toolbar and select Restore default icon from the context menu that ap-
pears.
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Deleting Toolbar Buttons

To delete a toolbar button, open the toolbar and right-click the toolbar button you want to delete. Select 
Delete Button from the context menu that appears.
❖ Note: If you delete one or more of your Actions from the Actions view of the main QuicKeys Editor, 

any toolbar buttons created to trigger those Actions are still available on their toolbar(s).
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This is the first of a series of chapters whose purpose is to describe the specific Action types QuicKeys 
contains. QuicKeys Tools is a set of Actions that can be found in the main editor’s Create menu. The 
QuicKeys Tools category contains the QuicKeys Controller, Toggle Toolbar, and Variables Actions.

QuicKeys Controller

QuicKeys Controller Actions give you special controls over the QuicKeys program itself. These controls 
allow you to quickly manipulate QuicKeys itself without interrupting your work. The Actions at your 
disposal when you use the QuicKeys Controller include:

• Toggle Recording • Show QuickReference Card • Exit QuicKeys 
• Start Recording  • Enable hot keys and timers • Toggle QuicKeys Status
• Stop Recording  • Disable hot keys and timers • Open QuicKeys Editor

Setting up QuicKeys Controller Actions

There are two ways to create or edit QuicKeys Controller Actions: use the Setup Wizard or use the 
Action Properties dialog. Below are the basic steps needed to create this type of Action using either 
method.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor, click the QuicKeys 
Controller button, and follow the instructions. At the beginning of the Setup Wizard, you are presented 
with options to Create an Action, Edit an Action, Delete an Action, or Create/edit multiple Actions. The 
setup for each of these options is explained within the Setup Wizard.

  

Figure 5-1: The QuicKeys Controller 
Setup Wizard lets you create Actions 
to control QuicKeys itself.

Chapter 5: QuicKeys Tools
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Using the Action Properties Dialog

The Action Properties dialog enables you to edit all of the options within a QuicKeys Action from a 
single window. This capability provides an alternative for users who prefer not to use the Setup Wiz-
ard. The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 36 for more information on this option.
To use the Action Properties dialog to create or edit a QuicKeys Controller Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > QuicKeys Tools > QuicKeys Con-

troller.
2. Choose an option from the Action-specific properties pane of the dialog. The available options are 

discussed in the next section of this chapter.
3.   In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4.   If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use.
5.   Click OK. Your new Action immediately appears in the Actions view.
6.   Close the QuicKeys Editor and press the hot key you selected. The Action-specific option you 

selected will react immediately to the trigger.

    

Figure 5-2: The QuicKeys Control-
ler Action Properties dialog lets you 
create Actions to control QuicKeys 
itself.  
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QuicKeys Controller Options

Below is a description of the Action-specific properties available with the QuicKeys Controller Action.
Open QuicKeys Editor - Opens the QuicKeys Editor.
Show QuickReference Card - Displays the QuickReference Card. The QuickReference Card is 
a window that displays Sequences and Actions along with their hot keys. This can be useful if you 
forget the hot key assigned to a specific Action and want to find it quickly. With the QuickReference 
Card open you can also click on an Action therein to trigger it.
Set status of QuicKeys - Turns QuicKeys hot keys on or off, or toggles between the on and off 
state.

Enable hot keys and timers - Turns QuicKeys hot keys and timers on.
Disable hot keys and timers - Turns QuicKeys hot keys and timers off.
Toggle status - Switches between QuicKeys being on and off.

Set recording status - Starts or stops recording, or uses the same trigger to toggle between the start 
or stop state.

Start recording - Starts recording a Sequence.
Record one action - Puts QuicKeys into recording mode. The next mouse click or key press is 
recorded as a single new QuicKeys Action.
Start recording (disable smart recognition) - Starts recording a Sequence. You should only 
select this option if you are having difficulty using Sequences with a particular program. For 
example, if your Sequence cannot complete a Select Menu Action successfully, you may want 
to choose this type of recording. When smart recognition is disabled, Sequences are composed 
solely of Mouse Click, Window Select, Window Waits, Type Text, and Type Keystroke Actions.
Stop recording - Stops the recording process.
Toggle recording - Starts and stops recording.

Exit QuicKeys - Quits the QuicKeys Engine and the QuicKeys Editor.
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Toggle Toolbar

QuicKeys Toolbars can be scoped to specific programs or universal in nature. Some overlay your windows, some 
hide at the edge of your screen. However, there may be times you need to get a toolbar out of your way, and the 
quicker the better. You can always go to the QuicKeys Menu in your system tray to turn toolbars on and off, but a 
much more convenient way is through the Toggle Toolbar Action. This Action lets you set up a hot key to toggle a 
specific toolbar on and off.

 

Figure 5-3: The Toggle Toolbar Ac-
tion Properties dialog lets you set up 
a hot key to toggle a specific toolbar 
on and off.

Toggle Toolbar Options

The single configurable option for this type of Action is a pop-up list containing each of the QuicKeys 
Toolbars you have created. Simply select the desired toolbar and set a hot key to configure this Action.
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Variables

Variables is one of the more advanced features of QuicKeys. In general they allow you to store, compare, 
and use information gathered on the fly in a multi-step sequence. These variables can be set to remember 
their default values even if you exit and relaunch QuicKeys or reboot your computer.

The Variables Window

Before the Variables Action and its options are discussed it is important to take a look at how QuicKeys 
variables are created. Within the QuicKeys Editor, in Actions view, the View menu contains an item 
named Show Variables...; selecting it will open the Variables window. This window contains all of the 
variables you have created and shows the data they contain along with a description of the data type. It 
also shows the system clipboard as “Clipboard” (the system clipboard can be thought of as a variable 
whose value is whatever you last cut or copied).

  

Figure 5-4: The Variables window displays 
all of the QuicKeys variables you have cre-
ated along with the system clipboard. From 
this window you can create new variables, 
set their value, and save a default value. 
This window updates live so you can watch 
your variables change as your Sequences 
play back.

Variables Window Options

The buttons in the toolbar across the top of the Variables window behave as follows (from left to right):
• New - Click to create a new variable.
• Delete - Select a variable from the list and click this button to delete that variable.
• Reload - Click to reload the default value of a variable selected in the list.
• Save - Select a  variable from the list and click this button to save the current value as default. The 

default is the value that is preloaded into the variable when you exit/restart QuicKeys or reboot your 
computer.

• Save All - Sets the default value of every variable in the list to its current value.

The Equation Tester Window

The Equation Tester window is opened by selecting View > Show Equation Tester... when the QuicKeys 
Editor is in Actions view. This window allows users to test the equations they will be using in their vari-
ables Actions without the need to put them into a working Action. Once you’ve created an equation that 
yields the results you want you can make quick use of it by copying and pasting it into a Variable Action.
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Figure 5-5: The Equation Tester lets you experiment with equations to test their results 

before using them in your Actions. The examples in this figure demonstrate the 
variable type-completion feature (left), and an evaluated equation (right).

Equation Tester Options

The upper pane of the Equation tester window is were you type in your equation for evaluation. If you 
begin typing the name of a defined variable QuicKeys will attempt to auto-complete the variable name 
for you; press tab to accept the suggestion or just keep typing to override the suggested auto-comple-
tion. The lower pane of the window displays the results of an evaluated equation.
The buttons in the toolbar across the top of the Equation Tester window behave as follows (from left to 
right):
• View Variables - Opens the Varibles window when clicked.
• Select Variable - This pop-up list includes the Clipboard and every QuicKeys variable you have cre-

ated. Selecting a variable from this list inserts it into the Equation Tester whereever the cursor is.
• Select Function - Selecting a function from this pop-up list inserts it into the Equation Tester window 

at the cursor location. Functions are explained in a separate document located on the Install CD or in 
the downloaded installation archive file.

• Select Operator - Selecting an operator from this list places it in the Equation Tester window at the 
insertion point.

• Evaluate - Click this button to evaluate the equation. Results are displayed in the lower pane.

Insert Variable

The Variables Action comes in four distinct flavors: Insert variable, Assign variable, Display variable, and 
Compare variable. The Insert Variable Action lets you extract the contents of a variable while a Sequence 
is playing. The contents of the variable are pasted into the front-most document at the insertion point.
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Figure 5-6: The Insert Variable 
Action properties dialog lets you 
choose your variable from a pop-
up list, or build an equation using 
variables, functions, and operators. 
The results of this Action are pasted 
into the front-most document at the 
insertion point.  

Insert Variable Options

• Variable pop-up list - Choose one of your variables or the system Clipboard variable from this list to 
have it pasted into the front-most document at the insertion point when the Action is executed.

• Equation field - Equations placed in this field are evaluated at run time. These equations can contain 
QuicKeys variables, functions, and operators. The buttons above the Equation field are explained in 
the Equation Tester section on page 60.

• Ask for variable or equation - Rather than define this step fully you can instruct QuicKeys to ask at 
run time. If this box checked, QuicKeys will pause playback when this step is reached and ask you 
for the variable or equation you want to use. 

Assign Variable

The Variables Action comes in four distinct flavors: Insert variable, Assign variable, Display variable, and 
Compare variable. The Assign Variable Action lets you change the value of a variable at run time. The 
value you assign can be a plain number or text, the contents of another variable, or the result of an equa-
tion you build.

  

Figure 5-7: The Assign Variable 
Action properties dialog lets you 
set up new values for variables. 
Choose a variable from the pop-up 
list then work within the Equation 
field to define the new value of that 
variable.
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Assign Variable Options

• Variable pop-up list - Choose one of your variables or the system Clipboard variable from this list. 
This variable will be assigned a new value as defined by what you place in the Equation field.

• Equation field - Equations placed in this field are evaluated at run time. These equations can contain 
QuicKeys variables, functions, and operators. The buttons above the Equation field are explained in 
the Equation Tester section on pages 57 & 58.

• Ask for variable or equation - Rather than define this step fully you can instruct QuicKeys to ask at 
run time. If this box checked, QuicKeys will pause playback when this step is reached and ask you 
for the variable or equation you want to use. 

Display Variable

The Variables Action comes in four distinct flavors: Insert variable, Assign variable, Display variable, and 
Compare variable. The Display Variable Action lets you take a peek at the contents of a variable at run 
time. This Action is configured similar to Insert Variable but instead of pasting the variable contents into a 
document it simply displays the value in a small window.

Compare Variable

The Variables Action comes in four distinct flavors: Insert variable, Assign variable, Display variable, and 
Compare variable. The Compare Variable Action lets you test the contents of a variable against another 
variable, a specific numeric value or bit of text, or the results of a function. The result will either be “true” 
or “false” which translate to that step being a success or failure with regard to the step results. This allows 
you to set up logical tests and branching to skip sequence steps or stop a playback when certain variables 
reach specific values.

  

Figure 5-8: The Assign Variable 
Action properties dialog lets you 
set up new values for variables. 
Choose a variable from the pop-up 
list then work within the Equation 
field to define the new value of that 
variable.

Compare Variable Options

• Variable pop-up list - Choose one of your variables or the system Clipboard variable from this list. 
The contents of this variable will be compared to whatever you put in the Equation field.
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• Comparison Operators pop-up list - When comparing the contents of a variable to another variable or 
equation you must choose a comparison operator. In order from top to bottom, the comparison opera-
tors in this list are: Equal to, Less than, Greater than, Less than or equal to, Greater than or equal to,  
and Not equal to.

• Equation field - Equations placed in this field are evaluated at run time. These equations can contain 
QuicKeys variables, functions, and operators. The buttons above the Equation field are explained in 
the Equation Tester section on page 60.

• Ask for variable or equation - Rather than define this step fully you can instruct QuicKeys to ask at 
run time. If this box checked, QuicKeys will pause playback when this step is reached and ask you 
for the variable or equation you want to use. 

Quickeys Variables Functions

QuicKeys Functions are plugins that are used in QuicKeys equations for performing calculations that can 
not normally be done in an equation. For example an equation in QuicKeys can not compute the square 
root of a number, but a QuicKeys Function can. QuicKeys Functions can let you access data from other 
programs or manipulate values from QuicKeys variables and return new values for all kinds of uses in 
QuicKeys or even in other QuicKeys Functions.

Using QuicKeys Functions

QuicKeys Functions are installed at the location “C:\Documents and Settings\<user>\Application 
Data\Startly\QuicKeys\Functions”. You may need to make the folder “Functions” inside the QuicKeys 
folder. After you have installed your functions, re-launch QuicKeys. Your functions will show up in the 
Equation pop-up list that is present above the equation field in the QuicKeys Variable Actions.

Using Variables

A book, or at least a very large pamphlet could be written describing ways to use variables in general, and 
QuicKeys Variables to be specific. Weʼre going to settle for an overview here and an example at the end 
of this chapter.

Users without a programming background may have little idea how variables are supposed to work. The 
premise is that QuicKeys variables are simply containers that you create and then use within multi-step 
shortcuts to hold, modify, and retrieve information as the shortcut plays out. 

Variables can be of great assistance in doing something as simple as pulling several cells worth of data 
from a spread sheet then moving that data into another type of document. For example, assume a spread-
sheet contains four columns containing Name, Address, City, and State and you want to move this data 
into a web form. Normally you would have to copy the contents of a cell, switch to a browser, paste, 
switch back to the spreadsheet, copy a cell, etc. Even using QuicKeys to help with this process doesnʼt 
reduce the inefficiency of switching between apps repeatedly. 



62

Chapter 5 - QuicKeys Tools

However, if you use variables you can copy and collect a whole row of cells into separate variables before 
switching to your browser. Tabbing through the browser fields and pasting the contents of your variables 
in the proper places as you do so is going to mean a huge speed improvement in your shortcut. 

Letʼs extend that example a bit further and assume there are dozens of rows of data to move. Youʼd want 
QuicKeys to go into a loop and copy these rows of data repeatedly until there was no more data to move. 
But how does QuicKeys know when to quit? Variables to the rescue again... Just test the value of your 
“Name” variable whenever you move data into it and if it ever becomes zero or “empty”, QuicKeys can 
branch out to end the shortcut at that point.

Some things to remember

Variables will undoubtedly be a daunting feature to some users, but just experiment and keep the fol-
lowing tips in mind as you do so:
• The Variables window is where you create new variables and assign their initial and default values if 

so desired.
• The Assign Variable shortcut is used to move data into your variables during playback of your Ac-

tions. The data you move into your variables during run time can only come from 4 places, the sys-
tem Clipboard, another QuicKeys variable, the contents of the Equation field, or from the user on the 
fly during playback of the Action.

• The Insert Variable Action is what you use to retrieve the contents of a variable and insert it into 
documents or display it on your screen.

• The Compare Variable Action is the tool you use to test the contents of a variable. The results will 
always be True or False which directly translates to Step Results of Success or Failure. For example, 
you may test to see if the number in one of your variables is larger than the number held in the system 
Clipboard. If your variable is larger, that step is a Success. If your variable is not larger, then that step 
is a Failure.

• Step Results are the key to making logical decisions with the results of your variable comparisons. 
For example, be it a successful or failed step, Step Results can stop an Action or cause it to jump to a 
non-sequential step.
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Example of Variables Usage

This example will explain a little about using variables in general along with using QuicKeys Variables in 
particular. This is an advanced example so you may need to make yourself more familiar with the product 
if the QuicKeys concepts here are not clear.

The Problem

“I wish I could copy two or three separate items from one document, then paste them into another docu-
ment in the order that I copied them. Yet at other times I would like to copy separate items from one docu-
ment then paste them into another document in reverse order. Is this something QuicKeys Variables can 
do?”

The Solution

The solution to this problem is to make use of a “stack” of variables that you can move data into and out 
of with a set of copy/paste hot key triggers. Copying new data into the top of the stack is called “pushing” 
it onto the stack. Grabbing and pasting data from the top of the stack is called “popping”, while grab-
bing and pasting data from the bottom of the stack is called “pulling”. Our solution will consist of three 
QuicKeys Sequences, one to Push copied data onto the top of the stack, one to Pop copied data from the 
top of the stack, and one to Pull copied data from the bottom of the stack. 

Assume the user has a list of three names they want to copy into their stack variables. First they will 
highlight a name, press F5 to copy it to a stackitem variable, highlight a second name and press F5 again 
copy it to the next stackitem variable, and finally highlight the third name and press F5 one more time to 
copy it to the last stackitem variable. Use of another “counter” variable acts as a pointer to tell QuicKeys 
which stackitem variable is current and which should be filled next. The following table demonstrates the 
concept. 

Table 5-1: Initial stackitem variable contents, and their contents as data is “pushed” onto the stack.
Variable 

Name
Initial 

Contents
Contents after 

first Push
Contents after 
second Push

Contents after 
third Push

stackitem3 - - - “Ted”
stackitem2 - - “John” “John”
stackitem1 - “Bill” “Bill” “Bill”

stackposition 0 1 2 3
 

Next let’s assume the user wants to paste data out of their stack in the order the data was copied in; this 
would mean pasting “Bill”, “John”, then “Ted” in that order. Pressing F6 will paste the contents of stack-
item1 (the “bottom” item in the stack) into a document, shuffle the contents of stackitem3 to stackitem2 
and the contents of stackitem2 to stackitem1, and finally change the positiion counter. Pressing F6 again 
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will shuffle the variable contents down the stack again and decrement the position counter yet again. The 
following table demonstrates the concept.

Table 5-2: Variable contents are shuffled down the stack as items are “pulled” from the bottom.
Variable 

Name
Initial 

Contents
Contents after 

first Pull
Contents after 

second Pull
Contents after 

third Pull
stackitem3 “Ted” - - -
stackitem2 “John” “Ted” - -
stackitem1 “Bill” “John” “Ted” -

stackposition 3 2 1 0
 
Now let’s assume the user wants to paste data out of their stack in reverse order that it was copied in. This 
would mean pasting “Ted”, “John”, and “Bill” in that order. Pressing F7 will paste the contents of stack-
item3 (the “top” item in the stack) into a document and decrement the position counter. Pressing F7 again 
will paste the contents of stackitem2 and futher decrement the counter. The following table demonstrates 
the concept.

Table 5-3: Variable contents are “popped” from the stack in reverse order that they were “pushed” on. 
Variable 

Name
Initial 

Contents
Contents after 

first Pop
Contents after 

second Pop
Contents after 

third Pop
stackitem3 “Ted” - - -
stackitem2 “John” “John” - -
stackitem1 “Bill” “Bill” “Bill” -

stackposition 3 2 1 0

How To

The tutorials in this manual will generally walk a user through creating each step in a QuicKeys Action 
or Sequence. However, due to the size and complexity of this example, it is an exception. Instead of a 
step by step tutorial, screenshots and general comments on the creation of the necessary sequences will 
be provided here. The actual Sequences will be provided on the installer CD or installer archive file as 
importable Quickeys Actions.

Set up the variables

Before you create/use Sequences containing Quickeys Variables steps, you need to set up the variables 
called by those Actions. Figure 5-9 shows the variables necessary for this example. To create these 
variables open the Variables window and simply click on the button that looks like a calculator and 
then click on the new variable to change its name. You can also click on the value of a variable to edit 
the value, but that isn’t necessary here, default values are fine.
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Figure 5-9: Open the Variables window by 
selecting View > Show Variables while in 
the QuicKeys Editor in Actions view. Create 
new variables by clicking on the leftmost 
button in the toolbar; rename new variables 
by clicking their name; change the value of a 
variable by clicking the current value.

Set up or import the Push onto Stack sequence

The “Push onto Stack” sequence can be found either on the installer CD or the installer archive in the 
following location: CD:\Documentation & Extras\Variables Example Actions.qkx. Import it from there 
or read along and build it yourself if you’re feeling confident. Appendix E describes importing Actions.

 

Figure 5-10: The Push onto Stack 
Sequence is used to copy highlighted 
data onto the system clipboard 
then move that data into the proper 
QuicKeys variable:

Step 1 copies the data to the system 
clipboard. 

Step 2 checks the value of the counter 
variable “stackposition”. If the value 
is “0” then the data on the clipboard 
is moved into stackitem1 and the 
counter is advanced to “1”.
 
Steps 5 and 8 act like step 2 but they 
move the clipboard data into stack-
item2 and stackitem3 respectively.
 
Step 11 determines if the stack is full. 
We only have 3 stack slots so when 
the counter reaches 3 we need to be 
warned.
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The logic and Action types used to make this Sequence are as follows:

Step # Action Type Description On Success On Failure
1 Type 

Keystroke
Simulates pressing Ctrl+C to copy highlighted data 
from a document into the system clipboard.

proceed to 
next step

stop and 
notify

2 Compare 
Variable

Compares the contents of stackposition to “0”. proceed to 
next step

jump to 
step 5

3 Assign 
Variable

Move the contents of the system clipboard into the 
first slot of the stack (stackitem1).

proceed to 
next step

stop and 
notify

4 Assign 
Variable

Increment the counter (stackposition) from 0 to 1 
because we now have one item in our stack.

done! (stop 
sequence)

stop and 
notify

5 Compare 
Variable

Compares the contents of stackposition to “1”. proceed to 
next step

jump to 
step 8

6 Assign 
Variable

Move the contents of the system clipboard into the 
second slot of the stack (stackitem2).

proceed to 
next step

stop and 
notify

7 Assign 
Variable

Increment the counter (stackposition) from 1 to 2 
because we now have two items in our stack.

done! (stop 
sequence)

stop and 
notify

8 Compare 
Variable

Compares the contents of stackposition to “2”. proceed to 
next step

jump to 
step 11

9 Assign 
Variable

Move the contents of the system clipboard into the 
third slot of the stack (stackitem3).

proceed to 
next step

stop and 
notify

10 Assign 
Variable

Increment the counter (stackposition) from 2 to 3 
because we now have three items in our stack.

done! (stop 
sequence)

stop and 
notify

11 Compare 
Variable

Compares the contents of stackposition to “3”. proceed to 
next step

stop and 
notify

12 Message Warn the user that all stack slots are filled. done! (stop 
sequence)

stop and 
notify

❖ Note: Step Results are the key to making variable comparisons work. If a comparison is true, the 
step is a “success” thus the “If step succeeds” results are followed. If a comparison is false, the “If 
step fails” results are followed. Double-click any step in a Sequence to edit its properties including 
step results handling.

Set up or import the Pull from Bottom of Stack sequence

The “Pull from Bottom of Stack” sequence can be found either on the installer CD or the installer ar-
chive in the following location: CD:\Documentation & Extras\Variables Example Actions.qkx. Import 
it from there or read along and build it yourself if you’re feeling confident. Importing instructions are 
found in Appendix E of this manual.
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Figure 5-11: The Pull from Bottom 
of Stack Sequence is used to deter-
mine the oldest item in the stack and 
insert its contents into a document:

Step 1 checks the value of the coun-
ter. If it is “0” the stack is empty so 
no “pull” can take place. 

Step 3 checks the value of the counter 
variable “stackposition”. If the value 
is “1” then the data in stackitem1 
inserted into your document and the 
counter is decremented to “0”.
 
Steps 6 and 10 act like step 3 but 
they insert data from stackitem2 and 
stackitem3 respectively.
 
Steps 8, 12 and 13 shuffle data down 
from stackitem3 to stackitem2 and 
stackitem2 to stackitem1. When you 
pull data from the bottom of the stack 
each stackitem above needs to “drop 
down” to the next slot.

 

The logic and Action types used to make this Sequence are as follows:

Step # Action Type Description On Success On Failure
1 Compare 

Variable
Compares the contents of stackposition to “0”. proceed to 

next step
jump to 
step 3

2 Message Warn the user that all stack slots are empty. done! (stop 
sequence)

stop and 
notify

3 Compare 
Variable

Compares the contents of stackposition to “1”. proceed to 
next step

jump to 
step 6

4 Insert 
Variable

Paste the contents of stackitem1 into the document. proceed to 
next step

stop and 
notify

5 Assign 
Variable

Decrement the counter (stackposition) from 1 to 0 
because we now have no items in our stack.

done! (stop 
sequence)

stop and 
notify
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6 Compare 
Variable

Compares the contents of stackposition to “2”. proceed to 
next step

jump to 
step 10

7 Insert 
Variable

Paste the contents of stackitem1 into the document. proceed to 
next step

stop and 
notify

8 Assign 
Variable

Move the contents in slot 2 of our stack down to slot 
1 since the contents of slot 1 have been “pulled”.

proceed to 
next step

stop and 
notify

9 Assign 
Variable

Decrement the counter (stackposition) from 2 to 1 
because we now have 1 item in our stack.

done! (stop 
sequence)

stop and 
notify

10 Compare 
Variable

Compares the contents of stackposition to “3”. proceed to 
next step

stop and 
notify

11 Insert 
Variable

Paste the contents of stackitem1 into the document. proceed to 
next step

stop and 
notify

12 Assign 
Variable

Move the contents in slot 2 of our stack down to slot 
1 since the contents of slot 1 have been “pulled”.

proceed to 
next step

stop and 
notify

13 Assign 
Variable

Move the contents in slot 3 of our stack down to slot 
2 since the contents of slot 2 have moved to slot 1.

proceed to 
next step

stop and 
notify

14 Assign 
Variable

Decrement the counter (stackposition) from 3 to 2 
because we now have 2 items in our stack.

proceed to 
next step

stop and 
notify

 
The third Sequence, “Pop from top of stack” works in a simlar way, but it inserts the most recently cop-
ied data into your document. The sequence to create it is a bit simpler than “Pull from bottom of stack” 
and so will not be ditailed here.

Alternate Solutions

You may find you need more slots in your data stack. You can easily add more by adding more stack-
item variables to the Variables window. You’d also need to adjust your Push, Pop, and Pull sequences 
by adding steps to test for and handle stackposition values beyond 0 to 3.
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The QuicKeys Type Text, Type Date/Time, Advanced Text Tools, and Special Characters Actions save 
you time by typing the information you need with a QuicKeys trigger. This chapter provides instructions 
for using these Actions to type text, type the date and time in a specified format, insert symbols and inter-
national characters in documents, reformat selected text, and much more.

Using Advanced Text Tools

The Advanced Text Tools Action is useful when you want to manipulate blocks of text. For example, you 
can use this Action to eliminate those pesky quote marks from your E-mail messages before you forward 
the message to another person. The tasks, or Actions, available using the Advanced Text Tools include:

 • Reformat Text  • Uppercase  • Lowercase  • Title Case
 • Quote Text  • Toggle Case  • Strip Quote Marks

Setting up Advanced Text Tools Actions

There are two ways to create and edit QuicKeys Advanced Text Tools Actions: use the Setup Wizard or 
use the Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor, click the Advanced 
Text Tools button, and follow the instructions. At the beginning of the Setup Wizard, you are presented 
with options to Create an Action, Edit an Action, Delete an Action, or Create/edit multiple Actions. The 
setup for each of these options is explained within the Setup Wizard. 

 

Figure 6-1: This dialog appears when you 
click the Advanced Text Tools button in the 
Setup Wizards view and choose to create or 
edit an Advanced Text Tools Action.

Chapter 6: Typing with QuicKeys
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Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit an Advanced Text Tools Action, follow these steps:

  

Figure 6-2: Setting up an Advanced 
Text Tools Action 
using the Action Properties dialog.  

 

1. Go to Actions view in the QuicKeys Editor and select Create > Text Tools > Advanced Text Tools.
2. Select an Action from the Action drop-down list.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use. For example, press the Alt key, the Control key and the R key simultaneously.
❖ Note: This Action is also a good candidate for an Action Menu toolbar trigger. See page 46 for 

more information on Action Menu toolbar buttons.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and open a word processing program. Select a block of text and press 

the hot key you assigned to this Action. The block of text you selected changes, depending on what 
type of text Action you chose.
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Advanced Text Tools Options

This section describes the Action-specific properties available with the Advanced Text Tools Action.
Reformat text - Removes carriage returns and white space from selected text. This is especially useful 
for people who want to copy text from a Web page or an E-mail message.
Quote text - Inserts a specified character at the beginning of each line of selected text. This option is 
useful when you want to forward a message from a client to your manager and you need to distinguish 
your comments from the customer’s comments.

Quote - The character you specify for the Quote Text option. You can specify up to eight characters 
in this field.
Characters per line - The number of consecutive characters the Quote Text option counts before 
inserting a carriage return.

Strip quote marks - Deletes the quote character inserted at the beginning of each line of selected text. 
This option is useful when E-mail reply text needs to be copied to a word processing document.
Uppercase - Converts all selected text to uppercase characters. For example, the sentence you just read 
would be transformed to: “CONVERTS ALL SELECTED TEXT TO UPPERCASE CHARACTERS.”
Lowercase - Converts all selected text to lowercase characters. For example, the sentence you just read 
would be transformed to: “converts all selected text to lowercase characters.”
Title case - Converts all selected text to title case characters. For example, the sentence you just read 
would look like this after selecting it and triggering the Title Case option: “Converts All Selected Text 
To Title Case Characters.”
Toggle case - Converts lowercase text to uppercase text and vice versa.
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Using Quick Type

With Quick Type, you can specify typed abbreviations for longer words, names, or phrases up to 10,000 
characters in size. All you need to do is build a glossary of the words you use and then choose which 
abbreviations you want to have to recall them. When an abbreviation key or keys are followed by a tab, 
space, or return key, the abbreviation is replaced by the word or name you specified in the Quick Type Ac-
tion. For example, you could type QK followed by <spacebar> and the word “QuicKeys” would be typed 
into your document.

  

Figure 6-3: When Quick Type is 
active the Quick Type menu icon 
appears in the dock. Quick Type can 
be controlled from this menu.

❖ Note: For best performance, limit Quick Type text to 2,000 characters or less.

Setting up Quick Type Actions

There are two ways to create and edit QuicKeys Quick Type Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Quick 
Type button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the 
Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Action, or 
Create/edit multiple Actions. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Quick Type Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Text Tools > Quick Type.
2. Select an Action from the Action drop-down list.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. Assign a trigger to the Action.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor.
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Figure 6-4: The Action Properties dialog for the Quick Type class of Actions. 

Quick Type Options

This section describes the Action-specific properties available with the Quick Type Action.
Enable Quick Type - Turns on the Quick Type feature. When Quick Type is enabled, the Quick Type 
icon appears in the System Tray. Right-click the Quick Type icon in the Tray to display the Quick Type 
menu.
Disable Quick Type - Turns off Quick Type functionality.
Toggle Quick Type - Alternately enables and disables Quick Type functionality.
Edit Quick Type glossary - Opens the Quick Type Glossary window (shown in Figure 6-5) where you 
can edit, delete, or add new items to your collection.

The Quick Type Glossary

The Quick Type glossary contains all the words, phrases, or paragraphs you have set up to type when 
you trigger a Quick Type Action.

To add text to your glossary:
1. Click the Edit glossary button in the Quick Type Setup Wizard or Action Properties dialog. If 
Quick Type is active you can also access the glossary through the Quick Type menu in the Tray.
2. In the Quick Type Glossary window, click the Add button.
3. In the Edit Glossary Entry dialog, specify the text key that will trigger the Action, the application 
(scope) in which the Action will occur, and the text you want the Action to type.
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4. Click OK to return to the Quick Type Glossary window.
5. Click Done in the Quick Type Glossary window when you are finished.

 
Figure 6-5: The Quick Type glossary window contains a listing of each abbreviation 

you’ve set up. Clicking the Add or Edit buttons open the selected item for editing. 
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Special Characters

The Special Characters Action is useful when you want to type a specific symbol or international char-
acter with a trigger you specify. International symbols and characters are the accents, diacriticals, and 
special alphabetic characters required for punctuation and non-English words.

For example, if you wanted to type a trademark symbol (™), you would usually have to press Alt+0153. 
This is a lengthy shortcut key to remember, especially if you need to remember several of these types of 
“shortcuts.” QuicKeys makes it much easier to use special characters by providing a method for assign-
ing simple triggers to the characters you need to use. For instance, you can use QuicKeys to make Ctrl+M 
type the trademark symbol rather than using Alt+0153.

Setting up Special Characters Actions

There are two ways to create or edit QuicKeys Type Text Actions: use the Setup Wizard or use the Ac-
tion Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the 
QuicKeys Editor and click the Special Characters button. Read 
the pages of each wizard dialog and follow the instructions. At the 
beginning of the Setup Wizard, you are presented with options to 
Create an Action, Edit an Action, or Delete an Action. The setup 
for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 34 for more information. To use the Action Properties dialog 
to create or edit a Special Characters Action, follow these steps:

1. Go to Actions view in the QuicKeys Editor and select Create > Text Tools > Special Characters.
2. Select the font you want to view.
3. Select the character you want to type.
4. In the General tab of the Action Properties dialog, type a name for this Action in the Name box.
5. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use.
6. Click OK. Your new Action appears in the Actions view.
7. Close the QuicKeys Editor and open a word processing program. Position your cursor in the docu-

ment and press the hot key you assigned to this Action. The special character you specified is typed 

Figure 6-8: QuicKeys can display a 
pop-up table of special characters for 

quick access in any program.
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into the open document.

 
Figure 6-9: Setting up a Special Characters Action through the Action Properties dialog.

Special Characters Options

This section describes the Action-specific properties available with the Special Characters Action.
Sample font - Changes the symbols based on the selected font. The font is only for sample viewing 
and locating the character you want; the character you select will be inserted using the font already 
chosen in the receiving program.
Select the character to type - Simply click which character you would like to type using this Action. 
Notice that uppercase and lowercase characters are listed separately.
Select character from a popup list - Choose this option when you want a table of special characters to 
appear when you trigger your Special Characters Action. For example, if you are typing a letter to your 
business partner in France and you trigger this option, you can select the international character used in 
his name from the character table. The table disappears and the international character is automatically 
inserted into your letter.
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Typing the Date and Time

The Type Date/Time Action is useful when you want to insert the date and/or time into documents. For 
example, you can use this Action to insert the date and time in your weekly reports.

Setting up Date/Time Actions

There are two ways to create and edit QuicKeys Type Date/ Time Actions: use the Setup Wizard or use 
the Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Type 
Date/Time button. Read the pages of each wizard dialog and follow the instructions. At the beginning 
of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Ac-
tion, or Create/edit multiple Actions. The setup for each of these options is explained within the Setup 
Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Type Date/Time Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Text Tools > Type Date/Time.
2. Select the Date/Time format you want to use from the Format drop-down list.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

Figure 6-10: Setting up a Type 
Date/Time Action through the Action 
Properties dialog. This Action can type 
the current Date and/or Time for you in 
literally any desired format.
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You can use the assigned Action name or type a different one.
4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu 

check box.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor.
7. Open a document in a word processing program.
8. Trigger the Type Date/Time Action you created. The date and time you specified is typed into the 

open document.

Type Date/Time Options

This section describes the Action-specific properties available with the Type Date/Time Action.
Format - This option is available in the Action Properties dialog. The Format drop-down list displayed 
in this dialog contains several different formats you can choose from when you create a Date/Time Ac-
tion. When you select a format, a sample of how that format will look appears in the Sample field.

Date/Time Abbreviation Meaning
mm month (numeric)
dd day (numeric)
yyyy year (four digit)
dow day of week
hh hour
mm minute
ss second
ap AM/PM
24 hour 24 hour clock or military time

Custom Format - If you select Custom Format from the Format list, the Format Builder button is 
enabled.
Custom Format Builder - Clicking the Format Builder button in either the Setup Wizard or the Action 
Properties dialog displays a Custom Date/Time Builder dialog. Select a format from the left column of 
the window and click the Add button to move it to the right column. Rearrange the order of the selected 
formats using the Up and Down buttons. Click the Type in ALL CAPS check box to capitalize all your 
date and time characters.
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Figure 6-11: Choose from many built in Date/Time formats or fully 

customize your own through the Custom Date/Time Builder. 

❖ Note: When using the Custom Date/Time Builder you must specify commas, colons, dashes, slashes, 
and spaces in your formats. You can preview what your custom format will look like by checking the 
Example field in the lower right corner of the custom format builder window.

If you combine these custom formats in the 
Custom Date/ Time Builder...

Your Date/Time Action types some-
thing similar to this...

Full month name+space+Day of 
month+space+Two digit year+space+slash+space+
Hour in 12hr format+space+Minute as number

July 04 05 / 03 45

Full weekday name+colon+space+Ab
breviated month name+space+Day of 
month+colon+space+Four digit year

Sunday: July 04: 2005

Hour in 12hr format+colon+Minute as 
number+colon+Second as number+space+AM/PM 
indicator+space+slash+space+Time zone

03:51:27 PM / Central Daylight Time

Standard Formats - This radio button is available in the Setup Wizard. The scroll list displays the 
formats you can choose from when you create a Date/Time Action. When you select a format, a sample 
of how that format will look displays at the bottom of the wizard screen.
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Typing Text

The Type Text Action is useful when you want to type frequently-used text with a simple trigger. For ex-
ample, you can use this Action to type your signature line in E-mail messages or to enter common infor-
mation into databases.

Setting up Type Text Actions

There are four ways to create QuicKeys Type Text Actions: use the Setup Wizard, use the Action Prop-
erties dialog, use drag and- drop functionality, or cut and paste.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Type Text 
button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the Setup 
Wizard, you are presented with options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Actions view to create or 
edit a Type Text Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Text Tools > Type Text.
2. Type the text you want to use when you trigger this Action.
❖ Note: Press Ctrl+Tab to insert a tab in the text you type.
❖ Note: The text box can hold up to 10 KB of text (approximately 10,000 characters).
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use. For example, press the Alt key, the Control key, and the S key simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and open your E-mail program. Position your cursor in the document 

and press the hot key or other trigger you assigned to this Action. The text you specified is typed 
into the open document.
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Figure 6-12: Store frequently used text 
in a Type Text Action. Text 
can be edited within the Action Proper-
ties dialog (shown) or 
within the appropriate Setup Wizard.

Using Drag-and-Drop Functionality

You can select text from one window and drag-and-drop it in the QuicKeys Editor to create a Type 
Text Action. When you drop the selected text onto one of the Editor views, the Action Properties dialog 
appears. The text you dropped onto the QuicKeys Editor appears in the Action-specific properties area 
of the dialog. You can edit the text in this dialog if desired, then you can assign the Type Text Action 
a trigger, such as a hot key or a place on an existing toolbar. Click OK in the Action Properties dialog 
and you are finished creating your Type Text Action.

Cutting and Pasting Text

You can cut selected text from one window and paste it into the Setup Wizards or Actions views of the 
QuicKeys Editor. To create a Type Text Action using cut and paste:
1. Select a block of text.
2. Copy it to the Clipboard.
3. Right-click in the Setup Wizards view, the My Keyboard tab, or the Actions view of the QuicKeys 

Editor and select Paste from the context menu that appears. A new Type Text Action appears in the 
Actions view of the QuicKeys Editor. You must assign the Type Text Action a trigger before you 
can use it.
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All computer users must learn how to manipulate files and folders early in their computer experience. 
Navigating through countless directories searching for that one file soon becomes second nature out of 
necessity, but such tasks can also become quite time-consuming. QuicKeys can automate these tedious 
processes for you with Actions such as Batch Processor, File Handler, Folders, Open, Recent Files, and 
Zip Files.

Batch Processor

The Batch Processor Action runs a QuicKeys Sequence on a group of files. If you routinely perform the 
same Sequence on multiple files, you should consider creating a Batch Processor Action to automate the 
process. For example, you can convert a group of graphics from BMP to GIF format or automatically 
change the margins and font size of multiple documents with a single Batch Processor Action.

Setting up a Batch Processor Action

Batch Processor Actions use QuicKeys Sequences to process multiple files. You should be familiar 
with creating QuicKeys Sequences before using the Batch Processor Action.
1. Create or choose a source folder that contains all of the files to be processed.
2. Create or choose a destination folder if you want the processed files to be saved in a different loca-

tion.
3. Open the program that will be used to process the files.
4. Open one of the files to be processed.
5. Create a QuicKeys Sequence that includes all of the steps required to process the file.

• You should begin your Sequence immediately after the file is opened. Do not include steps that 
open the program or file.

• Be sure to include a step that saves the file to the destination folder.
6. Test your Sequence to verify that it works properly.
7. Create your Batch Processor Action. Go to Actions view in the QuicKeys Editor and select Create 

> File & Folder Tools > Batch Processor.
8. Specify the source folder that contains the files to be processed. This is the same folder you created 

in Step 1. You can also choose any of the following options:
• Backup source folder - Creates a backup folder of the source files in the same location as the 

source folder.
• Skip read-only files - Locked files will not be processed.
• Include sub-folders - All files in the source folder and in sub-folders will be processed.

9. Select the application used to process the files.
10. Choose the QuicKeys Sequence you created in Step 5.

Chapter 7: Files & Folders
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11. You can also choose to show the results of a batch processing job. The results provide information 
on the number of files processed and the number of files skipped. A file may be skipped when it is 
busy or cannot be opened by the application.

Show results window upon completion - Displays a window with the processing results when the 
batch processing job is completed.
Log results to a file - Saves the batch processing job results to a .log file in the same location as the 
source folder.

 
Figure 7-2: The Batch Processor Action allows you to select one of 

your Sequences and apply it to a folder full of files.

Batch Processor Guidelines

Remember the following guidelines when you create a QuicKeys Sequence for your Batch Processor 
Action:
• Do not include steps in your Sequence that open the program or files; Batch Processor performs these 

actions as part of its standard operation. You should begin your Sequence immediately after the file is 
opened.

• Batch Processor Actions may not work smoothly with programs that display splash screens or infor-
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mational dialogs when launched. For example, some programs display a “Tip of the Day” window on 
startup. To avoid conflicts with Batch Processor, you should turn these types of displays off.

• You should begin your Sequence with a Pause Action.
• Make sure your Sequence contains a step that saves the file.
• You should save your processed files in different location than the source folder.
• Test your Sequence before using it in the Batch Processor Action.
• Some programs will launch multiple times during a Batch Processor Action. If this happens, add a 

step to the end of your Sequence to exit the program.
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File Handler

The File Handler Action is useful when you want to rename, move, or edit the attributes of selected files. 
Attributes can be anything from read/write access to file names. This feature is extremely valuable if you 
ever work with large batches of files.

For example, some Web sites make heavy use of scanned or digital photographs. Often, these are deliv-
ered in large batches to webmasters to be posted on the Web. QuicKeys makes it possible to rename these 
images en masse with numerical or alphabetical modifiers, so that files named 001.jpg, 002.jpg, etc., can 
be renamed chicago001.jpg, chicago002.jpg, etc. This helps bring order to the batch of images.

Additionally, files can be locked and unlocked by QuicKeys with a single hot key or mouse click. This is 
valuable when you want to lock a batch of original images to ensure that modifications are made only to 
the copies. All of the tasks, or Actions, available with File Handler include:

• Move   • Delete   • Copy   • Rename
• Set attributes  • Set extensions  • Open with

Setting up File Handler Actions

There are two ways to create or edit QuicKeys File Handler Actions: use the Setup Wizard or use the 
Action Properties dialog. When you are setting up File Handler Actions, you can use wildcards (such 
as * and ?) in the Specified file or folder text box.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the File Han-
dler button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the 
Setup Wizard, you are presented with options to Create an Action, Edit an Action, or Delete an Action. 
The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information To use the Actions Properties dialog to 
create or edit a File Handler Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > File & Folder Tools > File Han-

dler.
2. Choose an option from the Action-specific properties pane of the dialog. For example, set attribute  

Read-only to “on”.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 
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you want to use. For example, press the Shift key, the Control key, and the S key simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Select a group of files or folders and press the hot key or other trigger you assigned to this Action.

Triggering File Handler Actions

After you have specified your File Handler options, you can trigger your File Handler Actions several 
ways:

• You can right-click any file on your hard drive and select a File Handler Action from the context 
menu that appears. A File Handler Action is only available from a context menu when you have cre-
ated one using the QuicKeys Editor.

• If you have a File Handler Action Menu on a QuicKeys toolbar, you can drag files to the Action Menu 
toolbar button to move or copy the files, set the file extension, etc.

• You can press the hot key you assigned to the File Handler Action to trigger it.
• You can set up a timed trigger to start the File Handler Action.
• You can place File Handler Actions in the QuicKeys menu and select the Action from the menu.

  

Figure 7-2: This dialog appears when 
you click the File Handler button in the 
Setup Wizards view and choose to cre-
ate or edit a File Handler Action.

File Handler Options

Below is a description of the Action-specific properties available with the File Handler Action.

Set attributes - Alters the current selection or the specified file or folder. You can change one or many 
file and folder attributes such as read-only, hidden, system, archive, date, or time. Select Read-only so 
files cannot be edited. Choose Hidden to hide the selected file or folder. Select System to set the file or 
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folder to one that is exclusively used by the operating system. Select Archive to mark the file or folder 
for backup or removal.
Set extension - Appends a specified extension to the file names of currently selected or pre-specified 
files and folders. File extensions are the three-characters appended to selected files. Changing file ex-
tensions is useful when you want the selected file to be recognized by a different program.

Ask for extension... - Prompts you for a file extension when you trigger the Set extension Action. 
You must supply an extension composed of up to three characters when the prompt appears. For 
example, you would type ico and click OK if you wanted the selected files to be recognized as icon 
files.

❖ Note: You do not have to type the period character when specifying the file extension; QuicKeys 
automatically inserts it.

 
Figure 7-3: Four example views of the File Handler Action Properties window representing 

(clockwise from upper left) File Copy, Rename, Set Extension, and Move. 

Move - Moves the current selection or pre-specified files or folders to a destination you specify.
If using wildcards, ignore subfolders - Directs QuicKeys not to move subfolders if a wildcard is 
used in the folder name. A wildcard is a character, such as an asterisk (*) or a question mark (?) that 
can be used to represent one or many characters.
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Move To - Moves the selected files or folders to one of the locations specified in the Move drop-
down list. Select To Windows Desktop, Up one folder, Out of all folders, and To specified folder,.
Browse - Specifies where the files will be moved. The location displays in the Folder text box. This 
option is only available when the To specified folder option is selected in the Move list.

❖ Note: Be careful when you choose to move large batches of files to the root level of your hard 
drive. Due to the way the Windows operating system stores filenames, you may run into a character 
limit if you copy files with long file names to the root level of your drive.

Copy - Moves the current selection or pre-specified files or folders to one of the locations specified in 
the Copy drop-down list. Select To Windows Desktop, Up One Folder, Out of All Folders, or To Speci-
fied Folder.

If using wildcards, ignore subfolders - Directs QuicKeys not to move subfolders if a wildcard is 
used in the folder name. A wildcard is a character, such as a question mark (?) or an asterisk (*) that 
can be used to represent one or many characters.

Rename - Renames the currently selected or pre-specified files or folders using the naming conven-
tions you choose. A quick way to batch rename large numbers of files. Renaming options include:

Prefix Text - Places user defined text at the beginning of the names of all selected files or folders. 
Example: image01.jpg prefixed with “vacation_” becomes “vacation_image01.jpg”
Prefix Variable - Places one of four variable sequences at the beginning of the names of all selected 
files or folders. Example: A file named “image.jpg” prefixed with the variable range “000...999” 
becomes “000image.jpg”
Variable & Text - Replaces the entire name of all selected files or folders with one of four variables 
plus user defined text. Example: if you choose the AAA...ZZZ variable sequence and enter “_ar-
chive“ for a file named “filename.zip”, the name becomes “AAA_archive.zip“.
Text & Variable - Replaces the entire name of all selected files or folders with user defined text plus 
one of four variables. Example: if you enter “archive_“ and choose the 000...999 variable sequence 
for a file named “filename.zip”, the name becomes “archive_000.zip“.
Append Text - Places user defined text at the end of the names of all selected files or folders. Exam-
ple: A file named “image01.jpg” appended with “_vacation” becomes “image01_vacation.jpg“.
Append Variable - Places one of four variable sequences at the front of the names of all selected files 
or folders. Example: A file named “image.jpg“ appended with the variable range “000...999“ be-
comes “image_000.jpg“.
Fixed Name - Replaces the entire name of the selected file or folder with a user defined name.

Delete - Deletes currently selected or pre-specified files or folders. You can choose to move files/fold-
ers to the Recycle Bin or you can choose to delete them permanently.
Display “Open with...” dialog - Displays the Windows “Open With” dialog for the currently selected 
file or pre-specified file. For example, this option may be useful for text files that you alternately open 
in more than one text editor, such as WordPad and Microsoft Word.
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Folders

The typical computer user deals with several if not dozens of folders each day. Maneuvering to open or 
save a file within the Open and Save dialogs requires either a lot of mouse movement or keyboarding 
QuicKeys chops through this productivity killer by allowing you to set up shortcuts to directories. With 
the press of a hot key you can move deep into the directory hierarchy and save countless clicks.

The Folders Action, allows you to choose between the following pre-defined and user-defined folders dur-
ing the course of your work:

Pre-defined Actions

• Windows folder   • Favorites folder  • Recycle Bin
• Windows Temporary folder • Application Data folder • Printers
• Windows Desktop folder  • Up one folder level  • Control Panels
• My Documents folder  • Network Neighborhood • My Computer

  

Figure 7-4: The Folders Action can 
navigate to deeply nested folders on the 
fly; select from a list of common folders 
or specify your own.  

User-defined Actions

• Open a specified  folder
• Create a folder



91

Chapter 7 - Files and Folders

Setting up Folders Actions

There are two ways to create or edit QuicKeys Folders Actions: use the Setup Wizard or use the Action 
Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Folders 
button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the Setup 
Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Action, or Cre-
ate/edit multiple Actions. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page  34 for more information. To use the Action Properties dialog to 
create or edit a Folders Action, follow these steps:
1. Select Create > File & Folder Tools > Folders.
2. Choose an option from the Action-specific properties pane of the dialog.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the keys 

you want to use. For example, press the Shift key, the Alt key, and the F8 simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor.
7. Open a word processing program and select the Save As option.
8. Press the Folders hot key. The folder you selected appears within the standard Save dialog or the 

folder you specified will be created.

Triggering Folder Actions

After you have set up your Folders options, you can trigger them several different ways:
• Right-click any file on your hard drive and select a Folders Action from the context menu that ap-

pears. A Folders Action is only available from the context menu when you have created one using 
the QuicKeys Editor.

• Press the hot key you assigned (if any) to the Folders Action to trigger it.
• Set up a timed trigger to start the Folders Action.
• Place Folders Actions in the QuicKeys menu and select the Action from the menu.
• Add a Folders Action to a QuicKeys toolbar and trigger the Action from the toolbar.
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Folders Options

Below is a description of the Action-specific properties available with the Folders Action.

Open a predefined folder - Switches to the folder you specified when you created the Action.
Windows folder - Opens the Windows or WINNT folder (depending on your operating system) or 
switches to your Windows folder when any standard Save or Open dialog is displayed.
Windows Temporary folder - Opens the Windows Temporary folder or switches to your Windows 
Temporary folder when any standard Save or Open dialog is displayed.
Windows Desktop folder - Opens the Windows Desktop folder or switches to your desktop folder 
when any standard Save or Open dialog is displayed.
My Documents folder - Opens the My Documents folder or switches to your My Documents folder 
(or the Personal folder if you are using NT) when any standard Save or Open dialog is displayed.
Favorites folder - Opens the Favorites folder or switches to your Favorites folder when any standard 
Save or Open dialog is displayed.
Application Data folder - Opens the Application Data folder or switches to your Application Data 
folder when any standard Save or Open dialog is displayed.
Up One folder - Switches to the folder above the level of the folder you are viewing.

Open a specified folder - Switches to the folder you specified when you created the Action.
Create a folder - Creates a folder in the active Explorer window or in the directory you specify. The 
new folder has the name you provide in the text field.
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The Open Action

The Open Action is useful when you want to open programs, documents, control panels, or other types of 
files with a trigger. For example, you can use this Action to open a report you frequently need to edit.

Setting up the Open Action

There are three ways to create QuicKeys Open Actions: use the Setup Wizard, use the Action Proper-
ties dialog, or use drag-and-drop functionality.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Open but-
ton. Read each of the dialogs in the Setup Wizard and follow the instructions. At the beginning of the 
Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Action, or 
Create/edit multiple Actions. The setup for each of these options is explained within the Setup Wizard. 

  

Figure 7-5: The Open Action can 
launch programs and control panels, 
open documents and more. Specify nor-
mal, minimized, or Maximized on open.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page  34 for more information. To use the Action Properties dialog to 
create or edit an Open Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > File & Folder Tools > Open.
2. Choose option(s) from the Action-specific properties pane of the dialog. For example, choose Pro-

gram from the Type drop-down list and choose a program to open from the Path drop-down list.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. Click in the Hot key box and press the key(s) you want to use to trigger the Open Action. For ex-

ample, press the Alt key, the Ctrl key, and the 1 key simultaneously.
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5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key you assigned to this Action. The file or program 

you selected opens.

Using Drag-and-Drop Functionality

You can drag-and-drop programs, documents, control panels, or other types of files onto the QuicKeys 
Editor’s Actions view to quickly create an Open Action. When you drop one or more files onto the 
Actions view, an Action Properties dialog for each item appears. You can edit the properties of each of 
these new Actions through this dialog including renaming the Action or or assigning a trigger such as a 
hot key.

Open Options

Below is a description of the Action-specific properties available with the Open Action.
Type - The type of file you want to open. For example, you can open programs, documents, control 
panels, or other custom files.

Program - When you choose to open a program with QuicKeys, you are presented with a list of 
programs from which to choose. That list is populated by the programs in your Start menu. You can 
click the Browse button and navigate to the desired programs if it is not in the list.
Document - When you choose to open a document with QuicKeys, you must click the Browse but-
ton and navigate to the document you want to open.
Control Panel - When you choose to open a control panel with QuicKeys, you are presented with a 
list of all the control panels installed on your computer.
Custom - When you choose to open a file that is not available using any of the other Open options, 
you must type the directory path for that file in the Run field or click the Browse button and navigate 
to it.

Path - The information required in the Path box is dependent upon the type of file you selected in the 
Type drop-down list. Specify the program, document, control panel, or other type of file you wish to 
open.
Parameters - The program-specific command lines you can use to further control the behavior of the 
selected file. For example, the /n/e,C:\ parameter is already specified for the Windows Explorer pro-
gram. This parameter opens the Explorer in the C:\ directory in an Explorer view. If you changed the 
parameter to /n/e,C:\Windows, the Explorer program would open in the C:\Windows directory in the 
Explorer view.

❖ Note: Each program installed on your computer has its own unique set of command parameters 
that are reminiscent of DOS commands. Consequently, it would be wise to have experience with 
DOS before typing text in the Parameters field.

Start in - This command can be traced back to the DOS “change directory” (CD) command. If you 
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want to open a program that can only look for files in the currently selected directory, it is important to 
specify the directory path in the Start in field.

For example, if you can recall any DOS commands, you may remember that you once had to type 
copy C:\Programs C:\System\Documents to successfully copy files from one directory to another. 
However, if you typed C:\System C:\Documents, you would get an error because the computer was 
looking for C:\Programs in the C:\System\Documents directory.

Run - The appearance of the window when it opens. You can make the file appear in a normal, mini-
mized, or maximized window.
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Recent Files

The Recent Files Action gives you quick access to files that have recently been edited. It enables you to 
find recently modified files by searching modification dates based on the interval you specify. For exam-
ple, if you download a new shareware program from the Internet and cannot figure out where it ended up, 
Recent Files can find it for you.

You can set the following search options when you direct the Recent Files Action to locate files.

• Files modified in the last 15 minutes
• Files modified in the last hour
• Files modified in the last 24 hours
• Files modified in the last “X” hours and “X” minutes
• Exclude the Windows Temporary files from the search

Setting up Recent Files Actions

There are two ways to create and edit QuicKeys Recent Files Actions: use the Setup Wizard or use the 
Action Properties dialog.

  

Figure 7-6: The Recent Files setup 
wizard lets you choose a time frame by 
which to locate recently modified files.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Recent 
Files button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the 
Setup Wizard, you are presented with options to Create an Action, Edit an Action, or Delete an Action. 
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The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Recent Files Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > File & Folder Tools > Recent Files.
2. Choose a time range. For example, choose “Files modified in the last 15 minutes”.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu 

check box.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and select the Recent Files Action from the QuicKeys menu. All the 

files that have been modified in the interval you have specified are displayed in a list.
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Zip Files

The Zip Files Action enables you to compress files into archives, extract compressed files from archives, 
add new files to an archive, and validate compressed files within an archive.

Setting up Zip Files Actions

There are two ways to create and edit QuicKeys Zip Files Actions: use the Setup Wizard or use the Ac-
tion Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Zip Files 
button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the Setup 
Wizard, you are presented with options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup Wizard.

  

Figure 7-7: The Zip Files Action can 
add files to, remove files from, and 
verify the files in a zip archive.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page  34 for more information.
1. Go to Actions view in the QuicKeys Editor and select Create > File & Folder Tools > Zip Files.
2. Choose an option from the Action-specific properties pane of the dialog. For example, choose Add 

files to zip.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
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4. Select a trigger for the Action.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and trigger the Zip Files Action.

Zip Files Options

Below is a description of the Action-specific properties available with the Zip Files Action.
Add files to zip - Adds the specified file to the Zip archive. When this option is selected, you must 
choose whether to zip the file that is currently selected or a pre-specified file. You must also indicate 
a destination for the zip file. The destination can be the same directory as the specified file or a pre-
specified directory. Finally, you must tell QuicKeys how you want to handle situations where a zip file 
already exists. Click the Notify when completed check box if you want to be alerted when the files 
have been zipped.

Extract files from zip - Decompresses the specified files. When this option is selected, you must 
choose the source location of the zip file you want to decompress as well as the destination for the de-
compressed files. Then, you must choose replacement options if the decompressed files are duplicated 
in the destination directory. Click the Notify when completed check box if you want to be alerted when 
the files have been unzipped.

Verify zip file - Verifies that the zip file isn’t corrupted. When this option is selected, you must choose 
whether to verify the file that is currently selected or a file that has been pre-specified in the Zip Files 
Action.
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System Tools encompass the Button Click, Mouse Click, Mouse Position, QuicKeys Clipbook, Run 
Script, Select Menu, Set System Clock, System Specials, Type Keystroke, and Window Handler Actions. 
These Actions allow you to control or change the appearance and behavior of the Windows environment, 
without digging around in the system preferences. You can use the System Tools Actions to change your 
screen settings, cut and paste text and graphics to your Clipbook, rearrange the windows on your desktop, 
run scripts, and much more.

Button Click

The Button Click Action clicks dialog buttons in the front-most window. For example, you might want an 
Action that clicks a specified radio button or checks a specific check box. When you press your hot key 
the designated button is clicked by QuicKeys, saving you the trouble of mousing to and clicking it.

   

Figure 8-1: The properties portion 
if the Button Click Action window 
contains several different ways to 
designate the button to click. In addi-
tion, “Specify window properties” lets 
QuicKeys automatically discover what 
type of window the button occupies, 
saving you the trouble of trying to 
determine this yourself.

Setting up a Button Click Action

1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Button Click.
2. Determine how you want QuicKeys to find your button (typically “By name”) and click the ap-

propriate radio button in the Action properties dialog, filling in its associated fields. For example, if 
you chose “By name” fill in the name of the button in the associated field.

3. Open the program window containing the button you want QuicKeys to click for you. Go back to 
the Action properties dialog and click on the “Specify window properties” button. This will open a 
Window Properties dialog which is used to tell QuicKeys in which window to find the desired but-
ton; enter the information necessary for QuicKeys to locate the target window.

 Click the Specify window properties button to display the Window Properties dialog. Using the 
Window finder tool in the Window Properties dialog enables you to automatically populate the text 
fields and buttons in the Action Properties dialog. 
❖ Note: The Window Properties dialog is explained in more detail in Chapter 13, page 160.

4. Determine if this button should be clicked always or only when already on or off. Give your action 

Chapter 8: System Tools
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a name and a hot key (or other trigger).

Button Click Options

Below is a description of the Action-specific properties available with the Button Click Action.
Find button by name - Locates a button by its name which you enter into the text field.

Exact match - Select Exact match if the button text must match the button name exactly. There 
are situations where you might want to only match part of a button’s name.

Find button by ID - The Button Click looks for a program specific ID rather than looking for coor-
dinates. Button IDs are typically only known by developers, so the IDs are not commonly used.
Find button by coordinates - The intersection of the X and Y coordinates where the mouse click 
should occur.

X - The horizontal coordinates for the mouse click.
Y - The vertical coordinates for the mouse click.

Specify window properties - Displays the Window Properties dialog, which allows you to select a 
specific window with your mouse at which point QuicKeys will automatically fill in the necessary 
fields to identify the proper window during playback.
❖ Note: The Window Properties dialog is explained in more detail in Chapter 13, page 160.
When button is found - Choose whether to always click the button, click the button only when it’s 
on, or click the button only when it is off.
❖ Note: These rules are particularly useful for radio buttons and check boxes. If you want to ensure 
a check box or radio button is checked, select “Click when off”. If you want to uncheck a radio but-
ton or check box, select “Click when on”.
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Mouse Click

The Mouse Click Action allows QuicKeys to mimic a mouse click; you can trigger it with a hot key and 
save yourself some mousing around. This Action is especially useful in situations where there is no key-
board equivalent for the item you want to click. For example, if you are recording a Sequence that opens 
a file in Paint and then draws a square of a specific size, the QuicKeys Sequence will use a Mouse Click 
Action to select the Rectangle drawing tool in Paint.

  

Figure 8-2: Mouse Click Actions 
locate their targets by the “X, Y” coor-
dinates of those targets. By default the 
Mouse Click Action uses the upper left 
corner of the screen or a window as the 
origin; that is the point where X = 0, 
Y = 0.

Setting up Mouse Click Actions

To create a Mouse Click Action using the Action Properties dialog:

1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Mouse Click.
2. Make sure the window with the target you want QuicKeys to click on is open.
3. If you know the coordinates of your click target, enter those in the X and Y coordinate fields and 

skip to step 5. Otherwise click the Browse button and wait for the QuicKeys recording palette to 
appear (and the QuicKeys editor window to disappear).

4. Click on whatever the target of this Mouse Click Action is and wait for the Action Properties 
window to reappear. The X,Y location relative to the upper left corner of the target window should 
have been filled in by QuicKeys.

5. Click on the “Specify window properties” button. This will open a Window Properties dialog 
which is used to tell QuicKeys in which window to find the desired button; enter the information 
necessary for QuicKeys to locate the target window.

 Click the Specify window properties button to display the Window Properties dialog. Using the 



104

Chapter 8 - Using System Tools

Window finder tool in the Window Properties dialog enables you to automatically populate the text 
fields and buttons in the Action Properties dialog. 
❖ Note: The Window Properties dialog is explained in more detail in Chapter 13, page 160.

6. Make sure the correct mouse button is indicated and check any modifier keys you’d like QuicKeys 
to use when executing this click. Name the Action and give it a hot key (or other trigger).

     

Figure 8-3: The Mouse Click Action 
Properties dialog presents settings for 
the type of click, coordinates on which 
to click, which window or the screen as 
a point of reference, and any modifier 
keys to be pressed.

Mouse Click Options

Below is a description of the Action-specific properties available with the Mouse Click Action.
Click mouse at - Chooses the coordinates for the Mouse Click as well as the point from which those 
coordinates are measured.
Release mouse at - Chooses the coordinates for the release of the mouse click.
Double click - Double-clicks the mouse.

X - The horizontal coordinates for the Mouse Click.
Y - The vertical coordinates for the Mouse Click.

Referenced from - The point from which the coordinates are measured. Options include Top Left, 
Top Right, Bottom Left, Bottom Right, and Current Mouse Position.
Relative to - Chooses whether the mouse click coordinates occur relative to the Screen, the Front-
most program window, or the Window selected using the Select Properties button.
Mouse button - The mouse button that is clicked for this Action. The Middle button option is not 
applicable unless you have a third mouse button.
Modifiers - The keys that must be pressed in combination with the Mouse Click.
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Mouse Position

The Mouse Position Action enables you to specify where you want QuicKeys to place your mouse cursor. 
With this functionality you can drastically reduce the distance you must move your mouse for repeated 
tasks, reducing the chance of repetitive stress injuries to your wrists and hands.

For example, if you need to repeatedly move your mouse back to a tool palette to select a different tool, 
you should consider setting up a Mouse Position Action to zip your mouse over to that palette for you 
when you press a hot key.

Setting up Mouse Position Actions

Setting up a Mouse Position Action is similar to setting up a Mouse Click or Button Click action. 
Please see those sections earlier in this chapter.

Mouse Position Options

Below is a description of the Action-specific properties available with the Mouse Position Action.
Remember mouse position - Temporarily memorizes the current location of the mouse cursor so 
you can later return the cursor to that location with a QuicKeys trigger.
Restore last mouse position - Returns the mouse cursor to its previous location.
Center mouse on screen - Positions the mouse in the center of your screen.
Center mouse on active window - Positions the mouse in the center of the window or dialog that is 
currently active on your screen.
Center mouse on control - Positions the mouse at the coordinates you specify, relative to a window 
or palette or toolbar or just about any other control. You can manually enter the coordinates, or you 
can use the Specify window properties button to specify the location. When you click the Specify 
window properties button, the Window Properties dialog appears.
❖ Note: The Window Properties dialog is explained in more detail in Chapter 13, page 160.
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QuicKeys Clipbook

The QuicKeys Clipbook is a manager for bits of text and graphics called “Clips”. It can be used to store, 
edit and quickly retrieve snippets of text and images or combinations of the two. These Clips are not vola-
tile like the data on your system clipboard, they are stored permanently within QuicKeys. They preserve 
stylized text, such as font and color information and can be easily edited within the Clipbooks workspace 
in the QuicKeys Editor.

 
Figure 8-4: Clips containing text or graphics (or both) are stored and organized in Clipbooks, accessible 

from the Clipbooks view in the QuicKeys Editor window.

QuicKeys Clipbook Components

There are two basic components to QuicKeys Clipbooks: the collections of Clips you’ve created , and the 
QuicKeys Actions you  use to retrieve your Clips or collect new ones.
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Clipbook Collections

Figure 8-4 shows the QuicKeys Editor in Clipbooks viewing mode (1). On the left side of the editor 
you can select collections of Clips (2) and on the right you will see a listing of the Clips (3) in the se-
lected Clipbook. Clicking on a Clip will reveal its contents in the preview/editing pane (4) in the lower 
right portion of the editor window. Clips can be dragged from area (3) onto the folders in area (2) for 
easy organization.
When the QuicKeys Editor is in Clipbooks view mode the Create menu takes on new contents related 
solely to Clips. Menu options include:

New Clip Group - Creates a new Clipbook folder in the Clipbooks portion of the editor. The new 
folder is created as a subordinate of the currently selected Clipbook.
Blank Clip - Creates a new blank Clip in the currently selected Clipbook. Data can then be typed or 
pasted into this new clip. (This option is also available by right-clicking in the Clips region of the 
QuicKeys Editor window.)
Clip from Clipboard - Creates a new Clip in the currently selected Clipbook. The contents of this 
Clip are whatever was on the system clipboard at the time. (This option is also available by right-
clicking in the Clips region of the QuicKeys Editor window.)

Figure 8-5: In Clipbooks mode, the QuicKeys Editor’s Cre-
ate menu takes on new contents related to the creation and 
organization of Clips.

❖ Note: Clips can be easily cut, copied, pasted, and deleted by right clicking on them and selecting 
from the contextual menu that appears. These same operations are available through the Edit menu 
and through the main editor toolbar.

Clipbook Actions

Generally you will want to create at least two QuicKeys Actions to make best use of the Clipbooks 
feature, one to collect new Clips, and one to retrieve Clips from your collection to paste them into docu-
ments. These activities can be handled by two different configurations of the QuicKeys Clipbooks Action 
(“Copy selection to Clipbook” and “Prompt for list of items to paste from Clipbook”).
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QuicKeys Clipbook Options

To create a Clipbook Action, go to Actions view in the QuicKeys Editor and select Create > System 
Tools > QuicKeys Clipbook. The options available for this Action depend heavily on the choice you 
make in the first pop-up list titled “Action”. Each set of options will be discussed separately.

 
Figure 8-6: Clipbook Actions allow you to create Clips from selected text and graphics, storing them 
for later retrieval and use in your documents. This figure shows the configurable Action properties of 
(clockwise from upper left) Prompt for list of items to paste, Copy selection to Clipbook, Paste item 

from Clipbook, Delete item from Clipbook.
Action: Copy selection to Clipbook 
Copy selection to Clipbook is the quickest way to gather new text or graphics and save them as Clips. 
Once this Action is configured you simply select the image/text you want to save as a Clip, hit the as-
signed hot key, and a new Clip is created and saved in the desired Clipbook.

Clip hierarchy/tree pane - This setting lets you choose where to store the new Clip. The hierarchy of 
your Clipbooks is represented here, click on a Clipbook to set it as the destination for new Clips.
Prompt for name/Specified name - This pair of radio buttons tells QuicKeys to either give the new 
clip a specific name or put up a prompt dialog letting you name it on the fly. If you choose “Prompt 
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for name” QuicKeys will put up a small dialog when you trigger this Action, allowing you to name 
the Clip immediately. If you choose “Specified name” you must enter a name in the associated field; 
this will be the name of the Clip created any time you trigger this Action, replacing any Clip of the 
same name already in your Clipbook.

❖ Note: By using the “Specify name” option you can create multiple temporary clipboards. Create 3, 
5, 10, or more of these Actions, each saving its Clip under a unique specified name. Assign unique 
but similar hot keys to these Actions and you have half of a multi-clipboard system set up, the 
other half being a set of Actions to paste from those temporary clipboards.

Beep after selection is copied to Clipbook - Notification that the selection was successfully copied.
Action: Prompt for list of items to paste from Clipbook 
Prompt for list of items to paste from Clipbook is the most flexible way to retrieve Clips from your col-
lections and paste them into your documents. Once this Action is configured you simply press the as-
sociated hot key to reveal the “Select clip and paste” dialog. This dialog is a hierarchical list of all your 
Clips as you’ve arranged them in your Clipbooks. Click on the desired Clip and click the Paste button 
to insert the Clip in your document.

Clip hierarchy/tree pane - This setting lets you choose which Clipbook is selected by default when 
the Action is triggered. You can set up multiple Actions of this type and specify different Clipbooks 
for quicker access to specific categories of Clips.

 

Figure 8-7: When you trigger a 
Clips Action set to “Prompt for list 
of items to paste from Clipbook”, 
QuicKeys opens the Select clip and 
paste dialog. Navigate the group hi-
erarchy and select the desired Clip. 
Clicking the Paste button inserts that 
Clip into your document.



110

Chapter 8 - Using System Tools

Action: Open Clipbook Editor 
Open Clipbook Editor allows you to open the QuicKeys Editor to the Clipbooks view with the press of 
a hot key.

Clip hierarchy/tree pane - This setting lets you choose which Clipbook is opened by default when 
the Action is triggered. You can set up multiple Actions of this type and specify different Clipbooks 
for quicker access to specific categories of Clips.

Action: Paste item from Clipbook 
Paste item from Clipbook allows you to instantly paste specific Clips into documents. Once this Action 
is configured you simply press the associated hot key to insert the desired Clip in your document.

Clip hierarchy/tree pane - This setting lets you choose the Clipbook from which QuicKeys will 
paste the desired Clip.
Selected item - Choose the Clip you want QuicKeys to paste into your document. The items in this 
pop-up list are filtered by and dependent on what you have selected in the Clip hierarchy/tree field.
Specified name - If the specific Clip you want QuicKeys to paste is not yet created, or perhaps a tem-
porary Clip that you define and delete as you work, you can type in the name of the Clip in this field. 
If the clip exists when you trigger the Action its contents will be pasted into your document.

Action: Delete item from Clipbook 
Delete item from Clipbook allows you to instantly delete a specific Clip from your collection. Once 
this Action is configured you simply press the associated hot key to delete the desired Clip.

Clip hierarchy/tree pane - This setting lets you choose the Clipbook from which QuicKeys will 
delete the desired Clip.
Selected item - Choose the Clip you want QuicKeys to delete from your collection. The items in this 
pop-up list are filtered by and dependent on what you have selected in the Clip hierarchy/tree field.
Specified name - If the specific Clip you want QuicKeys to delete is not yet created, or perhaps a 
temporary Clip that you define and delete as you work, you can type in the name of the Clip in this 
field. If the clip exists when you trigger the Action it will be deleted from your collection.
Move to Recycle Bin - If this field is checked the Clip deleted by this Action will be moved to the 
system’s Recycle Bin. If this field is unchecked the Clip is deleted immediately and its contents are 
unrecoverable.

Why use Clips rather than Type Text?

To some, Clips might seem a duplication of the Type Text Action. While both Action types can contain 
stylized text, only Clips can contain images. Beyond this, hot keys and organization are a profound dif-
ference. There is no organizational feature to Type Text and each Action must have its own trigger to be 
used. Clipbooks, on the other hand, allows you to organize your text and images into hierarchical folders 
and lets you use a single hot key to open and list retrieve any of your stored Clips.
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Run Script

The Run Script Action executes scripts. Scripts are instructional commands written in a computer lan-
guage that is recognized by specific programs or script engines. The Run Script Action is only available 
from the Create menu when the QuicKeys editor is in Actions view. The Run Script Action lets you run 
scripts with a simple QuicKeys trigger.

If you know how to write Windows scripts, QuicKeys can run them as long as the appropriate script 
engine is installed on your computer. You can create and run Javascripts, Visual Basic scripts, or any other 
type of scripts Windows Scripting Host supports. Windows Scripting Host (WSH) is a language indepen-
dent scripting host for 32-bit Windows platforms.

Setting up Run Scrip Actions

You can create and edit QuicKeys Run Script Actions using the Action Properties dialog.

Using the Action Properties Dialog

To use the Action Properties dialog to create or edit a Run Script Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Run Script.
2. Choose a script for QuicKeys to launch. Use the Browse button to navigate through your directo-

ries if you cannot type the path of the script.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. If you want to choose a hot key to trigger this Action, click on the Hot key box and press the key(s) 

you want to use. For example, press the Shift key, the Control key, and the F8 key simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. The 

script you selected should launch.

Run Script Options

Below is a description of the Action-specific properties available with the Run Script Action.

Select script - Displays the directory path for the script in this field.

Browse - Navigates to the location of the script.

Parameters - The program-specific command lines you can use to further control the behavior of the 
selected script. For example, /n/e,C:\ opens Windows Explorer in the C:\ directory in an Explorer view.
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Select Menu

Select Menu is useful when you want to avoid using your mouse, or when you want to select a menu item 
that does not have a hot key assigned to it. For example, you can use this Action to assign a single hot key 
that selects the Exit command in all of your programs.

❖ Note: Some programs display what appear to be menus but in reality they are not. These simulated 
menus are not accessible to QuicKeys via Select Menu actions so your best bet is to use a series of 
Type Keystroke commands to trigger them. For example, most programs use “Alt+F” followed by “A” 
to trigger the File > Save As... menu item. QuicKeys can utilize a short sequence made up of two Type 
Keystroke actions to accomplish this same feat.

Setting up Select Menu Actions

There are two ways to create or edit QuicKeys Select Menu Actions: use the Setup Wizards view or use 
the Actions view.

       

Figure 8-7: The Select Menu Action 
Properties dialog presents settings for 
the menu item you want QuicKeys to 
select. Partial matches on the menu 
item name can be used for more ge-
neric menu selection actions.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Select Menu Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Select Menu.
2. Specify the menu item you want QuicKeys to locate when this Action is triggered.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. If you want to choose a hot key to trigger this Action, click on the Hot key box and press the key(s) 

you want to use. For example, press the Shift key and the F3 key simultaneously.
5. Click OK. Your new Action appears in the Actions view.
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6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. The 
menu item is selected.

Select Menu Options

Below is a description of the Action-specific properties available with the Select Menu Action.
Menu Item - Type the name of the menu item you want QuicKeys to select in this box.

Browse - As soon as you click the Browse button, the QuicKeys Editor disappears and puts up a 
notification dialog telling you that your next menu selection will be recorded. Click OK and the 
recording palette appears. Select the menu item you want to use for this Action. The QuicKeys 
Editor reappears with the name of the menu item you selected displayed in the Menu Item field. 
To cancel the Browse option, press the X button on the recording palette.

          

Figure 8-8: The Menu Browser in-
structional dialog will appear when you 
click Browse to indicate the menu item 
you want QuicKeys to select.

Starts with - Requires that the menu item QuicKeys searches for must start with the characters 
supplied in the Menu Item box.
Exact match - Requires that the menu item QuicKeys searches for must exactly match the char-
acters supplied in the Menu Item box. This means that the search is case sensitive.
Contains - Requires that the menu item QuicKeys searches for must contain the characters sup-
plied in the Menu Item box.

Menu ID - This option is available in the Action Properties dialog. Menu IDs vary from program to 
program. Therefore, the Menu ID field should only be populated when you click the Browse button 
and QuicKeys records the Menu ID number for the menu item selected. The Menu ID number is 
useful when a menu contains information, such as colors, that cannot be specified in the Menu text 
field. It is also useful if the menu item toggles between two options, such as Redo and Undo.
Active program menu - This option is available in the Action Properties dialog. Use this option to 
select an item from the menus displayed in the currently active program. For example, if Microsoft 
Word was the foreground program on your desktop, this Action would select an item from one of 
Word’s menus.
Active program system menu - This option is available in the Action Properties dialog. Use this 
Action to select an item from the menu that displays when you click the program icon in an open 
program. The program icon is the icon in the upper left corner of a window.
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Active document system menu - This option is available in the Action Properties dialog. Use this 
Action to select an item from the menu that displays when you click the program icon in an open 
document. The program icon is the icon in the upper left corner of your document window.
Start menu - This option is available in the Action Properties dialog. Use this option to select an 
item from the Windows Start menu.
Context menu - This option is available in the Action Properties dialog. Use this option when you 
want to select a context menu item within a Sequence. Context menus appear when you right-click 
your mouse.
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Set System Clock

Using the Set System Clock Action, you can change your system clock to a time you specify or to a time 
designated on a specified time server.

Setting up Set System Clock Actions

There are two ways to create or edit Set System Clock Actions: use the Setup Wizards view or use the Ac-
tions view. The following instructions assume you have the Always use Setup Wizards for editing check 
box cleared in the Options dialog. See page 34 for more information.

To use the Action Properties dialog to create or edit a Set System Clock Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Set System Clock.
2. Specify how you want to set your system clock. You can choose to set it by a selected remote time 

server or you can enter a specific date and time.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. If you want to choose a hot key to trigger this Action, click on the Hot key box and press the key(s) 

you want to use. For example, press the Shift key, the Ctrl key, and 0 simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. The 

system clock is changed using the date and time you specified.

Set System Clock Options

Below is a description of the Action-specific properties available with the Set System Clock Action.
Remote time server - Sets the system clock according to the time indicated on a selected remote 
time server. Default time servers include NIST, Purdue University, Coypu, and the U.S. Naval Ob-
servatory. You can also click the Edit time servers button to link to other remote time servers. To add 
a time server to your list of remote time servers, click the Add button and provide the remote time 
server’s name, address, time protocol, and network protocol.
❖ Note: If you are using a firewall, check that ports 37 or 123 are open. See your network adminis-
trator for more information.
Specified date and/or time - Chooses the date and/or time to which you want to set your system 
clock.
Notify when completed - Alerts you when the system clock has been successfully changed.



116

Chapter 8 - Using System Tools

System Specials

The System Specials Action offers a way to make a variety of common computer tasks faster and easier 
to complete. You can use the System Specials Action to shutdown your computer, restart your computer, 
restart Windows, log off, lock your computer, put your computer in standby, or empty the Recycle Bin.

Setting up System Specials Actions

There are two ways to create or edit QuicKeys System Specials Actions: use the Setup Wizards view or 
use the Actions view.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the System 
Special button. Read the pages of each wizard dialog and follow the instructions. At the beginning of 
the Setup Wizard, you are presented with options to Create an Action, Edit an Action, or Delete an Ac-
tion. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

To use the Action Properties dialog to create or edit a System Specials Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > System Specials.
2. Specify which basic computer task you want to automate.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. Select a trigger for this Action.
5. Click OK.
6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action.

    

Figure 8-9: The System Specials Ac-
tion gives you one-touch 
control of a variety of common com-
puter tasks.
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System Specials Options

Below is a description of the Action-specific properties available with the System Specials Action.

Shutdown computer - Shuts down your computer.

Restart computer - Restarts your computer.

Log off computer - Logs you off your computer.

Lock computer - Locks your computer. When you unlock your computer, you must enter your Win-
dows password at the prompt.

Set computer to standby - Puts your computer in sleep mode.

Empty Recycle Bin - Deletes the contents of the Windows Recycle Bin. Click the check box Prompt 
for confirmation if you want to see a prompt before the contents of the Recycle Bin are actually de-
leted.

Hybernate computer - Puts your computer in Stand By mode. 
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Type Keystroke

This Action provides a way to replace hot key assignments built into your programs with QuicKeys hot 
keys that make sense to you. The Type Keystroke Action is useful when you want to substitute one key 
for another. For example, if you upgrade one of your programs only to find that all your favorite built-in 
shortcut keys have been changed, you can just change them right back to what you’re accustomed to us-
ing with the Type Keystroke Action.

Type Keystroke is also a good candidate for manipulating program menus. Nearly every menu in every 
program has a series of hot keys that can be pressed to select an item. Type Keystroke actions can be as-
sembled into a Sequence, allowing you to press a single hot key to select frequently used menu items.

Setting up Type Keystroke Actions

There are two ways to create and edit Type Keystroke Actions: use the Setup Wizard or use the Action 
Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Type 
Keystroke button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the 
beginning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, or 
Delete an Action. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

To use the Actions Properties dialog to create or edit a Type Keystroke Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Type Keystroke.
2. Put your mouse cursor in the “Keys to type” field and press the key or key combination you want 

QuicKeys to type for you.
3. In the Name box of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. Click on the Hot key box and press the key(s) you want to use to trigger this Action.
5. Click OK. Your new Action appears in the Actions view.

Type Keystroke Options

Below is a description of the Action-specific properties available with the Type Keystroke Action.
Key(s) to type - The key you want to replace. The Type Keystroke Action enables you to substitute 
a QuicKeys hot key for this key.
Modifiers - The keys that are pressed at the same time as the key(s) listed in the Key(s) to type box. 
The modifier key options include the Shift, Alt, Control, and Windows keys.
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Window Handler

The Windows Handler Action is useful for controlling Windows without having to use your mouse.

Setting up Window Handler Actions

There are two ways to create and edit Window Handler Actions: use the Setup Wizard or use the Action 
Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Window 
Handler button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the begin-
ning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, or Delete 
an Action. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Actions Properties dialog 
to create or edit a Window Handler Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > System Tools > Window Handler.
2. Select the type of window you want to manipulate and then choose the Action you want to perform 

with the window.

      

Figure 8-10: The Window Handler 
Action lets you quickly manipulate the 
front-most program window, all of a 
program’s windows, a specified win-
dow, or every window currently open 
on your computer.

3. In the Name box of the Action Properties dialog, a name is automatically assigned to the Action. 
You can use the assigned Action name or type a different name.

4. Click on the Hot key box and press the key(s) you want to use to trigger this Action.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key you assigned to this Action.
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Window Handler Options

The Window Handler options vary depending upon whether you select All windows, Active window, or 
Specified window. Below is a description of the Action-specific properties available with the Window 
Handler Action.

All Windows

Cascade windows - Staggers your windows across your screen.
Tile windows horizontally - Arranges the windows horizontally on your screen.
Tile Windows Vertically - Arranges windows vertically on your screen.
Close all Windows - Closes all your open windows.
Minimize all Windows - Minimizes all your open windows.

Active Window

Close active window - Closes the front-most window.
Minimize active window - Minimizes the size of the front-most window.
Maximize active window - Maximizes the size of the front-most window.
Restore last minimized window - Returns the last window you minimized back to its original size.
Toggle active window size - Alternately minimizes and maximizes the front-most window.
Center active window - Positions the active window so it is in the middle of your screen.
Set active window size - Adjusts the size of the front-most window to the coordinates you specified 
in QuicKeys.

Specified Window

Close specified window - Closes the specified window. Minimize specified window - Minimizes the 
specified window.
Maximize specified window - Maximizes the specified window.
Restore specified window - Returns the specified window you minimized back to its original size.
Toggle specified window size - Alternately minimizes and maximizes the specified window.
Center specified window - Positions the specified window so it is in the middle of your screen.
Set specified window size - Adjusts the size of the specified window to the coordinates you speci-
fied in QuicKeys.
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Tutorial - Using Clipbooks as a Multi-clipboard

Let’s have a look at some uses for the improved QuicKeys Clipbooks feature. The most obvious and gen-
eral use for Clipbooks is as a repository for the dozens or perhaps hundreds of important bits of text and 
graphics you need for your daily work. Retrieval of this data from your Clipbooks is as simple as pressing 
a hot key to pull up an organized list of Clips and choosing the one to paste. This functionality is rather 
self-explanatory, so this tutorial will instead focus on a Clipbooks use you may not have considered.

The Problem

“I need to copy and paste between a spreadsheet and a database repeatedly several times per day. Three 
fields in the spreadsheet contain data that needs to be moved to the database. Currently I must switch to 
the spreadsheet, copy the first cell of data, switch to the database and paste. Then it’s back and forth two 
more times to complete the process. Can QuicKeys help me streamline this?”

The Solution

This whole sequence of events could be scripted with QuicKeys, but a more flexible solution with uses 
beyond this single task is what will be described. Our goal is a set of Actions that allow us to copy mul-
tiple bits of data then switch to another document and paste those separate bits of data. We’ll be creating 
a set of three empty Clips, three Clipbook Actions to copy data into those Clips, and three more Clipbook 
Actions that paste data from those Clips. This will build what is essentially a multi-layered clipboard.  

How To

1. Open the QuicKeys Editor and select the Clipbooks view.
2. Click on the Personal Clips folder in the workspace pane (upper left portion of the QuicKeys Edi-

tor) to select it.
3. Select Create > New Clip Group, a new folder named “New Clip Folder” will appear beneath the 

Personal Clips folder. This is where we’ll store our multiboard Clips so change the name of the 
folder to Multiboard.

4. With your new “Multiboard” Clipbook selected, go back to the Create menu and select Blank Clip. 
Do this two more times and rename the Clips as “clipboard1” “clipboard2” and “clipboard3” as 
shown in the figure below:

  

Figure 8-11: Completion of steps 
1 through 4 should result in your 
Clipbooks view containing a new 
Clipbook named “Multiboard” which in 
turn contains three “clipboard” Clips.

5. Our clipboards are ready, now we need to create Actions that allow us to store data on each of them 
as needed. Switch to Actions view in the QuicKeys Editor and click on the Universal folder located 
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in the Workspace (upper left) area of the editor. Create a new Action by selecting Create > System 
Tools > QuicKeys Clipbooks and configure the Action Properties as follows:
• Select “Copy selection to Clipbook” from the Action pop-up list.
• Locate and select your “Multiboard” Clipbook from the displayed “Clip” hierarchy.
• Check the “Specified name” radio button and type “clipboard1” in the associated field.
• Name the Action “Multiboard [copy1]” and give it Short+Ctrl+1 as a hot key.
• Click OK to save and close the Action Properties window.

     

Figure 8-12: Action Proper-
ties dialog showing a com-
pleted “Copy selection to 
Clipbook” Action. This is one 
of three copy Actions used 
to feed data into the three 
empty Clips used as multiple 
clipboards.

6. You need two more of these Actions so you can save data to your other two “clipboard” Clips. Lo-
cate your “Multiboard [copy1]” Action in the QuicKeys Editor and click on it to select it. Duplicate 
this Action by selecting Copy from the Edit menu and then selecting Paste from that same menu. 
This will create an Action named “Copy of Multiboard [copy1]”.

7. Open the copied Action for editing. Change the Name to “Multiboard [copy2]”, change the hot key 
to Shift+Ctrl+2, and change the Specified name field to “clipboard2”. Click OK to save and close 
the Action Properties dialog.

8. As in steps 6 and 7, duplicate “Multiboard [copy1]” one more time and edit it to change the Name 
to “Multiboard [copy3]”, change the hot key to Shift+Ctrl+3, and change the Specified name field 
to “clipboard3”. Click OK to save and close the Action Properties dialog.
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9. You should now have three Actions set up to copy data into your custom clipboards. Now we 
need to create Actions that allow us to paste the data from those clipboards. In Actions view in the 
QuicKeys Editor click on the Universal folder located in the Workspace (upper left) area of the edi-
tor. Create a new Action by selecting Create > System Tools > QuicKeys Clipbooks and configure 
the Action Properties as follows:
• Select “Paste item from Clipbook” from the Action pop-up list.
• Locate and select your “Multiboard” Clipbook from the displayed “Clip” hierarchy.
• Check the “Selected item” radio button and select “clipboard1” from the associated pop-up list.
• Name the Action “Multiboard [paste1]” and give it Short+Alt+1 as a hot key.
• Click OK to save and close the Action Properties window.

     

Figure 8-13: Action Prop-
erties dialog showing a 
completed “Paste item from 
Clipbook” Action. This is one 
of three copy Actions used to 
retrieve data from the three 
designated Clips used as mul-
tiple clipboards.

10. You need two more of these Actions so you can pull data from your other two “clipboard” Clips. 
Locate your “Multiboard [paste1]” Action in the QuicKeys Editor and click on it to select it. Du-
plicate this Action by selecting Copy from the Edit menu and then selecting Paste from that same 
menu. This will create an Action named “Copy of Multiboard [paste1]”.

11. Open the copied Action for editing. Change the Name to “Multiboard [paste2]”, change the hot key 
to Shift+Alt+2, and change the Selected item pop-up list to “clipboard2”. Click OK to save and 
close the Action Properties dialog.
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12. As in steps 10 and 11, duplicate “Multiboard [paste1]” one more time and edit it to change the 
Name to “Multiboard [paste3]”, change the hot key to Shift+Alt+3, and change the Selected item 
pop-up list to “clipboard3”. Click OK to save and close the Action Properties dialog.

Test your Actions

Open a document in your preferred word processor and type three words: “one two three”. Now highlight/
select the word “one” and press your Shift+Ctrl+1 hot key to copy your selection into the Clip named 
“clipboard1”. Next select the word “two” and press Shift+Ctrl+2 to copy it into clipboard2. Finally Select 
“three” and press Shift+Ctrl+3 to copy it into clipboard3. Make a new line in your document and press 
Shift+Alt+1 to paste the contents of clipboard1 into your document. Press Shift+Alt+2 then Shift+Alt+3 
to paste the contents of clipboard2 and clipboard3.

What else?

QuicKeys Clipbooks is a very flexible feature. In the preceding example you could add as many addition-
al clipboards as desired. If you add several more clipboards to your multiboard you may want to change 
the hot key triggers to chained hot keys. For example, use Shift+Ctrl+C -> 1

Multiboard Clip Hot Key Chain to Copy Hot Key Chain to Paste
clipboard1  Shift+Ctrl+C -> 1  Shift+Ctrl+V -> 1
clipboard2  Shift+Ctrl+C -> 2  Shift+Ctrl+V -> 2
clipboard3  Shift+Ctrl+C -> 3  Shift+Ctrl+V -> 3
Etc.
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Screen Tools include Screen Capture, Screen Saver, and Screen Settings Actions. These Actions enable 
you to capture images from your screen, trigger your screen saver, and adjust the resolution of your screen 
with simple QuicKeys triggers.

Screen Capture

QuicKeys has the flexibility of taking screen shots of your entire screen or an active window with a hot 
key. You can then save the captured image to a file, the Windows clipboard, the QuicKeys Clipbook, or 
you can print it.

Setting up Screen Capture Actions

There are two ways to create and edit QuicKeys Screen Capture Actions: use the Setup Wizard or use 
the Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards tab in the QuicKeys Editor and click the Screen 
Capture button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the begin-
ning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete 
an Action, or Create/edit multiple Actions. The setup for each of these options is explained within the 
Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Screen Capture Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Screen Tools > Screen Capture.
2.   Choose what part of the screen you want to capture and then choose how you want to save the im-

age.
3.   In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4.   If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu 

check box.
5.   Click OK. Your new Action immediately appears in the My Actions tab.
6.   Close the QuicKeys Editor and select the Screen Capture Action from the QuicKeys menu.

Screen Capture Options

Below is a description of the Action-specific properties available with the Screen Settings Action.

Chapter 9: Screen Tools
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Capture entire screen - Takes a screen shot of the entire screen.
Capture active window - Takes a screen shot of the front-most window.
Paste into Windows clipboard - Stores the screen shot on the Windows clipboard.
Paste into QuicKeys Clipbook - Stores the screen shot in the QuicKeys Clipbook.
Print to the default printer - Prints the screen shot to the printer specified in Windows as the de-
fault printer.
Save as a file - Stores the screen shot in a file you specify. 

      

 
Figure 9-1: The Screen Capture Action 
lets you capture the active window or 
your entire screen and save it to a file, 
print it, put it in the system clipboard, 
or put it in a QuicKeys Clipbook.
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Screen Saver

The Screen Saver Action enables you to control your screen saver with QuicKeys triggers. You can use 
QuicKeys to select a screen saver or to turn your screen saver on and off.

Setting up Screen Saver Actions

There are two ways to create and edit QuicKeys Screen Saver Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards tab in the QuicKeys Editor and click the Screen 
Saver button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the begin-
ning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete 
an Action, or Create/edit multiple Actions. The setup for each of these options is explained within the 
Setup Wizard.

     

 
 
Figure 9-2: The Screen Saver Action 
lets you change screen savers, turn 
your screen saver on and off, and sleep 
your monitor with the tap of a key.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Screen Saver Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Screen Tools > Screen Saver.
2.   Choose a Screen Saver option. If you choose Select screen saver, you must specify which screen 
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saver you want to use.
3.   In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4.  If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu 

check box.
5.   Click OK. Your new Action immediately appears in the My Actions tab.
6.   Close the QuicKeys Editor and select the Screen Saver Action from the QuicKeys menu.

Screen Saver Options

Below is a description of the Action-specific properties available with the Screen Saver Action.
Start screen saver - Starts your screen saver.
Stop screen saver - Closes the screen saver so your desktop is again visible.
Enable screen saver - Enables the screen saver so it starts at the specified interval.
Disable screen saver - Disables the screen saver so it does not automatically start.
Toggle enabled/disabled status - Alternately enables and disables the screen saver.
Select screen saver - Allows you to choose from your installed screen savers.
Turn monitor off - Immediately puts your display to sleep.
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Screen Settings

The Screen Settings Action is useful if you need to change your screen settings for different programs or 
different monitors. For example, if you use your laptop computer with a desktop monitor when you are 
at work, you may want to create a Screen Settings Action that automatically switches between the lap-
top screen settings and the desktop screen settings. The settings available in the Screen Settings Action 
depend upon the capabilities of your monitor and video card.

Setting up Screen Settings Actions

There are two ways to create and edit QuicKeys Screen Settings Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards tab in the QuicKeys Editor and click the Screen Set-
tings button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the beginning 
of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Ac-
tion, or Create/edit multiple Actions. The setup for each of these options is explained within the Setup 
Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Screen Settings Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Screen Tools > Screen Settings.
2.   Choose a screen setting from the Action-specific properties pane of the dialog.
3.   In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4.   If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu 

check box.
5.   Click OK. Your new Action immediately appears in the My Actions tab.
6.   Close the QuicKeys Editor and select the Screen Settings Action from the QuicKeys menu. The 

screen settings should change immediately after you trigger the Action.

Screen Settings Options

This section offers descriptions of the Action-specific properties available with the Screen Settings Ac-
tion.
Screen Settings - Choose the settings you want to use for your screen display.
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❖ Note: The settings that display in the Screen Settings list depend upon the capabilities of your video 
card and monitor.
Test - Changes the display so you can see what your screen setting selection looks like.
 

  

Figure 9-3: The Screen Settings Action 
lets you change your screen settings on 
the fly.
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If you have the appropriate sound hardware you can use QuicKeys to play your CDs or DVDs, set the 
volume for your individual audio devices, and play specified sounds. This chapter provides instructions 
for setting up CD/DVD, Set Audio Volume, and Play Sound Actions to control all these tasks for you.

❖ Note: You must have a sound card installed for the multimedia tools to function properly.

CD/DVD

With QuicKeys you can control your internal CD-ROM and DVD players. With a trigger you can:

 • Play a CD or DVD   • Pause a CD or DVD

 • Stop a CD or DVD   • Skip to the Next Track

 • Go back to the Previous Track  • Eject the CD or DVD

Setting up CD/DVD Actions

There are two ways to create and edit QuicKeys CD/DVD Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the CD/DVD 
button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the beginning of 
the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Ac-
tion, or Create/edit multiple Actions. The setup for each of these options is explained within the Setup 
Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a CD/ DVD Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Multimedia Tools > CD/DVD.
2. Choose an option from the Action-specific properties pane of the dialog. For example, select Pause.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use. For example, press the Control key and the F2 key simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action.

Chapter 10: Multimedia Tools
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CD/DVD Options

Below is a description of the Action-specific properties available with the CD/DVD Action:
Play - Plays the CD or DVD.
Pause - Pauses the CD or DVD.
Stop - Stops the CD or DVD.
Next track - Skips to the next track on the CD or DVD.
Previous track - Skips to the previous track on the CD or DVD.
Eject - Ejects the CD or DVD.
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Play Sound

The Play Sound Action is only available from the Create menu. This is because the Play Sound Action is 
typically used within QuicKeys Sequences to get the user’s attention when a certain step has finished or 
the Sequence has ended. You can use the Play Sound Action to play selected .wav sound files when you 
select a QuicKeys trigger.

Setting up Play Sound Actions

There are two ways to create and edit QuicKeys Play Sound Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

You cannot select the Play Sound Action from the Setup Wizards view. You can, however, use the 
Setup Wizard for this Action from the Create menu if you have selected the “Always use Setup Wiz-
ards for editing” checkbox in the View > Options dialog. Select Create > Multimedia > Play Sound, 
read each of the dialogs in the Setup Wizard and follow the instructions. At the beginning of the Setup 
Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Action, or Cre-
ate/edit multiple Actions. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

To use the Action Properties dialog to create or edit a Play Sound Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Multimedia Tools > Play Sound.
2. Choose a sound file using the Browse button in the Action-specific properties pane of the dialog.
3. Click the Test button if you want to try out the select sound file.
4. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
5. Assign a trigger and click OK. Your new Action appears in the Actions view.

Play Sound Options

Below is a description of the Action-specific properties available with the Play Sound Action:
Sound file - Type the directory path for the sound file you would like QuicKeys to play. The file 
must have a .wav extension in the file name.
Test - Click the Test button to verify you selected the correct sound and that the sound plays prop-
erly.
Browse - Click the Browse button to navigate to the sound file you would like to use.
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Set Audio Volume

The Set Audio Volume Action is useful when you want to be able to set every option in your sound arse-
nal with a QuicKeys trigger. For example, with a single QuicKeys trigger you can set the volume for all 
of your audio devices or just one of the available devices. The available audio devices include:

 • Master Out  • Wave   • Synth   • CD

Setting up Set Audio Volume Actions

There are two ways to create and edit QuicKeys Set Audio Volume Actions: use the Setup Wizard or use 
the Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Set Audio 
Volume button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the begin-
ning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete 
an Action, or Create/edit multiple Actions. The setup for each of these options is explained within the 
Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Set Audio Volume Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Multimedia Tools > Set Audio Vol-

ume.
2. Choose an option from the Action-specific properties pane of the dialog. For example, choose Mas-

ter Out.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different one.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use. For example, press the Shift key, the Control key, and the 2 key simultaneously.
5. Click OK. Your new Action appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action.
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Figure 10-1: The Set Audio Volume 
Action lets you adjust the volume of 
the sound output from hardware de-
vices on your computer.

Set Audio Volume Options

Below is a description of the Action-specific properties available with the Set Audio Volume Action:
Master Out - Adjusts the volume in identical increments for every audio device available on your 
computer. It’s comparable to the universal remote you have at home for your TV, VCR, and CD 
player.
Wave - Adjusts the volume for digitally sampled files on your computer. Wave files contain a .wav 
or .mpg extension and are usually quite large in size. An example of a wave file would be the harp-
like sound your computer makes when you turn it on (called “The Microsoft Sound.wav”).
Synth - Adjusts the volume for your Musical Instrument Device Interface (MIDI) files. MIDI sound 
files are typically low fidelity sounds synthesized by your computer that are much smaller in size 
than digitally sampled files. An example of a Synth file would be the music you hear when you visit 
some Web sites.
CD - Controls the volume for the computer’s CD player. Maximum - Turns the volume of the se-
lected audio device to the loudest setting.
Maximum - Maximizes the volume of the selected audio device.
Louder - Turns the volume of the selected audio device to the next highest incremental setting.
Softer - Turns the volume of the selected audio device to the next lowest incremental setting.
Toggle on and off - Turns the selected audio device alternately on and off.
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If your computer does not have access to other computers or the Internet, the information in this chapter 
will probably not be applicable to you. If, however, your computer is on a network, there are several net-
work tasks that QuicKeys can help you with. These tasks include choosing printers and network drives, as 
well as selecting Microsoft’s Dial-Up Networking settings.

Choose Printer

The Choose Printer Action is useful if you frequently switch printers on your network. For example, this 
Action can be extremely useful in QuicKeys Sequences when you want to send a fax and switch back to 
your regular printer once the fax is sent.

Setting up Choose Printer Actions

There are two ways to create and edit QuicKeys Choose Printer Actions: use the Setup Wizard or use 
the Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Choose 
Printer button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the begin-
ning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete 
an Action, or Create/edit multiple Actions. The setup for each of these options is explained within the 
Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Choose Printer Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Network Tools > Choose Printer.
2. Choose a printer from the Action-specific properties pane of the dialog.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or you can type a different name.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use. For example, press the Shift key, the Alt key, the Control key, and the O key si-
multaneously.

5. Click OK. Your new Action immediately appears in the Actions view.
6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. The 

printer you selected should immediately become the default printer.

Chapter 11: Network Tools
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Figure 11-1: The Choose Printer Ac-
tion lets you switch printers on the fly 
without having to open the system’s 
Printers control panel.

Choose Printer Options

Below is a description of the Action-specific properties available with the Choose Printer Action:
Select printer - Displays a list of all the printers to which you have access. You can add more print-
ers to this list by selecting the Printer Control Panel and choosing the Add Printer option.
Display message when printer has changed - Displays a message when your printer has been 
changed so you can print.
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Dial-up Networking

The Dial-Up Networking Action enables you to connect or disconnect from a Dial-Up Networking service 
with a simple QuicKeys trigger. It can be a big time saver if you use, for example, AOL for your home 
e-mail but also need to connect a your office through a VPN connection.

The tasks available using the Dial-Up Networking Action include:

• Connect to Dial-Up Networking service
• Disconnect from Dial- Up Networking service
• Toggle connection state
❖ Note: You must have Dial-Up Networking installed and configured on your computer for this Action 

to function properly.

Setting up Dial-up Networking Actions

There are two ways to create and edit QuicKeys Dial-Up Networking Actions: use the Setup Wizard or 
use the Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Dial-Up 
Networking button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the be-
ginning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete 
an Action, or Create/edit Multiple Actions. The setup for each of these options is explained within the 
Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Dial- Up Networking Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Network Tools > Dial-up Network-

ing.
2. Choose an option from the Action-specific properties pane of the dialog. For example, select Con-

nect to a Dial-Up Networking service.
3. Choose an entry from the Available Dial-up Networking entries field.
4. Give your Action a new name and assign it a hot key if desired. If you want to trigger this Action 

from the QuicKeys menu, select the Include in QuicKeys menu check box.
5. Click OK. Your new Action immediately appears in the Actions view.
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Figure 11-2: The Dial-up Networking 
Action lets you change your connec-
tion to the internet with ease.

Dial-up Networking Options

Below is a description of the Action-specific properties available with the Dial-Up Networking Action.
Connect to a Dial-Up Networking service - Connects to the service specified in the Dial-Up Net-
working control panel.
Disconnect a Dial-Up Networking service - Disconnects from the specified Dial-Up Networking 
service.
Toggle connection status - Connects and disconnects from a Dial-Up Networking service.
Add new connection - Opens the New Connection Wizard so you can add another service to the 
list. See Figure 11-3 for the types of services that can be added through this wizard..
Notify upon success - Displays a dialog if the new connection is successful.
Notify upon failure - Displays a dialog if the new connection is not successful.
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Figure 11-3: The New Connection 
Wizard is invoked by clicking on the 
Add new connection button. This wiz-
ard will step you through adding new 
network connections.
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Network Drives

The Network Drives Action is useful if you need to access several different network drives on a daily 
basis. The options available in the Network Drives Action include:

Setting up Network Drives Actions

There are two ways to create and edit QuicKeys Network Drives Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Network 
Drives button. Read each of the dialogs in the Setup Wizard and follow the instructions. At the begin-
ning of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, or Delete 
an Action. The setup for each of these options is explained within the Setup Wizard.

• Connect to a network volume
• Toggle connection
• Disconnect from a network volume

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Network Drives Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Network Tools > Network Drives.
2. Choose a network drive from the Action-specific properties pane of the dialog.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. If you want to trigger this Action from the QuicKeys menu, select the Include in QuicKeys menu 

check box.
5. Click OK. Your new Action immediately appears in the Actions view.
6. Close the QuicKeys Editor and trigger the Network Drives Action from the QuicKeys menu or 

with whatever other type of trigger you assigned to this Action. The network drive you specified is 
immediately selected.

Network Drives Options

Below is a description of the Action-specific properties available with the Network Drives Action:
Connect to a network volume - Connects you to a network volume.
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Disconnect from a network volume - Terminates your connection to a network drive.
Toggle connection - Alternately connects and disconnects you from a network volume or drive.
Server path - The directory path of the network volume.
Browse - Click the Browse button to navigate to the location of the network volume.
Local drive - The drive letter your computer will use to identify the selected network volume. Do 
not select any drive letters that are already in use.
Reconnect at logon - Choose this option when you want to retain drive mapping information, even 
after you restart your machine. If this option is not checked and you restart your machine, you must 
trigger the Network Drive Action to remap the drive.
Name - The user name you use to login to the selected network volume.
Password - The password you use to login to the selected network volume.
Remember name and password - Select this option if you do not want to be prompted for your 
name and password each time you trigger this Network Drives Action.
Display notification if Action succeeds - Displays a message alerting you that your map/unmap 
action was successful.
Display notification if Action fails - Displays a message alerting you that your map/unmap action 
was not successful.

  

 
 
Figure 11-4: The Network Drives Ac-
tion lets you connect to or disconnect 
from shared drives and folders on your 
network.

More About Network Drive Actions

Since QuicKeys Actions are stored under your login preferences, your user name and password infor-
mation for network drives are secure as long as other users do not know your network login name and 
password.
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The majority of many computer users’ time is spent on the web or using e-mail. QuicKeys’ internet tools 
can increase your productivity in these areas by giving you quick access to web sites and boiler plate e-
mail messaging. Toss in the ability to fill in web page text fields, toggle web form check boxes and radio 
buttons, and select from pop-up menus in a web page and you have a very powerful set of internet tools.

Instant E-mail

QuicKeys helps you make the best use of your time by providing the ability to instantly create and send 
messages containing boiler plate text and/or selected files with a simple QuicKeys trigger. The options 
available with the Instant E-mail Action include:

 • Create new message   • Create message with text
 • Send selected text   • Send recent files
 • Send selected files   • Archive attachments

❖ Note: E-mail programs that support “mailto:” handlers or that support the Mail Application Program 
Interface (MAPI) can be used with the QuicKeys Instant E-mail Action. Some of the more common 
programs that support MAPI include Outlook, Outlook Express, Exchange client/Windows Messaging, 
Eudora, Lotus Notes, and Novell® GroupWise. This list is not inclusive, so you should also ask your E-
mail vendor whether or not their software supports MAPI.

Setting up Instant E-mail Actions

There are two ways to create or edit QuicKeys Instant E-mail Actions: use the Setup Wizard or use the 
Action Properties dialog.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Instant E-
mail button. Read the pages of each wizard dialog and follow the instructions. At the beginning of the 
Setup Wizard, you are presented with options to Create an Action, Edit an Action, Delete an Action, or 
Create/edit multiple Actions. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit an Instant E-mail Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Internet Tools > Instant E-mail.
2. Select an option from the Action-specific properties pane of the dialog. For example, choose Create 

message with text and type the text you want to include in your messages.
3. If you would like to restrict the functionality of this Action to your E-mail program, select the Ac-

Chapter 12: Internet Tools
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tion Scope tab and select Program from the Scope drop-down list. Choose your E-mail program 
from the Program drop-down list that appears.

4. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 
You can use the assigned Action name or type a different name.

5. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 
you want to use. For example, press the Shift key, the Alt key, and the F7 keys simultaneously.

6. Click OK. Your new Action immediately appears in the Actions view.
7. Close the QuicKeys Editor.
8. Press the hot key or other trigger you assigned to the Instant E-mail Action. Your e-mail software 

should respond immediately to the QuicKeys Action as long as it handles mailto: or MAPI.

More About Instant E-mail

QuicKeys uses your default E-mail program for Instant E-mail Actions. Your default mail program 
must support mailto: handling or the Mail Application Program Interface (MAPI) to work with 
QuicKeys.

Instant E-mail Options

Below is a description of the Action-specific properties available with the Instant E-mail Action.
Create new message - Opens a new message window where you can type your e-mail message.
Create message with text - Opens a new e-mail message window that contains text you have previ-
ously specified.
Send selected text - If you have a block of text selected in a program, triggering this type of Instant 
E-mail Action will open a new message window containing that selected text.
Send recent files - Displays a list of recently modified files you can choose to attach and send in a 
message. You can specify the time interval QuicKeys uses to populate the list of recently modified 
files. Your choices include In the last 15 minutes, in the last 6 hours, In the last half hour, In the last 
24 hours, or In the last hour.
Send selected files - If you have a file selected, triggering this type of Instant E-mail action will 
open a new message window attaching the selected file to it.
Zip attached files - Compresses attached files. Check this option when you want to compress 
your E-mail attachments. Your E-mail client must support the Mail Application Program Interface 
(MAPI) to properly enclose the selected file(s) because attachments are not self-extracting. This 
means the recipient of your compressed files must be capable of unzipping files. When QuicKeys is 
used to attach files, the E-mail message carrying the attachment contains a line that says, “File at-
tached by QuicKeys.”
Send to mailto handler - Displays a dialog where you can choose whether to use a MAPI mail 
handler or a mailto: mail handler.
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Web Launcher

The Web Launcher Action is useful when you want to open Uniform Resource Locators (also known as 
URLs or simply “web pages”) with a single hot key. For example, you can use this Action to open your 
local Television News channel’s home page. The Web Launcher Action includes the following options:

• Open URL     • Open Text Selection As URL
• Display Netscape Bookmarks Browser • Display Internet Explorer Favorites
❖ Note: The Web Launcher Action is more versatile that its name implies. It actually supports File 

Transfer Protocol (FTP), HyperText Transfer Protocol (HTTP), and E-mail URLs. This means you 
can use the Web Launcher to visit FTP sites and Web sites, as well as to E-mail a friend or business 
colleague. For example, if you want to use Web Launcher to log you into an FTP site, you would 
type something along the lines of: 
 
 ftp://<username > :<password > @ftp.domain.com

Setting up Web Launcher Actions

There are three ways to create and edit QuicKeys Web Launcher Actions: use the Setup Wizard, use the 
Action Properties dialog, or cut and paste a URL into the QuicKeys Editor.

Using the Setup Wizard

To use the Setup Wizard, select the Setup Wizards view in the QuicKeys Editor and click the Web 
Launcher button. Read the pages of each wizard dialog and follow the instructions. At the beginning 
of the Setup Wizard, you are presented with options to Create an Action, Edit an Action, or Delete an 
Action. The setup for each of these options is explained within the Setup Wizard.

Using the Action Properties Dialog

The following instructions assume you have the Always use Setup Wizards for editing check box 
cleared in the Options dialog. See page 34 for more information. To use the Action Properties dialog to 
create or edit a Web Launcher Action, follow these steps:
1. Go to Actions view in the QuicKeys Editor and select Create > Internet Tools > Web Launcher.
2. Select the option you want to use in the Action-specific properties pane of the dialog. For example, 

select Open URL.
3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Action. 

You can use the assigned Action name or type a different name.
4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the key(s) 

you want to use. For example, press the Shift key, the Control key, and the - [dash] key simultane-
ously.
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5. Click OK. Your new Action immediately appears in the Actions view.
6. Close the QuicKeys Editor.
7. Press the hot key or other trigger you assigned to this Action. The Web site you specified should 

launch immediately.

Web Launcher Options

Below is a description of the Action-specific properties available with the Web Launcher Action.

Open URL - Opens the location specified in the URL field.

Show dialog before opening URL - Prompts you to specify which URL you want to visit.

Open text selection as URL - Opens selected text as a URL.

Display Netscape Bookmarks browser - Displays the list of Netscape bookmarks you have ac-
cumulated in a Bookmark Browser dialog.

Display Internet Explorer Favorites browser - Displays the list of Internet Explorer favorites 
you have accumulated in a Favorites Browser dialog.
URL - The Uniform Resource Locator that specifies where the specified page is located. Most URLs 
look like this: http://www.startly.com
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Web Object Click/Value

We’ve all  had to fill out a form or two on web sites, but some of us end up filling out the exact same form 
or find ourselves running through the exact same series of web links repeatedly. QuicKeys can help auto-
mate these activities with the Web Object Click and Web Object Value Actions. These Actions are nearly 
identical in nature so will be explained together.

First, here is an example of how you might use Web Object Click and Web Object Value Actions. Imagine 
you must frequently place online orders through a particular web store. Some features of your order will 
likely be the same each time, such as shipping method, additional insurance options, and shipping/billing 
addresses. With little effort a QuicKeys Sequence can be assembled that will prep the order for you each 
time it is needed, leaving you to deal only with a few details.

Manipulating objects on a web page with QuicKeys consists of three basic steps:

1. Identify the web object you want to manipulate.
2. Determine what you want to do with/to that web object, such as click it or enter text into it or put a 

check mark in it.
3. Choose the appropriate Action (Web Object Click or Value) and fill in the required fields.

 
Figure 12-1: Web forms utilize a variety of objects by which users makes their choices known. 
QuicKeys can access many of these objects, reading or setting their values, clicking them, etc. 

❖ Note: The Web Object Click and Web Object Value Actions only work with Internet Explorer!
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Which Action is appropriate?

Use Web Object Click to:
• click on text links, image links, or image map links
• click on form buttons such as Submit or Continue

Use Web Object Value to:
• set radio buttons or check boxes
• fill in text entry fields
• select items from pop-up menus

Identify the Web Object

The most difficult facet of using the Web Object Actions is identifying the object you want to ma-
nipulate so QuicKeys can play back your Action correctly. A big helper in this endeavor is the Object 
Finder tool. Simply click and drag this tool onto any web object and release. This should fill in one or 
more of the fields in the Action properties dialog. 

 
Figure 12-2: Click and drag the Object Finder tool onto a web page link, text field, button, or check box and 
release. The identifying characteristics of that web object will automatically be filled in where possible by 
QuicKeys. Once the desired object has been identified you can direct QuicKeys to click it or check/set its value.
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❖ Note: QuicKeys’ ability to identify a web object is 100% dependent upon how that object’s web 
page was built. If a web object has no ID or no Name or no Type, these values won’t auto-fill when 
using the Object Finder tool,  nor will they likely be accessible by QuicKeys to click, check, set, or 
otherwise manipulate.

Web Object Click attributes

Object ID - ID of the web object, if it has one.
Object Name - Name of the web object, if it has one.
Object Type - Type of web object.
Object Value - Value of web object

Indexes - Each attribute of a web object has an optional index number. 

Web Object Value attributes

Same as Web Object Click above, with the addition of:
Get Value - Moves the value of the web object onto the system clipboard.
Set Value - Assigns a value to the web object.

From Clipboard - Gets the value from the clipboard.
Text Entry field - User inputs the value.

Setting and Getting Values

What values can you give to a web object? Again, this is 100% up to the code behind the web page. For 
example if you want QuicKeys to pick “5-User Pack” from the pop-up list shown in Figure 12-1, you 
would be tempted to put “5-User Pack” in the Set Value field. But in reality, that item on this particular 
pop-up menu is coded with the name “5u”. The Object Finder tool inside the Web Object Value Action 
Properties dialog will be able to sort all this out for you as demonstrated by the tutorial at the end of 
this chapter.
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Tutorial 3 - Filling out a Web Form

Tutorial time! Let’s create another Action, making use of some of the more powerful features of 
QuicKeys’ Internet Tools. This tutorial will provide an example of building a Sequence to fill out a web 
form.

The Problem

“I frequently need to order a specific piece of merchandise from a web store. It would be great if 
QuicKeys provided a way to automate this for me.”

The Solution

Build a short Sequence in QuicKeys that opens a specific web page and fills out a web form when trig-
gered by selecting “Web Order” from the QuicKeys Menu. This sequence will consist of seven steps; 
the first three steps open the web page and wait for it to load. Steps 4 and 5 fill out web objects with the 
desired values. Steps 6 and 7 ask “are you sure” and then proceed to checkout.

  

Figure 12-3: The seven step Sequence 
described in this tutorial calls up an 
online web store, fills out an order form, 
presents an “are you sure” dialog, and 
clicks on the “submit” button to proceed 
to checkout.

How To

1. Open the QuicKeys Editor and select the Actions view.
2. Select Create > Sequence, a new Sequence Properties window will open.
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3. Select Insert > Internet Tools > Web Launcher in the Sequence Properties window to add the first 
step to the sequence. The Web Launcher step will open as a new window. This step is intended to 
open an Internet Explorer window to the desired web store. Fill out the Action Properties dialog 
for this Web Launcher Action as shown in Figure 12-4 and click OK to save and close the Web 
Launcher step.

     

Figure 12-4: Step 1 of the Sequence is a 
Web Launcher Action whose purpose is 
to open Internet Explorer to the desired 
web page containing an order form we 
want QuicKeys to fill out.

4. Open an Internet Explorer window and go to the following web address: http://www.startly.com/
shop/buy-qkw.html. Fill out this web form by setting the product/price pop-up list to ‘5-User Pack’ 
and checking the ‘Electronic Delivery’ radio button (please use Figure 12-1 as a reference).

5. Go back to the Sequence Properties window you were working in and select Insert > Sequence 
Tools > Wait for Window. This step will tell QuicKeys to wait until the Internet Explorer window 
has opened before continuing to the next step. Configuring the Wait for Window step may appear a 
bit daunting but it is really quite easy if you use the built in Window finder tool.

    

Figure 12-5: Step 2 of the Sequence is a 
Wait for Window Action whose purpose 
is to tell QuicKeys to wait for the appro-
priate window to open before continu-
ing onto the next step in the Sequence.

6. In the Wait for Window dialog, select the “Wait for window with specified properties” radio button 
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and select “Appears” from the “Wait until window” pop-up list. We’re telling QuicKeys to wait 
until a window with some specific properties appears before continuing; let’s define those proper-
ties:

7. Click on the “Specify window properties...” button to bring up the Window Properties dialog. 
Rather than try to figure out what all the fields in this dialog should contain, just click and drag the 
“Window Finder” tool from this dialog onto the Internet Explorer window you opened in step 4, 
and release. This will auto-fill the fields with the information that makes the target window unique 
and identifiable.

    

Figure 12-6: The Window Properties 
dialog tells QuicKeys the specifics of 
the window it should be looking for. 
Just drag the Window finder tool onto 
the desired window to auto-populate the 
fields with its defining characteristics.

8. Click OK to close the Window Properties dialog, and click OK to save and close the Wait for Win-
dow step.

9. Select Insert > Sequence Tools > Pause in the Sequence Properties window to add the third step to 
the Sequence. Configure this Pause Action for a 1 second pause. This hard pause may or may not 
be necessary on playback, but when waiting for windows to load it is often a good idea to add a 
short pause so QuicKeys does not get ahead of the operating system.

10. Select Insert > Internet Tools > Web Object Value in the Sequence Properties window to add the 
fourth step to the Sequence. This step will select the desired item from the pop-up list on the web 
form we’re using QuicKeys to fill out.

11. Click, drag and release the ‘Object Finder’ magnifying glass onto the pop-up menu in the web form 
(the web form you filled out earlier in this tutorial); this will populate the Object Name and Object 
Type fields with “sku” and “combo box”. It also fills Object Value with ‘1u’ and the Set Value field 
with ‘5u’. The Object Value field represents (in the case of a pop-up list) the initial or default value 
of a web object. In the case of this web form, the “sku” pop-up list is initially set to ‘1u’ (Single 
User Pack). The Set Value field represents the current value of the pop-up list; in the case of this 
web form and way we filled it out in step 4, the value will be ‘5u’ (5-User Pack). Click OK to save 
and close this Web Object Value step.

❖ Note: Manually determining what value goes in the Set Value field would require a user to go View > 
Source while viewing the web form in Internet Explorer.; this gives you access to the options avail-
able for a particular web object, but it isn’t pretty. Using the Object Finder tool avoids this cumber-
some method, auto-filling the current value of the web form object for you.
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Figure 12-7: Sequence step 4 is set 
up to choose the proper item from the 
product/price pop-up list in the web 
store form. Dragging the Object Finder 
magnifying glass onto a web object will 
gather data on that object and populate 
the appropriate fields. In this example 
the object has discovered the object 
name, type, and initial/default value. 
The Object Finder has also discovered 
the current pop-up list selection (‘5u’) 
and seeded the “Set Value” field with 
that information. On playback, Object 
Name, Type, and Value will be used to 
identify the proper object, and Set Value 
will be used to set that object to the 
desired value.  

12. Next we need to set up a step which will select the desired radio button from the shipping options. 
Create another Web Object Value step and use its Object Finder control to discover and populate 
the fields therein. The following values should auto-fill:
  Object Name: ship   Object Type: radio button
  Object Value: elec   Set Value: elec

 Click OK to close and save this step.
13. Select Insert > Sequence Tools > Message to create a new Message step. The purpose of this step 

is to warn the user that they’re about to submit the order form and give them a chance to cancel. 
When this step is executed a small message window will appear with an OK and a cancel button 
on it. Clicking OK will cause the sequence to proceed to the next step, clicking cancel will halt the 
sequence at that point.

 Enter text something to the effect of “You are about to submit a web order, continue?” and check 
the ‘Show OK button’ and ‘Show cancel button’ boxes. In the Step results handling area at the 
bottom of the window change the “If step fails” pop-up to ‘Stop sequence’. The default step failure 
setting would stop the sequence and warn the user that the sequence failed, but we intentionally 
caused the failure so we don’t need that warning dialog.
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Figure 12-8: Sequence step 6 puts up a 
simple warning dialog giving the user 
a chance to abort the web order. When 
configuring a Message Action with 
an OK (proceed) button and Cancel  
(stop playback) button, it is desireable 
to change the Step result handling for 
failure to “Stop sequence” rather than 
“Stop sequence and notify user”. The 
user causes the step to technically “fail” 
when clicking on the cancel button so 
there is no need to display a warning.

 

14. Select Insert > Internet Tools > Web Object Click in the Sequence Properties window to add the 
seventh and final step to the Sequence. This type of Action is nearly identical to the Web Object 
Value Action but is used only for clicking on web objects rather than setting a value. Drag and 
release the Object Finder tool over the “Proceed to Checkout” button on the web form to automati-
cally populate the fields necessary to locate and activate that button during playback. Click OK to 
save and close this step.

15. Name the Sequence something like “Web Order” and check the “Include in QuicKeys Menu” 
checkbox as shown in Figure 12-3. Click Save & Exit to close the Sequence editor window.
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Figure 12-9: Use a Web Object Click 
step to click on the “Proceed to Check-
out” button in the we web form. The 
Object Finder tool can be used to auto-
fill the necessary fields with the neces-
sary information to locate the proper 
button during playback.

Test your sequence:

If it is still open, your Internet Explorer window. Now select “Web Order” from the QuicKeys Menu in 
your system tray. QuicKeys should run open a new Internet Explorer window to the appropriate web 
page and adjust the pop-up list and the shipping setting. When the “are you sure” dialog appears, click 
OK to let the sequence finish.
❖ Note: Don’t worry about accidentally purchasing 5 more copies of QuicKeys, simply click the Clear 

Shopping Cart button when the sequence completes.
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QuicKeys Actions are great for simple, one-step tasks. However, there are times when repetitive tasks 
require several consecutive steps. For these situations, QuicKeys offers Sequences. Sequences are collec-
tions of Actions that you put together to complete a multi-step task.

The Sequence Editor (found by selecting Create > Sequence in Actions view) provides access to over a 
dozen Actions that are most suited for use within a multi-step Sequence. These Actions are called Se-
quence Tools and they include:

• Check Condition   • Insert Action   • Message
• Password vault   • Pause    • QuicKeys Event Logger
• Select Items in Dropdown List • Select Items in List  • Switch tabs
• Wait Condition   • Wait for User Input  • Wait for Window
• Window Selector

❖ Note: When you are working in the Sequence Editor new steps/Actions are added by selecting them 
from the Insert menu. This menu is at the top of the Sequence Editor window and is also accessible 
by right clicking in the list of Actions within the Sequence Editor window. 

 
Figure 13-1: The Insert menu in the Sequence Editor can be invoked from the menu bar at the top 

of the window or by right-clicking in the list of Actions in the bottom half of the window.

Chapter 13: Sequence Tools
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Check Condition

The Check Condition Sequence tool is a powerful component for more advanced QuicKeys Sequences. 
With a Check Condition Action, you can verify that a specific condition is met before proceeding to the 
next step of the sequence. For example, you can create a Sequence that checks the date and time and only 
continues between 8:00 AM and 5 PM.

Check Condition Options

Below is a description of the Action-specific properties available with the Check Condition Action.
Check file - Checks the presence of a user-specified file and optionally establishes if the file is read-
only, a specific size, or a specific version. For example, you could insert a step in your sequence that 
checked for the presence of a specific weekly report that is greater or equal to 5 bytes in size.
Check folder - Checks for the presence of a user-specified folder.

 

 
Figure 13-2: Check Condition can look for many different properties and states of files, folders, and data 

on your computer. Two examples (left to right) are Check File and Check clipboard content. 

Check window - Examines the status and/or size of windows that possess the specified Title, Class, 
and Type properties. You can populate most of the text boxes and fields in this dialog using the Win-
dow Finder tool.
To use the Window Finder tool:
1. Open the window you want to examine in your Sequence.
2. Click and hold your mouse on the Window Finder tool in the Action Properties dialog, and when 

your cursor becomes a magnifying glass, drag it over the window you want to test.
3. Release the Window Finder cursor when it is positioned over the window you want to use in your 
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Sequence. The Check window fields are automatically filled with information about the selected 
window.

  

 
 
 
Figure 13-3: Use the Window 
Finder tool to show QuicKeys 
which window to check for 
during a Check Window step. 
Just click on the magnifying 
glass tool and drag it to the 
desired window. Release your 
mouse and QuicKeys automati-
cally fills all applicable Action 
Properties buttons, checkboxes, 
fields and pop-up menus.

Check window control - Examines the status and/or state of the control using the specified Text, 
Class, and Type properties. You can populate most of the text boxes and menu in this dialog using the 
Control Finder tool. The Control Finder tool works like the Window Finder tool described earlier in 
this section.
Clipboard Content - Looks at the System clipboard for the presence of a specific data type. If the data 
type is Text an additional pop-up list is enabled allowing you to specify whether the text begins/con-
tains/ends with a certain string, or is numerical.
❖ Note: More powerful testing of the contents of the sytem clipboard can be accomplished with 

QuicKeys Variables as discussed in Chapter 5.
Check program - Verifies that a specified program exists, is running, or is frontmost on your desktop.
Check current date and time - Checks the current system date/time against the specified date/time.
Run executable and test the result value - Launches an executable or a script that returns a numeric 
result. When you choose this option, you must indicate whether the executable is a Specified file or an 
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Installed file.
When you select Specified file, click the Browse button to locate the executable you want to use. After 
you select a file, you can specify a working directory or parameters under which the executable will 
run. You can also indicate what the Sequence can expect from the executable’s return code.

Installed File - For the Installed file option to be available, you must create a QKScripts directory 
and store your scripts in that directory. Just as the Run Script Action (see Chapter 8) works, the 
scripts you add to this directory require the appropriate script engine be installed on your computer.
To create the QKScripts directory and install your script(s):

1. Create a folder called “QKScripts” in your QuicKeys directory. The path of the folder should 
be C:\Program Files\Startly\QuicKeys\QKScripts.

2. Copy your executable(s) into the QKScripts folder.
3. Click the Installed file option and select the executable file you wish to use for this condition 

check.
Check menu - Checks for the existence of a certain menu item or attributes of that menu item. If you 
know the correct information you can hand-type the menu name and select the menu source radio but-
ton. If not, you can simply use the Browse button to let QuicKeys help you gather the correct informa-
tion. Menu characteristics you can check/wait for include:

Checked: Is there a check mark next to the menu item?
Exists: Does the menu item exist or not?
Enabled: Is the menu item enabled or disabled?

❖ Note: You can tell QuicKeys to ignore any of these conditions. For example, you can select “Don’t 
Care” if you are unconcerned whether the menu item in question is enabled or disabled.

Insert Action

The Insert Action Sequence step plays an existing Action or Sequence within another Sequence. Unlike an 
Action that is copied into a Sequence, the Insert Action is automatically updated if any changes are made 
to the original Action or Sequence you inserted.

For example, an action named “database login” is a simple 4 step sequence that types username, presses 
Tab, types password, clicks OK. This could be used inside another sequence in two ways, either by 
copying and pasting those 4 steps into another larger sequence, or by calling the original database login 
sequence with an Insert Action step.
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Figure 13-4: Insert Action lets you place one Action or Sequence inside another, creating 

modular Sequences whose parts can be reused by multiple additional Sequnces.

Message

Use the Message Sequence tool to create a custom dialog that appears at a designated point in your 
Sequence. This can be used as an “are you sure?” warning dialog, or even as a manual if/then decision 
within the Sequence (the user can decide whether or not the Sequence will proceed at this point).

Message Options

Below is a description of the Action-specific properties available with the Message Action.
Message to display - The text you want to appear in your custom dialog.
Show OK button - Displays an OK button in the Message dialog. Clicking this button will make 
the Message step “succeed” and the Sequence will continue.
Show Cancel button - Displays a Cancel button in the Message dialog. Clicking this button will 
make the Message step “fail” and the Sequence will stop or jump to a specified step depending on 
how you set up the Step results handling for this message step.
Continue automatically after X seconds - Stops looking for user input “X” seconds after the Mes-
sage dialog appears. Putting a Message step at the beginning of a Sequence is a good way to warn 
users that a Sequence is about to run. Having it Continue automatically after X seconds gives a user 
(if present) time to cancel it but it will run anyway if left untouched.
Text entry field - Enabling this checkbox adds a text entry field to the Message dialog when it is 
displayed to the user. This text field can be used in the following ways:
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Put text on clipboard - Whatever the user types into the Message dialog will be moved onto the 
system clipboard for eventual pasting, or for testing with QuicKeys’ Check Condition steps.
Type text - Whatever the user enters is in turn typed into the front-most document or program.
Type text with return - As “Type text” above, but QuicKeys will append a return/line feed. 

 
Figure 13-5: QuicKeys can display a Message dialog as a warning that a 

Sequence is about to run, or as a user decision point in a Sequence. 

Password Vault

The Password Vault tool is a secure way to use passwords within your QuicKeys Sequences. The pass-
words you put into Password Vault are blacked out as you type them in, and they’re encrypted when 
stored.

Password Vault Options

Below is a description of the Action-specific properties available with the Password Vault Action.
Password - The password you want QuicKeys to type for you.

Pause

The Pause Action is useful if you need to direct a QuicKeys Sequence to wait for a specified length of 
time before proceeding with the Sequence. With Sequences, timing is everything and sometimes hard 
pauses are necessary to give your computer time to catch up with QuicKeys’ commands.

Pause Options

Below is a description of the Action-specific properties available with the Pause Action.
Duration - The length of the pause in measurements of Seconds or Milliseconds. These options give 
you precise control over the duration of your pause so the Sequence takes no longer than necessary 
to complete.
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QuicKeys Event Logger

The QuicKeys Event Logger provides you with the ability to write out events to the System Event log or 
to a user-determined log file.

Event Logger Options

Below is a description of the Action-specific properties available with the QuicKeys Event Logger Ac-
tion.

Type of Event - Select from the pop-up to indicate whether your custom event is to be of type Error, 
Warning, or Information.
Event Description - Enter the text you want written to the log file.

Select Items in Dropdown List

Use Select Items in Dropdown List (see Figure 3-7 for an example of a Dropdown list) to select items 
from specific combo box controls. You help QuicKeys identify which window, which dropdown list on 
that window, and which item in that control it should be looking for and it will make the designated selec-
tion when the sequence is played back.

Select Items in Dropdown List Options

Below is a description of the Action-specific properties available with the Select Items in Dropdown 
List Action.

Browse - Click the Browse button to identify the dropdown list containing the item you want to 
select. It is unlikely you’ll know what to enter into the Control Property fields so using the Control 
Finder tool is advised. Click and drag the Control Finder to the drop-down list from which you want 
QuicKeys to pick an item.
Specify window properties - By default QuicKeys will look for the list box in the front-most 
window. You can be more specific if so desired by clicking Specify window properties and using the 
Window Finder tool.
Select item - Tell QuicKeys which item to select by its index or its text name, or choose to unselect 
all items.
Double-click item - QuicKeys will double-click the desired list item if this box is checked.
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Figure 13-6: QuicKeys can select items from combo boxes (also known as drop-down lists). Locating and 

identifying the proper combo box and window that contains it is simplified by QuicKeys’ dragable 
Control and Window Finders. Just click and drag to the target control and window to auto-fill 

the information necessary for QuicKeys to find these controls again during playback.
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Figure 13-7: Examples of List and Drop-down List controls that QuicKeys can manipulate 

with its Select Items in List and Select Items in Dropdown List actions.

Select Items in List

Use Select Items in List (see Figure 3-7 for an example of a List) to select items from a specific list box. 
You help QuicKeys identify which window, which list on that window, and which item in that list it 
should be looking for and it will make the designated selection when the sequence is played back.

Select Items in List Options

Below is a description of the Action-specific properties available with the Select Items in List Action.
Browse -  Click the Browse button to identify the list containing the item you want to select. It is 
unlikely you’ll know what to enter into the Control Property fields so using the Control Finder tool 
is advised. Click and drag the Control Finder to the list you from which you want QuicKeys to pick 
an item.
Specify window properties - By default QuicKeys will look for the list box in the front-most 
window. You can be more specific if so desired by clicking Specify window properties and using the 
Window Finder tool.
Do action - Choose to Select a single item, Unselect a single item, Select a range of items, Unselect 
a range of items, or Unselect all items in the list. The Select by options change depending upon 
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which action you choose.
Select by - Select an item by index or text and indicate whether or not the text must exactly match 
the text you specify in the Start text box. You can also choose to double-click the selected item.

Switch Tabs

QuicKeys can be used to switch between tabs in a window. The tabbed window interface is common in 
control panels and properties dialogs throughout the Windows operating system. Like the Select Items 
in Dropdown List Actions, Switch Tabs needs to have the window and the specific set of tabs it will be 
working in specified when the Action is created.

Switch Tabs Options

Below is a description of the Action-specific properties available with the Switch Tabs Action.
Find tab control - Click the Browse button to identify the tab control on which to operate.
Find tab control on window - Click the Specify window properties button to display the Window 
Properties dialog. Using the Window finder in the Window Properties dialog enables you to auto-
matically populate the text fields and buttons in the Action Properties dialog.
Select tab - Select the desired tab by its item index or by its text name and indicate whether or not 
the text must exactly match the text you specify.

Wait Condition

The Wait Condition Sequence tool is a powerful component for more advanced QuicKeys Sequences. 
With a Wait Condition Action, you can pause the playback of a Sequence until a specific condition is met. 
For example, you can create a Sequence that pauses playback and waits for a specific program to open 
before continuing. Wait Condition can be especially useful for handling timing for Actions running on 
unattended workstations and servers.

Wait Condition Options

Below is a description of the Action-specific properties available with the Wait Condition Action.
Wait for file - Waits for a certain attribute of a specified file to reach a particular value. You can wait  
for a file’s version number to change, wait until a file is no longer ‘read-only’, or wait for its size 
to reach a certain point. For example, you could insert a step in your sequence that waits for a web 
server’s log file to reach 5MB in size.before continuing the sequence which might archive that log file 
and create a new one.
Wait for folder existence - Pauses playback of a Sequence until a user-specified folder exists.
Wait for window control - Examines the status and/or state of the control using the specified Text, 
Class, and Type properties. You can populate most of the text boxes and menu in this dialog using the 
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Control Finder tool. The Control Finder tool works like the Window Finder tool described earlier in 
this section.

 
Figure 13-8: Wait Condition can look at and wait for state changes in many different properties of files, folders, 

and data on your computer. Two examples (left to right) are Wait for program and Wait for date and time. 

Wait for clipboard content - Pauses playback and waits for the presence of a specific data type on the 
system clipboard. If the data type you are testing for is ‘Text’, an additional pop-up list is enabled al-
lowing you to specify whether the text begins/contains/ends with a certain string, or is numerical.
❖ Note: More powerful testing of the contents of the sytem clipboard can be accomplished with 

QuicKeys Variables as discussed in Chapter 5.
Wait for program - Waits for a specified program to match a certain state, such as: is running or is not 
running, is front-most or is not front-most.
Wait for date and time - Halts playback until the specified date/time before continuing. Options in-
clude checking both date and time or only one of the two.
Wait for menu - Halts playback until a specific menu item meets certain conditions. If you know the 
correct information you can hand-type the menu name and select the menu source radio button. If not, 
you can simply use the Browse button to let QuicKeys help you gather the correct information. Menu 
characteristics you can check/wait for include:

Checked: Wait until a check mark next to the menu item appears or disappears.
Exists: Wait until a specific menu item appears or disappears.
Enabled: Wait until a menu item becomes enabled or disabled.

❖ Note: You can tell QuicKeys to ignore any of these conditions. For example, you can select “Don’t 
Care” if you are unconcerned whether or not the menu item in question has a check mark beside it.
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Wait for User Input

Direct your Sequence to wait for user input, such as a keystroke or a mouse click, before proceeding with 
the Sequence. You can have the Sequence wait for any keystroke, a specific keystroke, or a specific mouse 
click. Click one of the modifier check boxes to use a specific modifier key in combination with the mouse 
button you selected. This type of Sequence step is useful if there is a point where a user must intervene to 
enter some data or double check that the Sequence is playing back properly.

Wait for Window

The Wait for Window Sequence tool gives you the ability to specify which window or what type of 
window you want QuicKeys to look for when it is running through a Sequence. For example, if your Se-
quence opens several windows and you want to choose an option in the window named Browser, you just 
need to specify Wait for window whose title contains Browser in the Sequence Action Properties dialog. 
Sequence steps of this type are useful for eliminating the uncertainty of Pause steps; a program or window 
may not always take a fixed amount of time to open, it depends on many factors. Waiting for a specific 
window to actually appear is a much more reliable timing method.

Wait for Window Options

Below is a description of the Action-specific properties available with the Wait for Window Action.
Wait for window whose title contains - Type the name that appears in the window’s title bar in this 
box.
Wait for Window with selected properties - Click the Select properties box to display the window 
selection dialog.
Window Properties - Choose the properties a window must possess to satisfy the Wait command. If 
you select the Window finder icon, wait until your cursor becomes a magnifying glass and drag it to 
the window you want to select. When you drag the Window finder icon, all the other Window Selec-
tor fields are filled with information.
• Window name is the name in the title bar.
• Window class can be populated using the Window finder tool.
• A Top Level Window is a program or system window. A Popup Window is a secondary dialog 

within a program.
• Click the Window finder icon and drag it to the window you want to select in your Sequence. As 

you drag, your cursor becomes a magnifying glass and the Window name, class, and type fields 
change dynamically, depending on where the cursor is positioned.

• Select the Hide QuicKeys Editor check box when you want the Editor dialog to disappear while 
you use the window finder tool.

Wait until window - Waits until the window appears, disappears, becomes active, or becomes inac-
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tive.
Give up after X seconds - Stops looking for the Action “X” seconds after this step of the Sequence 
is triggered.

Window Selector

Use the Window Selector to choose a program window in a Sequence. Click the Specify window proper-
ties button to display the Window Properties dialog. Using the Window finder tool in the Window Prop-
erties dialog enables you to automatically populate the text fields and buttons in the Action Properties 
dialog.

Window Selector Options

Below is a description of the Action-specific properties available with the Window Selector Action.
Select window whose title contains - The name of the window for which you want the Sequence to 
search.
Select window with selected properties - Enables the Select Properties button.
Select Properties - Select the properties that will idenfity the desired window.
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QuicKeys Sequences are a step up in power from simple QuicKeys Actions and thus add a bit more com-
plexity in setting them up and utilizing them most effectively. Not only do you need to consider how best 
to string multiple Actions together to make a usable Sequence, you also need to understand some added 
features introduced in the Sequence editor.

Overview of Sequences

Building Sequences can be challenging unless you have a multi-step task clearly mapped out in your 
mind. Even then, it’s important to know how QuicKeys Sequences work so you can make the most of 
their power and flexibility. There are two basic tasks you must complete when you build a Sequence:

• You must record or manually create the individual Actions you want to include in the Sequence.
• You will likely need to test and adjust your Sequence.

❖ Note:  As you begin building Sequences with QuicKeys, remember that Sequences can be created a 
number of different ways and still be successful. There is no “right way” to build a QuicKeys Sequence.

An example of a simple multi-step task you can replace with a QuicKeys Sequence is logging into a 
database and preparing to edit it. Figure 14-1 illustrates how QuicKeys Sequences can help you automate 
this type of task. All you have to do is press the assigned QuicKeys trigger and you’re free to grab a cup 
of coffee or dig through your files while the sequence runs its course.

 
Figure 14-1: An example of turning a series of related actions into a QuicKeys Sequence.

Recording Sequences

Recording is an easy way of creating multi-step Actions. Typically recordings will require some hand 
editing to work efficiently, but it’s an excellent way to not only build the foundation of a new QuicKeys 
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solution, but also gives insight into how QuicKeys interprets and interacts with your computer. There are 
three ways you can select the Start Recording option:

• From the QuicKeys menu
• From the File menu in the QuicKeys Editor
• With a Start Recording hot key created using the QuicKeys Controller Action.

When you start recording, a Recording toolbar appears and you are “live”. This means that QuicKeys 
is now watching everything you do on your computer. When you finish the tasks you want QuicKeys to 
record, click the Stop button on the Recording palette. The Sequence Editor automatically appears when 
you click Stop. Every task you just completed is listed in the lower half of the Sequence Editor dialog. 
You can also use the pause button to temporarily halt and resume recording if you need to do some task 
you don’t want recorded into the Sequence.

    

Figure 14-2: The Recording Palette 
appears when QuicKeys is in record 
mode. When in record mode, QuicK-
eys is watching your actions and 
building a Sequence which can then be 
edited and played back at any time.  

❖ Note: As you become more familiar with QuicKeys, in some cases you may find it easier to manu-
ally create Sequences and forgo the recording feature.

The Sequence Editor

The Sequence Editor enables you to create and modify Sequences. You can access the Sequence Editor a 
couple of different ways:

• Create a new Sequence by going to Actions view and selecting Sequence from the Create menu.
• Create a new Sequence through QuicKeys recording feature.
• Edit an existing Sequence by going to Actions view and double clicking on it.

Major features of the Sequence Editor are explained on page 17 of this manual and there is also a tutorial 
showing use of the Sequence Editor on page 36.

Sequence Editor Components

The Sequence Editor is organized similarly to the Action Properties dialog for any QuicKeys Action; 
exceptions are as such: 
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The Menu Bar

The Sequence Editor has a menu bar at the top of the window containing File, Edit, and Insert [Action] 
menus.

File Menu

Record More - Puts QuicKeys back in recording mode, adding new steps to 
the existing Sequence. 
Print - Prints the current Sequence. 
Print Setup - Configure the print output before printing. 
Exit - Close the Sequence Editor window without saving the Sequence. 
Save & Exit - Save the Sequence and close the editor window.

The Repeat Tab

In some cases you may want a Sequence to run a number of times in succession without having to 
press its hot key repeatedly. The Repeat tab lets you set a Sequence to repeat automatically a specified 
number of times, or it can prompt you to enter the number of times to repeat whenever it is triggered.

Edit Menu

Cut - Cut the selected step or steps from the Sequence. 
Copy - Copy the selected Sequence step or steps. 
Paste - Paste cut/copied step or steps into the Sequence at the insertion point. 
Delete - Delete selected Sequence step or steps. 
Select All - Select all steps in the Sequence. 
Properties - Open and edit the selected Sequence step.

Insert Menu

The Insert menu is similar to the main editor’s Create menu, but instead of 
creating new independent Actions it inserts new Actions into the current Se-
quence. Select an Action from this menu and it will appear in your Sequence 
as a new step wherever the insertion point is. You can even insert new Se-
quences inside the current Sequence, a QuicKeys subroutine if you will.
❖ Note: The Sequence Tools submenu contains Actions that are useful mainly 

in Sequences, but you may find some of them would be benefit you as 
stand-alone Actions. If so, feel free to create one-step Sequences for these 
occassions. 
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The Step ID and Description Columns

The lower portion of the Sequence editor lists the steps that are in that Sequence and their step num-
bers. Each of the steps listed can be double-clicked to open for editing or setting step results behavior.

The Result Column

The Result column displays the chosen Result Handling options selected for a particular step in the Se-
quence. You can alter the step result behavior to customize how success or failure of a step is handled.

Using the Result Handling Feature

When you build Sequences, you may discover that your Sequence encounters unexpected conditions that 
can keep it from completing its assigned task successfully. To resolve this issue, the QuicKeys Sequence 
Editor uses built-in result handling. This essentially means that you can tell each step of the Sequence 
what to do if it comes across unexpected dialogs or other items. That way, you don’t waste your time 
watching your Sequence to ensure it doesn’t run into any obstacles while it’s running.

Result handling can also be used to build logic into a Sequence. For example, if a Button Click step fails 
because the button is not found, this failure can be used to tell the Sequence to jump ahead to a step fur-
ther along or even backward in the Sequence, skipping steps or repeating steps already played. While any 
Action’s results behavior can be altered to add logic to a Sequence, the combination of result handling and 
Check Condition Actions allow even more branching and looping flexibility.

In the If step succeeds and If step fails lists of the Action Properties dialog, you can direct a particular step 
in the Sequence to Stop the Sequence, Stop the Sequence and notify user, Continue to the next step, or 
Jump to a specific step. Each result handling option is represented by a different icon that displays in the 
Sequence Editor’s Result column. All step results options are listed in the following table:

Results 
Icon

Description

Continue to next step
Stop Sequence (does not notify user)
Stop Sequence and notify user
Jump to step (specify step)
Fail Sequence (used only with subordinate Sequences)
Fail Sequence and notify user (used only with subordinate Sequences)

Each step of a Sequence will either succeed or fail as it is played. You can tell QuicKeys what to do in 
either case on every step. By default each new Sequence step is set up to “Continue to next step” if the 
current step succeeds and to “Stop Sequence and notify user” if the current step fails. You can double-
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click the icons to change the result handling option for a specific step.

 
Figure 14-3: Step result icons are displayed to the right of each step in a Sequence, letting you know at a glance 
what QuicKeys is supposed to do when a step either succeeds or fails. Double-click on a step to open that step’s 
Action Properties dialog containing two Step result handling pop-ups; one for step success and one for failure.

Editing Failed Sequences

If QuicKeys is unable to complete a step in your Sequence that uses the “notify user” result handling 
option, an alert window appears. Click OK to go to the failed step. Click Cancel to stop the attempted 
playback of the Sequence.

Editing Sequences

The Sequence Editor gives you the tools to correct problems in your Sequences or fine-tune their behav-
ior.. Editing a Sequence can involve rearranging step order, inserting steps, deleting steps, or altering the 
properties and result handling of existing steps.

Inserting Steps

You can insert new steps into your Sequence by selecting them from the Insert menu and configuring 
them in the Action Properties dialog that appears. When you insert a new step it is placed below the 
insertion point - the red line that runs horizontally through the list of steps in your Sequence editor.
❖ Note: The insertion point can be moved around by clicking on it and dragging it up or down in the 

steps list.
In addition to the Insert menu, new steps can be created by selecting an existing step and copying it 
(Ctrl+C or right-click for contextual menu), then pasting it (Ctrl+V or right-click for contextual menu) 
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where the insertion point is.
You can also drag-and-drop Actions from the QuicKeys Editor’s Action list to the insertion point in the 
Sequence Editor.

Rearranging Steps in a Sequence

Rearrange Sequence steps by dragging-and-dropping them in the desired location within the Sequence 
Editor.

Renaming Sequences

To rename a Sequence, open the Sequence you want to rename. Then, make your changes to the Se-
quence name and press the Enter key. You can also rename any Action or Sequence from the Actions 
view of the main editor window. Just click on the name of an Action or Sequence and it will go into 
edit mode; change the name and press Enter to confirm.

Deleting Sequence Steps

To delete steps in a Sequence, open the Sequence Editor, select the step you want to delete, and press 
the Delete key.

Sequence Tips

There are some methods you can use when you build Sequences that help ensure that they function prop-
erly. This section provides some basic tips for building QuicKeys Sequences.

• During recording, don’t click taskbar buttons; instead, use Alt+Tab to select a different program. The 
taskbar buttons frequently rearrange themselves on your taskbar, so clicking on them is not a reliable 
method of choosing them in a Sequence.

• Use the keyboard to select options whenever possible. Keyboard selections are more reliable than 
mouse clicks. This is important for recording menu selections as the menu objects in many programs 
don’t behave as menus beneath the surface where QuicKeys does its watching and recording.

• Make your movements slow and deliberate while recording.
• Do not use a mouse wheel when you record your Actions.
• Insert Pauses or Wait steps in your Sequences if you are having problems getting your Sequences to 

play back correctly.
• Use the “Type Text” function to select items in lists. For example, it’s preferable to type the first few 

letters of an item in a drop-down list to select it rather than using your mouse to select it.
• Do not grab a scroll bar to scroll through a list in a Sequence. Instead, use the Page Up and Page 

Down keys.
• When you look at the results of a recorded Sequence in the Sequence Editor, it is normal for tabs and 
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returns to be displayed as Type Keystroke Actions.
• As a matter of practice, you should not select items in the status area of the taskbar, or “tray,” during a 

recording because they may not always be located in the same place when you trigger your Sequence.
• If you have a choice, use Ctrl+C, Ctrl+X and Ctrl+V to Copy, Cut and Paste rather than drag-and-

drop or contextual menus via right-clicks.

Subordinate Sequences

Subordinate Sequences, or “Sub-Sequences,” are Sequences that are embedded within other Sequences. 
This feature allows you to break a larger task into smaller tasks, which simplifies creating and trouble-
shooting complex Sequences.

Creating Subordinate Sequences

You can create subordinate Sequences inside a Sequence you are editing by selecting the Sequence 
option from the Insert menu. You can tell the difference between the Sequence Editor and the Sub-
Sequence Editor by looking at the tabs. The Sequence Editor has five tabs: General, Repeat, Toolbars, 
Action Scope, and Timed Triggers. The Sub- Sequence Editor only has three tabs: General, Repeat, and 
Step Results.

❖ Note: You can also drag-and-drop Sequences from the Actions view into an open Sequence edi-
tor window to create Sub-Sequences. This inserts a copy of the dragged Sequence into the current 
Sequence. Editing the original Sequence you dragged in will not alter the copy contained as a sub-
Sequence.

How a Subordinate Sequence Works

To better understand Sub-Sequences, take a look at the following abstracted example. The master 
Sequence contains 5 steps, the third one calls the Sub-Sequence. Upon reach step 3, the playback of 
Sequence steps switches from the master to the subordinate Sequence. The three steps of the Sub-Se-
quence are played back before the final two steps of the master are played.

Master Sequence
1 Action step
2 Action step Sub-Sequence
3 Subordinate Sequence step ---------> 1 Action step

2 Action step
<---------------- 3 Action step

4 Action step
5 Action step
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Sub-Sequence Editor

The Sub-Sequence Editor is composed of three tabs: the General tab, the Repeat tab, and the Step Re-
sults tab. The General and Repeat tabs behave just like those in the standard Sequence editor.

Step Results Tab - Choose how you want your Sub-Sequence to react to successes and failures. The 
success and failure pop-ups work like those for individual Sequence step results handling, but in the 
case of Sub-Sequences they tell QuicKeys what to do if the subordinate Sequence fails rather than 
an individual step.
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This section provides tips for using QuicKeys, describes solutions for some common issues you may 
encounter when using QuicKeys, and discusses how to back up your QuicKeys data.

Backing Up Your QuicKeys Data

QuicKeys maintains your Actions, Toolbars, and Clipbooks in one location. You can drag these items to 
a second hard drive, network storage location, or burn them to a CD to back them up. The can easily be 
restored by dragging them back to their original locations.

Back it up

1. Exit QuicKeys.
2. Navigate to C:\Documents and Settings\<user>\Application Data\Startly
3. Locate the QuicKeys folder inside and copy it to your backup location.

Restore it

1. Exit QuicKeys.
2. Copy your backed up QuicKeys folder into the C:\Documents and Settings\<user>\Application 

Data\Startly folder.
❖ Note: Overwriting one QuicKeys data folder with another will destroy all of the Actions, Toolbars, 

and Clips in the folder being overwritten. If you need to merge archived data with current data, use 
the methods discussed in Appendix E.

Helpful Tips

• You can drag files into the QuicKeys Editor to create Open Actions.
• You can drag text to the QuicKeys Editor to create Type Text Actions.
• Cut and paste URLs into the QuicKeys Editor to quickly create Web Launcher Actions.
• Get a bit more help with the process of creating and editing Actions by checking the “Always use 

Setup Wizards for editing” check box in the View > Options dialog of the main editor window.
• You can right-click an Action in the QuicKeys Editor and choose Cut or Copy from the contextual 

menu that appears. You can then paste it to duplicate it, or open a Sequence and paste it inside as a 
new step in that Sequence.

• Press Control+Tab to insert a tab character into the Type Text Action Properties dialog.
• Hold your mouse button down when assigning certain keys as hot key triggers. Keys like “Enter” 

and “Esc” have special meaning and will not be assigned as hot keys unless the left mouse button is 
depressed when you assign them as hot keys.

• If you use Web Launcher with the America Online (AOL) browser, Internet Explorer is launched 
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rather than the AOL browser.
• If you want the hot help that appears over toolbar buttons to be more descriptive, change the name of 

the Action represented by the toolbar button. The hot help pop-ups are filled by the information you 
provide in the Name field of your Actions.

• Press Ctrl+Esc to stop Quick Type while it is typing text.

Troubleshooting

• Installation must take place while logged in as an administrator or as a user with administrative rights.
• Make sure you are very careful about assigning single keys as your hot key triggers. For example, 

assigning the “I” key for the Open Internet Explorer Action could get irritating after a few minutes of 
trying to type the letter “I”.

• If you are consistently having problems with the same program when you are recording sequences, 
choose to Disable smart recognition within the QuicKeys Controller Action.

• Desktop Scope is limited to the actual desktop being active. It does not include hard drive windows.
• The “Windows Specials Up one folder” Action does not navigate up one folder level if you are using 

it within a standard Windows Explorer window. It only works within Open or Save dialogs.
• If one of your QuicKeys triggers suddenly doesn’t work, make sure you don’t have a QuicKeys dia-

log open. When a QuicKeys dialog is open, the QuicKeys menu in the system tray has a red X over it.
• If you only see a few buttons in your Setup Wizards view, make sure you have “All Wizards” selected 

in the workspace pane (left side of the main editor window).
• You must exit the Clipboard Editor before you can see your newly added clips in the Prompt for item 

to paste window.
• You must have an insertion point available (blinking cursor inside a text field) before the QuicKeys 

Clipboard paste function works properly.
• If you delete, rename, or move custom icons that are used in toolbars, the toolbar button that used that 

icon will no longer display that graphic.
• It is possible to add toolbar buttons to toolbars that have a different scope than the Actions represent-

ed by the toolbar buttons. This capability may keep the Action that is triggered with the toolbar button 
from functioning properly. For example, a toolbar button representing a Microsoft Word Action can 
be added to a toolbar that only works in Internet Explorer.

• If you are using a firewall and are having difficulty connecting to a remote time server, check that 
ports 37 or 123 are open. See your network administrator for more information.

• If you are experiencing frequent timeouts when you select Check for QucKeys updates, check your 
Internet connection. If your Internet connection is functioning properly, call Startly Technology’s 
technical support team.
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Multi-user Workstations

If your computer is on a network, you probably have to provide your user name and password when you 
start up your computer. Actions you create under this identity are stored in a preference file that is linked 
to your user name and password. The benefit of this architecture is that multiple users can log into the net-
work from the same workstation, yet retain their own personal QuicKeys Actions. The process is invisible 
to you, but it’s important to know if you are concerned about your Actions being used by someone else.
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This chapter discusses how to create icons that can be used in QuicKeys toolbars. The ability to create 
your own toolbar icons enables you to completely customize how QuicKeys toolbars look and function.

Using Bitmap Images

If you have a company logo or some other graphic saved as a bitmap, you can use it in a QuicKeys 
toolbar. Unlike icons, QuicKeys toolbars save bitmap images internally, so even if you delete the original 
image, your toolbar icons will remain intact.

To use a bitmap image in your toolbar:

1. Right-click the toolbar icon you want to replace and select Set icon from bitmap. A standard Open 
dialog appears.

2. Navigate to the bitmap image you want to use.
3. Select the bitmap image and click Open. The bitmap image appears as a button on your toolbar.

Restoring Default Icons

If you don’t like the button changes you made to your QuicKeys toolbar, you can easily restore your icon 
buttons to their original appearance. Just right-click the toolbar button you want to replace and select 
“Restore default icon”.

Creating an Icon

If you know how to create icons, this section is for you. The first step in using one of your own icons in 
a QuicKeys toolbar is creating the icon. Icons require the .ico extension in the file name and they must 
equal 16x16 or 32x32 pixels.

The following example uses Microsoft’s Paint program, since it installs with most Windows systems. 
However, you can also use other graphics programs to create icons, such as Adobe Photoshop.

To create an icon:

1. Open the Paint program that is installed with standard installations of Windows.
2. Select Attributes from the Image menu.
3. In the Attributes dialog, type 32 in the Width and Height fields.
❖ Note: You can also type 16 in both fields if you want to create a smaller icon.

4. Select Pixels in the Units area to use pixels as your unit of measurement.
5. Select whether you want to use black and white or colors in your icon.
6. Click OK when you are done. A blank square appears in the Paint dialog.

Appendix B: Custom Toolar Icons



186

Appendix B - Custom Toolbar Icons

7. Use the tools in the Paint program’s tool palette to create an image.
8. Select Save as from the File menu.
9. Navigate to the location on your hard drive where you want to save this icon.
10. Type a name for the icon in the File name box. For example, type greenface.ico to mark the file as 

an icon file.
11. Select 24-bit Bitmap from the Save as type drop-down list.
12. Click Save. The new icon is saved to the location you specified.

Setting the Icon in QuicKeys

The next step in customizing your toolbar buttons is adding your new icon to your toolbar buttons.
To set a custom toolbar icon:
1. Right-click a button on a toolbar button.
2. Select Set icon from file.
3. Click the Browse button in the Select Icon dialog.
4. Navigate to the custom icon you just created.
5. Choose the icon and click Open. The Select Icon dialog appears.
6. Select the icon in the Select Icon dialog and click OK. The new icon appears immediately on the 

toolbar you selected.
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There are some key combinations that QuicKeys cannot use as hot keys because they are reserved for op-
erating system functions. This appendix lists the reserved hot keys along with a brief explanation of why 
they cannot be used.

Key Combination Why it can’t be used 
F1 Opens QuicKeys Help feature
Windows+E Starts Windows Explorer
Control+Esc Opens the Start menu
Alt+Tab Switches to the next program listed in the taskbar
Windows+Tab Selects the next taskbar button
Windows+F Opens a search window to locate files and folders
Windows+Ctrl+F Opens a search window to locate networked computers
Windows+F1 Opens Windows online Help
Windows+R Opens the “Run” dialog
Windows+Pause Opens the System Properties control panel
Windows+D Shows the Desktop
Windows+M Minimizes all open windows
Windows+Shift+M Maximizes all open windows

Appendix C: Reserved Hot Keys
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The top of the QuicKeys Editor window contains a menu bar with many options. What follows is a 
description of each item in each menu on the QuicKeys Editor menu bar. These descriptions assume the 
QuicKeys Editor is in Actions view unless otherwise stated.

 
Figure D-1: The File, Edit, and View menus are located at the top of the QuicKeys Editor window.

File Menu

• Connect to Action Folder... - Selecting this item allows you to link QuicKeys to more than one set of 
QuicKeys Actions. Navigate to a location where QuicKeys Actions exist and click OK to gain access 
that folder full of Actions. See Appendix E for more information on sharing Actions.

• Disconnect from Action Folder... - Selecting this item will disconnect your copy of QuicKeys from 
the Action folder you have selected in the Workspace pane of the QuicKeys Editor. See Appendix E 
for more information on sharing Actions.

• Start Recording - Puts QuicKeys in recording mode. When in recording mode this menu item changes 
to “Stop Recording”.

• Record One Action - Records your next mouse click or keystroke as a new QuicKeys Action.
• Import... - Import QuicKeys Actions that have been previously exported to a ‘.qkx’ file.
• Export Selection... - Exports all selected Actions to a ‘.qkx’ export file.
• Print... - Prints a QuickReference Card listing the Actions currently visible in the QuicKeys Editor, 

along with their hot key, a Description, and additional trigger indicators.
• Print Setup... - Choose printer and page setup for printing.
• Exit - Closes the QuicKeys Editor window, leaves the QuicKeys Engine running.

Appendix D: Editor Menu Bar
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Edit Menu

• Cut/Copy/Paste/Delete - Standard editing commands. If you have an Action, Toolbar, Toolbar Button, 
or Clip selected, you can use these menu items to cut/copy/paste/delete that item or items.

• Select All - Selects all of the Actions, Toolbars, Toolbar Buttons, or Clips visible in the main editor.
• Properties - Opens a selected Action or Toolbar’s properties dialog for editing.
• Advanced

• Toolbars - Opens the selected Action’s properties dialog directly to its Toolbars tab.
• Action Scope - Opens the selected Action’s properties dialog directly to its Action Scope tab.
• Event Triggers - Opens the selected Action’s properties dialog directly to its Event Triggers tab.

• Set Hot key - Puts the selected Action in hot key editing mode.
• Clear Hot key - Removes the hot key from the selected Action.
• Rename - Puts the selected Action/Toolbar/Button/Clip in rename mode.
• Debug Actions - Puts QuicKeys in Debug mode to help you trace errors in playback of Sequences 

and Actions.
• Trigger Action - Triggers selected Action causing it to execute.

View Menu

• Toolbar - Show/Hide the toolbar at the top of the QuicKeys Editor window.
• Format bar - Show/Hide the formatting bar at the top of the QuicKeys Editor window.
• Status bar - Show/Hide the status bar at the bottom of the QuicKeys Editor window.
• Large Icons - Displays the contents of the View pane (right half of the QuicKeys Editor window) us-

ing large icons.
• Small Icons - Displays the contents of the View pane using small icons.
• List - Displays the contents of the View pane as a simple list.
• Details - Displays the contents of the View pane as a detailed list.
• Refresh - Refreshes the contents of the View pane.
• Options... - Opens the Options dialog, explained on page 34 in Chapter 3.
• Plug-ins... - Opens the QuicKeys Plug-in Manager dialog, explained in on page 29 in Chapter 3.
• Show Variables... - Opens the Variables window where you can create new QuicKeys variables, de-

lete them, and set their value.
• Show Equation Tester... - Opens the Equation Tester window where you can enter and test equations 

for use with QuicKeys Variables.
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Figure D-2: The Go, Create, and Help menus are located at the top of the QuicKeys Editor window.

Go Menu

• Actions - Switches the QuicKeys Editor view to Actions mode.
• Toolbars - Switches the QuicKeys Editor view to Toolbars mode.
• Clipbooks - Switches the QuicKeys Editor view to Clipbooks mode.
• Setup Wizards - Switches the QuicKeys Editor view to Setup Wizards mode.

Create Menu (Actions view)

• Sequence - Opens a new Sequence Properties window. This window becomes an Action itself, con-
taining one or more other Actions as steps.

• All other menu items in the Create menu create new QuicKeys Actions when selected.

Create Menu (Toolbars view)

• New Toolbar - Creates a new toolbar.
• New Button - Creates a new button on the selected toolbar.
• Toolbar Button Wizard - Opens a wizard to guide you through adding buttons to a toolbar.

Create Menu (Clipbooks view)

• New Clip Group - Creates a new folder (Clip Group or Clipbook) in the workspace pane.
• Blank Clip - Creates a new blank Clip inside the selected Clipbook.
• Clip from clipboard - Creates a new Clip inside the selected Clipbook. This clip is pre-loaded with 

the contents of the system clipboard.
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Create Menu (Setup Wizards view)

• Sequence - Opens a new Sequence Properties window. This window becomes an Action itself, con-
taining one or more other Actions as steps.

• All other menu items in the Create menu open the associated Setup Wizard to create new QuicKeys 
Actions when selected.

Help Menu

• QuicKeys Help - Opens the QuicKeys Help window.
• Startly on the Web - Links to Startly’s home page and support pages.
• Check for New Versions... - Checks a file on the Startly web site to compare the version you are using 

against the latest version available; requires an internet connection.
• About QuicKeys... - Brings up a window containing your QuicKeys serial number, registration infor-

mation, system information and links to Startly web resources.
• Enter Activation Key - Choose this menu item to enter the unlock code for QuicKeys if you are cur-

rently using a demo version. You can also change a registered key through this item.
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Sharing Actions, Toolbars, and Clipbooks

Using other people’s Actions

There are three methods to get other users’ data to load into your QuicKeys program:

Install Action, Toolbar, and Clips files

This is a simple, manual method for installing data files. QuicKeys must be exited and run again for 
the new files to be loaded and become available for use. QuicKeys stores your Actions, Toolbars, and 
Clipbooks data in the following location:

C:\Documents and Settings\<user>\Application Data\Startly\QuicKeys
Among other things, this QuicKeys folder contains sub-folders named “Actions”, “Clipbooks”, and 
“Toolbars”. These sub-folders contain the data for each new Action, Clipbook, and Toolbar you cre-
ate. Each of these items is stored with the same name that item displays in the QuicKeys Editor. If you 
remove a data file from one of these folders, the next time you run QuicKeys that item will not load. 
Conversely, if you drag additional Action, Toolbar, or Clips files into the appropriate folder, those items 
will be available in the QuicKeys Editor the next time you restart the program.

 
Figure E-1: By default the Application Data folder is hidden from view. This can be remedied by navigating 
to your user folder (1) and selecting ‘Folder Options’ from the ‘Tools’ menu (2). Inside the resulting Folder 

Options window select the View tab (3) and check the ‘Show hidden files and folders’ radio button (4).
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Import Actions

Actions that have been exported from QuicKeys can be imported by another user. Importing makes the 
new Actions available for immediate use, no re-launch is required.
1. Open the QuicKeys Editor and select Actions view.
2. Select File > Import...
3. Navigate to a QuicKeys export file and click the ‘Open’ button. Your new Actions will load and be 

ready to use.

Connect to a public Action Folder

If you have access to a file server or shared workstation whose owner has made QuicKeys Actions (or 
Clips and Toolbars for that matter) available to the public or selected users, you can easily connect to 
those Actions, Clips, and Toolbars.
1. Log into the server or workstation that is home to the repository of Actions you want. You need to 

be able to navigate to the target folder to connect to it with QuicKeys.
2. Open the QuicKeys Editor and select Actions view. Choose File > Connect to Action Folder...
3. Navigate to the folder containing the shared Actions and click the ‘Open’ button. Any Actions 

inside that folder will be loaded into QuicKeys and available for immediate use.
❖ Alert!: Be sure that the Action Folders that are to be shared by multiple users are stored in a secure 

area where they cannot be tampered with.
❖ Note: If you want to connect to a public Clips collection or Toolbar folder, follow these same in-

structions but make sure the QuicKeys Editor is in Clipbooks or Toolbars view as appropriate.
❖ Note: Actions that have loaded from folders you connected to can be edited but may or may not be 

editable by you depending on how the file permissions are set.
❖ Note: QuicKeys loads the data files only upon initially connecting to a shared Action Folder or 

when QuicKeys is exited and re-launched. If the owner makes changes to an Action your copy of 
QuicKeys will not be updated until you either exit and re-launch QuicKeys or disconnect/connect to 
the shared folder again.

Making your Actions available to others

There are three ways to share your Actions with other QuicKeys users:

Distribute your Action/Toolbar/Clips files

1. Locate your Actions, Toolbars, and/or Clips in the C:\Documents and Settings\<user>\Application 
Data\Startly\QuicKeys folder and copy any files you want to share out to another location.

2. Pass these copied files on to whoever you wish; they will need to follow the instructions found 
earlier in this chapter to install them properly.
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Export your Actions

1. Within the QuicKeys Editor (Actions view) highlight the Actions you want to export and select 
Export Selection... from the File menu.

2. Navigate to the desired destination and click the Save button.
3. Pass this exported file on to anyone you wish; they will need to follow the importing instructions 

found earlier in this chapter.

Make your Actions/Toolbars/Clips public

There is no mechanism within QuicKeys to enable file sharing or act as an Actions server per se. What 
QuicKeys can do however, is connect to folders containing Actions/Toolbars/Clips that are outside the 
default QuicKeys data folder.
To make your Actions, Toolbars, and/or Clips available to others you need only move copies of your 
data files to an accessible location. Be it a file server or a shared folder on your workstation, if users are 
allowed to log in and access that location their copy of QuicKeys can load data from it.
❖ Note: Don’t lump Action, Toolbar, and Clips data files into the same folder! QuicKeys will not be 

able to load Actions from a folder containing Toolbar or Clips files. Users connecting to your shared 
data files will need to connect to separate folders for Actions, Toolbars, and Clips, so be sure to keep 
these files separated in appropriately named and organized folders when making them available for 
sharing.
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Descriptions of the Preloaded Actions

When you install and run QuicKeys it will automatically load a default set of Actions if you are a new 
user of the product and have no Actions already in place from a previous version. Feel free to edit and 
explore these Actions, delete the ones you don’t need, and alter the hot keys and triggers as you desire.

 
Figure F-1: New installs of QuicKeys come with 17 pre-loaded Actions you can use, edit, and dissect.

Action Name Action Type Trigger / Hot Key Description
Clipbook - Copy 
selection to 
Clipbook

QuicKeys 
Clipbook

Shift + Ctrl + C Press the hot key combination, ‘Shift + Ctrl 
+ C’, to copy selected text or graphics into 
your Clipbook collection.

Clipbook - Open 
Editor

QuicKeys 
Clipbook

Shift + Ctrl + E Press ‘Shift + Ctrl + E’ to open the 
QuicKeys Editor in Clipbooks view.

Clipbook - Prompt 
for list of items to 
paste

QuicKeys 
Clipbook

Shift + Ctrl + V Press ‘Shift + Ctrl + V’ to open a list of all 
your Clips for pasting into a document.

Open Internet 
Explorer

Open Shift + Ctrl + O -> I -> E Press ‘Shift + Ctrl + O’ then quickly press 
‘I’ followed by ‘E’ to open the Internet 
Explorer program.

Open Outlook 
Express

Open Shift + Ctrl + O -> O -> E Press ‘Shift + Ctrl + O’ then quickly press 
‘O’ followed by ‘E’ to open the Outlook 
Express email program.

Appendix F: Preloaded Actions
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Action Name Action Type Trigger / Hot Key Description
Open Windows 
Explorer

Open Shift + Ctrl + O -> W -> E Press ‘Shift + Ctrl + O’ then quickly press 
‘W’ followed by ‘E’ to open Windows 
Explorer.

Quick Type [Edit 
Glossary]

Quick Type Ctrl + F5 Press the combination ‘Ctrl + F5’ top open 
the Quick Type glossary and edit your type-
completion list.

Quick Type 
[Toggle]

Quick Type Shift + F5 Press the hot key ‘Shift + F5’ to toggle 
Quick Type auto-completion on and off.

QuicKeys 
Editor [Open]

QuicKeys 
Controller

Alt + Ctrl + E Press the ‘Alt + Ctrl + E’ hot key combo to 
open the QuicKeys Editor.

QuicKeys Triggers 
[Toggle]

QuicKeys 
Controller

Alt + Ctrl + Q Disable/Enable QuicKeys’ triggers by 
pressing ‘Alt + Ctrl + Q’.

QuickReference 
Card

QuicKeys 
Controller

Alt + Ctrl + R Pressing ‘Alt + Ctrl + R’ opens the 
QuicKeys QuickReference Card allowing 
you to see and trigger Actions.

Recent Files modi-
fied in the last 15 
minutes

Recent Files Shift + Alt + F Press the listed hot key combination to 
bring up a list of all files that have been 
edited in the past 15 minutes.

Reformat Selected 
Text

Advanced Text 
Tools

Shift + Alt + R Select a block of text and press the listed 
hot key combo to bring up a list of ad-
vanced text formatting options.

Special Characters 
Popup

Special Char-
acters

Shift + Alt + C Press ‘Shift + Alt + C’ to bring up a palette 
of special characters. Click the desired 
character to insert it into a document.

Turn Monitor Off Screen Saver Alt + Ctrl + Esc Pressing the indicated hot key combo will 
instantly put your display in sleep mode.

Type Date-Time Type Date/
Time

Shift + Ctrl + D Insert the current date and time into a docu-
ment by pressing ‘Shift + Ctrl + D’

Web Page 
[QuicKeys]

Open URL Shift + Ctrl + W -> Q -> K Press Shift + Ctrl + W then quickly press 
‘Q’ followed by ‘K’ to open the QuicKeys 
web page.

❖ Note: These default Actions are available on the QuicKeys installer CD and download archive as an 
exported Actions file. This file can be found at \Extras\Default Actions in either location.
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Action - The time-saving tools you create with QuicKeys to automate single step or multi-step tasks.
Action scope - The range of operation for an Action. For example, you can create Actions that only 
work when Microsoft Word is active, or you can make “universal” Actions that can be triggered in any 
active program on your computer.
class - The way the system defines a window.
Clip - Individual item in a QuicKeys Clipbook containing text or graphics or both.
Clipboard - The system’s holding area for an item selected using the cut or copy feature.
Clipbook - Clips containing images and text that you’ve collected are stored and organized in 
QuicKeys Clipbooks.
combo box - A control that combines an edit control with a list box. This allows the user to type an 
entry or choose one from the list.
context menu - A menu that appears when you right-click your mouse.
dialog - A type of window that contains buttons and various options through which you can carry out a 
particular command or task.
extension - The part of a Windows file name that identifies file type, such as “.dll”.
hot key - The key or key combination you can press on your keyboard to trigger a QuicKeys Action.
list box - Any type of box containing a list of items you can select.
parameters - Program-specific command lines you can use to further control the behavior of the se-
lected file when it is opened.
plug-in - Each type of Action available within QuicKeys is considered a plut-in. This term can also 
refer to future QuicKeys add-ons.
properties - Attributes or characteristics of an object used to define its state, appearance or behavior.
QuicKeys Editor - The main component of the QuicKeys interface where you access the Setup Wiz-
ards, Actions, Toolbars, and Clipbooks views, as well as the various menu items.
QuickReference Card - A dialog that displays all of your Actions and hot keys when invoked. Click-
ing on an Action listed on the QuickReference Card will cause it to execute.
QuicKeys menu - The context menu that appears when you right-click the QuicKeys icon located by 
default in the status area of the taskbar (also referred to as the system tray).
scope - The range of operation for an Action. For example, you can create Actions that only work when 
Microsoft Word is active, or you can make “universal” Actions that can be triggered in any active pro-
gram on your computer.
Sequence - A type of Action that contains a series of other Actions as steps that execute consecutively.
Setup Wizards - Screens that help you create various Actions in a step-by-step fashion.
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shortcut - The icon that appears when you drag a QuicKeys Action to the desktop and it becomes an 
“official” Microsoft shortcut.
taskbar - The bar that appears by default at the bottom of the Windows desktop. A QuicKeys icon 
appears in the status area of the taskbar (also referred to as the system tray). When you rightclick the 
QuicKeys menu, a context menu appears that makes Toolbars, recording options, and open and exit 
options available.
toggle - Turns a particular mode on or off. For example, you can toggle hot keys on or off to enable 
and disable them.
toolbar - Graphical palettes you can use to trigger Actions and display Action menus.
trigger - A hot key, menu item, timer, or other event that tells QuicKeys to execute an Action.
URL - Uniform Resource Locator. The Worldwide Web (WWW) consists of URLs that take you to 
specific Web sites. For example, Startly Technology’s URL is http://www.startly.com/
volume - The level of sound on your computer. Also a term for a hard drive or partition of a hard drive.


