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Chapter 1: 
Welcome to QuicKeys
QuicKeys is a powerful software tool you can use to automate your computer. It’s a tool, however, that is only as 
effective as you make it. Once you install QuicKeys, make a mental note of each of the tedious, routine tasks you 
perform on your computer and earmark those tasks for some attention from QuicKeys. Each time you think of 
something that QuicKeys can make easier for you, create a Shortcut that automates that task or series of tasks.

To create a QuicKeys Shortcut, all you have to do is define the task you want to perform in QuicKeys and then 
replace the task, or series of tasks, with a single trigger, such as a Hot Key. QuicKeys automates common com-
puter tasks that include anything from opening folders you frequently use to logging into a database.

QuicKeys provides you with a powerful and versatile recording function that is ideal for automating lengthy or 
complex tasks. Tell QuicKeys to watch your actions and it can then play those actions back whenever you want.

QuicKeys toolbars work much like the toolbars you use in your other applications, except that you call the shots 
with QuicKeys toolbars. You specify what each toolbar button does, which icon is used, and when the toolbars 
are displayed. In other words, QuicKeys toolbars give you complete control.

However you choose to use it, QuicKeys offers powerful solutions that make it indispensable for assigning repet-
itive tasks to the computer and not to the computer user.

Using this Manual
Read this section to learn how the QuicKeys instructions are organized and to become acquainted with the con-
ventions used in this manual. Knowing how the manual is set up will help you use it more efficiently.

Organization

The first half of this manual introduces you to QuicKeys and provides you with basic instructions for operating 
the software. The remaining chapters contain reference material specific to individual Shortcut Types available in 
the Create menu.

Use the index to locate specific information and use the table of contents to become acquainted with the organi-
zation of each chapter of the manual. A glossary defining specific terms is located on page 151.

Assumptions

This documentation assumes you have a working knowledge of the Mac OS X operating system and accompany-
ing hardware. For example, you should know how to use your mouse and how to open, save, and close files. You 
should also be familiar with Mac OS X interface elements, such as the Dock. If you need assistance with stan-
dard procedures or Mac OS X terms, consult the documentation that came with your computer or your Mac OS 
X CD.
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Conventions

�    A right arrow character (>) indicates the hierarchy of menu and submenu options. For 
example, Create>Files>Change Folder.

�    When you must select or type text into a specific interface element (such as a button or a 
text field), the text appears in Arial font. For example, select File>Print.

�    A ❖ symbol indicates a note that provides supplemental information about the topic being 
covered.

�    Variable text is contained within opposite-facing arrow characters. Items such as your hard 
drive name and Shortcut names are considered variable text. For example, look in the <hard 
drive>:Applications: <folder or file>.

Contextual Menu Technology
Most of the features in QuicKeys can be accessed via contextual menus. When the manual refer-
ences contextual menus, you can Control+click the item being discussed to display a pop-up menu 
with function-specific options.
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Contacting CE Software
If you have questions about QuicKeys that are not addressed in the manual, use this section to learn how 
to contact CE Software.

Technical Support

CE Software offers online, fax, and telephone support as well as a QuicKeys Community forum at 
http://forum.cesoft.com/. Visit the Technical Support Web page at http://help.cesoft.com/ for information about the 
various support options.

Contact Information

The Technical Support Department is available Monday through Friday from 8:00 A.M. to 
5:00 P.M. U.S. Central Time.

�   Phone: 515-221-1803

�   Fax: 515-221-1806

�   Web page: http://help.cesoft.com/ 

�   E-mail: ceonline@cesoft.com

Before You Call

Check the following Web sites for technical information:

�   View http://www.quickeys.com/ for updates and product information.

�   View http://help.cesoft.com/ for technical support information.

When You Call

To help our Technical Support team assist you as quickly as possible, please have the following 
information available when you speak with, or write to, a Technical Advisor:

�   Product name and version (e.g. QuicKeys X2)

�   Operating system and version (e.g. Mac OS X 10.2.3)

�   Computer type and model (e.g. PowerBook G4)

�   Product serial number
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Product Feedback

What do you think of QuicKeys? We want to know and we encourage you to submit your ideas to 
feedback@cesoft.com so we can consider them for the next version of QuicKeys.

Sales and Customer Service 

The CE Software Sales and Customer Service department is open Monday through Friday from 
8:00 A.M. to 5:00 P.M. U.S. Central Time.

�    Phone: 800-523-7638 or 515-221-1801

�    Fax: 515-221-1806

�    Web site: http://www.cesoft.com/

Ownership Transfer

If you transfer ownership of a CE Software product, please e-mail us at sales@cesoft.com or 
send a letter with the product name, serial number, your name, and the new owner’s name 
and address to:

CE Software, Inc.
Attn: Ownership Transfer
P.O. Box 65580
West Des Moines, IA 50265 U.S.A.

Change of Address

If you change your address, please e-mail us at sales@cesoft.com or send a letter indicating 
your old and new address to:

CE Software, Inc.
Attn: Change of Address
P.O. Box 65580
West Des Moines, IA 50265 U.S.A.

User Guide Feedback

CE Software welcomes feedback about the documentation that accompanies QuicKeys. Please 
e-mail us at manuals@cesoft.com with your comments and suggestions.

The most current version of this manual is available online at http://www.cesoft.com/ and can be viewed 
with Adobe® Acrobat Reader 4.0 or greater. Visit http://www.adobe.com/ to download a free copy of 
Acrobat Reader.
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Chapter 2: 
Installing and Opening QuicKeys
This chapter provides you with general installation information. For the most current installation information, 
view the Read Me document that accompanies the QuicKeys application.

Minimum System Requirements
Verify that your computer meets the following system requirements before installing QuicKeys:

�    Mac OS 10.2.3 (Mac OS 10.2.4 recommended)

�    20 MB free hard disk space

�    G3 processor (or greater)

�    128 MB of RAM

�    Certain features require an Internet connection

Turning on Accessibility

QuicKeys requires that your Accessibility preference be turned on. To turn on the Accessibility preference, fol-
low these instructions:

1. Select System Preferences from the Apple menu.

2. Select Universal Access from the System category.

3. Check the Enable access for assistive devices checkbox.

FIGURE 1. OS X Universal Access options
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4. If you are prompted, enter your administrator password.

5. Quit the System Preferences.

Installing QuicKeys
To install QuicKeys, drag the QuicKeys application icon to your Applications folder. The Applica-
tions folder is located on the main level of the Mac OS X hard drive.

For instructions on upgrading QuicKeys from a previous version, refer to the QuicKeys Read Me.

Opening QuicKeys
The QuicKeys application can be operated in the foreground or the background. If QuicKeys is 
running in the background, the presence of the application is nearly transparent to the user. If 
QuicKeys is running in the foreground, the QuicKeys icon appears in the Dock and QuicKeys oper-
ates much as your other applications. You can tell QuicKeys how you want it to behave using your 
QuicKeys preferences.

By default, the QuicKeys preferences are set to make QuicKeys behave as a standard application. 
When you login to your computer, the QuicKeys application opens and the QuicKeys Editor dis-
plays. If you close the QuicKeys Editor, you can display it again by clicking the QuicKeys icon in 
the Dock. If you quit QuicKeys, both the QuicKeys Editor and the QuicKeys Dock icon are 
unavailable until you again launch the QuicKeys application. For more information on setting the 
QuicKeys “open” preferences, see page 72.

❖Note: If you quit the QuicKeys application, you will not be able to play your Shortcuts. 
(The QuicKeys application can be running without displaying the QuicKeys Editor.)

Adding QuicKeys to the Dock

There are two ways to add QuicKeys to the Dock: select the Show QuicKeys icon in Dock preference or 
drag the QuicKeys application icon to the Dock.
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Checking for Updates
The Check for Update option checks CE Software’s Web site to verify you are using the most current ver-
sion of QuicKeys. When you select Check for Update from the QuicKeys X2 application menu, the QuicK-
eys Update window appears. You can set QuicKeys to check for updates manually or automatically. If 
you choose to check for updates automatically, you must specify the interval used to check for more 
current versions of QuicKeys.

If you are unable to connect to CE Software’s Web site, the attempt will time out. A connection failure 
may occur if you have no Internet connection, if you have problems with your Internet service, or if CE 
Software’s server is momentarily unavailable.

FIGURE 2. The QuicKeys Update window
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Chapter 3: 
QuicKeys Overview
This chapter is designed to introduce you to basic QuicKeys concepts and the QuicKeys interface. The function-
ality of elements introduced in this chapter are fully documented in later chapters of this manual. To quickly 
locate more information about a particular part of the interface, use the index.

Single-step and Multi-step Shortcuts
Single-step and Multi-step Shortcuts are the foundation of the QuicKeys application. Single-step Shortcuts auto-
mate simple one-step tasks, such as opening your Documents folder. Multi-step Shortcuts automate multi-step 
tasks, such as starting a database application, searching for a specific item and printing out the selected database 
records. 

Shortcuts are built using the Shortcut Editing window. Single-step Shortcuts use one Shortcut Type while Multi-
step Shortcuts are built using a collection of Shortcut Types. Shortcuts can be assembled manually or by using 
the QuicKeys recording feature. The recording feature enables QuicKeys to “watch” what you are doing and 
repeat your actions. See Chapter 6 for more information on recording.

Creating Shortcuts

When you create a QuicKeys Shortcut, you can choose the trigger that plays it. In other words, you specify the 
“signal” that tells QuicKeys when to perform the Shortcut. For example, if you want QuicKeys to open a data-
base application and enter the current date in the database you can use a QuicKeys trigger to tell QuicKeys that 
you want to play the Shortcut. It’s like having a personal assistant inside your computer that understands a lan-
guage of triggers that you choose.

That’s all there is to using QuicKeys: thinking of tasks to automate, creating QuicKeys Shortcuts to replace those 
tasks and triggering the tasks. You must spend a few minutes telling QuicKeys what you want, but from that 
point on you can save hours, days, or even weeks with Shortcuts that only took a couple of minutes to set up. It is 
a good return for a small investment of time. In fact, after using QuicKeys for a few weeks, you may be amazed 
when you sit down at a computer that doesn’t have QuicKeys and realize how much you depend on the software.
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The QuicKeys Editor
The QuicKeys Editor is your control center for creating, modifying and deleting Shortcuts. The 
most fundamental parts of the QuicKeys Editor include: the QuicKeys Editor Toolbar, the Scope 
List and the Shortcut List.

Sorting Editor Columns

Click the On, Type, Shortcut, Scope or Trigger column heading to sort your Shortcuts. A triangle 
appears in the column heading that is being used to sort your Shortcuts. Click the sorting triangle to 
toggle between ascending and descending order.

�    The On column is sorted by whether the Shortcut is turned on or off.

�    The Type column is sorted by the name of the Shortcut Type (e.g. an AppleScript Shortcut 
Type is listed before a Change Folder Shortcut Type).

�    The Shortcut column is sorted by the name of the Shortcut. 

�    The Trigger column is sorted by the assigned trigger.

�    The Scope column is sorted by the application to which each Shortcut is scoped.

❖Note: When All Shortcuts is selected in the Scopes column, the QuicKeys Editor dis-
plays a Scopes column rather than a Triggers column.

FIGURE 3. The QuicKeys Editor
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Resizing Columns

You can resize the Scope List by clicking the sizing bar between the Scope List and the Shortcut List 
and dragging the list to the desired size.

You can resize the Trigger and Shortcut columns by clicking and dragging the line between the Shortcut 
column heading and the Trigger column heading.

The QuicKeys Editor Toolbar

The QuicKeys Editor Toolbar encompasses the buttons along the top of the QuicKeys Editor. You can 
use the default button set or you can change which buttons display in the QuicKeys Editor Toolbar by 
selecting View>Customize Editor Toolbar and dragging frequently-used Shortcut Types to the toolbar. The 
default QuicKeys Editor Toolbar set includes the Info button, Rename button, Play button, Shortcut 
Debugging button, New Shortcut button, and the Record button. 

Info Button

Click the Info button when you want to view information specific to the selected Shortcut. See 
page 15 for more information on the QuicKeys Info window.

Rename Button

Click the Rename button when you want to rename your QuicKeys Shortcut.

Play Button

Click the Play button when you want QuicKeys to play the selected Shortcut.

Shortcut Debugging

Click the Shortcut Debugging button when you want to troubleshoot your recordings. See 
page 65 for more information on the debugging feature.

FIGURE 4. The QuicKeys Info window
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New Shortcut Button

Click the New Shortcut button to display a list of all the different Shortcut Types. You can 
create a Shortcut by selecting a Shortcut Type from this list. For more information on cre-
ating Shortcuts, see Chapter 4.

Record Button

Click the Record button when you want QuicKeys to record your actions. The recording 
feature is covered in more detail on page 61.

Other Shortcut Types

If you customized the QuicKeys Editor Toolbar, you may see additional buttons in the 
toolbar that enable you to create specific QuicKeys Shortcut Types with a click of your 
mouse. To add Shortcut Types to your QuicKeys Editor Toolbar, select View>Customize Editor 
Toolbar. See page 69 for more information on customizing the QuicKeys Editor Toolbar.

The Scope List

Click an item in the Scope List to choose which Shortcuts are displayed in the Shortcut List. When 
you assign a scope to a Shortcut, the use of the Shortcut is restricted to the application you select. 
Instructions for setting Shortcut scope are located on page 32. The scopes available in QuicKeys by 
default include:

�    All Shortcuts—Displays all the Shortcuts you have created.

�    All Applications—Displays all the Shortcuts assigned to all applications.

�    Unscoped Shortcuts—Displays all the Shortcuts that are not assigned to any application.

The Shortcut List

Shortcuts are the time-saving tools you create with QuicKeys to automate single-step or multi-step 
tasks. The Shortcut List shows all of the Shortcuts you have created for a selected scope. The list 
also displays the Shortcut type, name and trigger. You can sort the Shortcuts in the Shortcut List by 
clicking on a column heading.
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The Shortcut Editing Window
The Shortcut Editing window appears with Shortcut-specific options when you create or edit Shortcuts. 
When you open the Shortcut Editing window, you can specify Shortcut-specific properties, set up a 
QuicKeys trigger and choose a trigger scope. Use the Shortcut Scope pop-up menu to set an application 
scope for the Shortcut.

❖Note: You can have more than one Shortcut Editing window open concurrently. When a Shortcut 
Editing window is open, the triggers for that Shortcut are disabled until you close the window.

FIGURE 5. An example of a Shortcut Editing window
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The Shortcut Editing Toolbar

The Shortcut Editing Toolbar looks like the QuicKeys Editor Toolbar except that it also contains 
the Add Step button and the Steps button.

Add Step Button

Click the Add Step button and select a Shortcut Type from the list to create a Shortcut step. 
For more information on creating Shortcuts, see Chapter 4.

Steps Drawer

Select View>Show Steps Drawer when you want to display the Steps Drawer. The Steps Drawer 
slides out from behind the Shortcut Editing window. It lists all the steps used in a Shortcut.

Shortcut Triggers

You can specify triggers for a Shortcut in the Shortcut Triggers area of the Shortcut Editing win-
dow. See page 24 for information on triggers.

Shortcut Step

Each Shortcut Type has different options that can be set in the Shortcut Step area of the Shortcut 
Editing window. To learn more about the options that appear in the Shortcut Step area, refer to the 
chapter that discusses the Shortcut Type you are using. For example, if you are setting up a Clips 
Shortcut, refer to the chapter entitled “System Tools” on page 107.

Show/Hide Buttons

Click the Show/Hide buttons to alternately show and hide the Shortcut Triggers area and the Short-
cut Step area of the Shortcut Editing window. This capability is useful if you have limited screen 
real estate. See Figure 5 for an illustration that shows the Show/Hide buttons.

FIGURE 6. Click the Add Step button in the Shortcut Editing Toolbar
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QuicKeys Info Window
The QuicKeys Info window appears when you click the Info button in the QuicKeys Editor or in the 
Shortcut Editing window. When you select the Info button in the QuicKeys Editor, the Shortcut Tool-
bars appear in the QuicKeys Info window. The window shows on which toolbars the selected Shortcut 
has been placed.

When you click the Info button in a Shortcut Editing window, you can choose from several items in the 
pop-up list including Shortcut On/Off, Shortcut Comments, Step Comments, Shortcut Icon, Shortcut 
Toolbars, and Step Results.

Shortcut On/Off

You can turn Shortcuts on or off in the QuicKeys Info window. To open the QuicKeys Info window, 
click the Info button in the Shortcut Editing window. Select Shortcut On/Off from the pop-up list and click 
the Enable Shortcut checkbox to turn the Shortcut on. When you return to the QuicKeys Editor, the Short-
cut will have a dot in the “On” column. 

An example of when you may want to use this option is when you have a timed trigger that saves a doc-
ument and copies it to a file server every 30 minutes. If the server is unavailable for a couple of hours, 
turn off the Shortcut until the server is again available.

FIGURE 7. Turn Shortcuts on or off in the QuicKeys Info window.
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Shortcut/Step Comments

When you select the Shortcut Comments or step Comments option from the pop-up list, you can 
type a description of the Shortcut or step in the text field. This option is especially helpful for track-
ing the functionality of each step in a Multi-step Shortcut for your own records or for providing 
information to a colleague with whom you share Shortcuts. See page 78 for more information on 
sharing Shortcuts with the export feature.

Shortcut Icon

The Shortcut Icon option is useful if you add a Shortcut to a toolbar and you want to visually differ-
entiate the Shortcut icon from the standard Shortcut Type icons. You can change the icon for a par-
ticular Shortcut using the following instructions:

1. Select the icon you want to use by copying it to your clipboard.

2. Open the Shortcut Icon window (see Figure 9) and select the default icon.

3. Press Command+V to paste the new icon into the Shortcut Icon window. 

4. Close the QuicKeys Info button to save your icon change.

For information on creating QuicKeys toolbars, see page 79.

FIGURE 8. Type Shortcut and Step Comments in the QuicKeys Info window.

FIGURE 9. Change a Shortcut icon in the QuicKeys Info window.
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Shortcut Toolbars

If the selected Shortcut is available in a toolbar, you can view the name of the toolbar in the Shortcut 
Toolbars tab of the Info window.

Step Results

Select Step Results in the Info window to display the Step Results options. Use the pop-up lists in this 
window to choose how you want each step of a Shortcut to react to a success and failure. For more 
information on step results, see page 23.

FIGURE 10. The QuicKeys Info window shows which toolbars contain the selected Shortcut.

FIGURE 11. Set up Step Result options in the QuicKeys Info window. 
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Toolbar Editing Sheet
The Toolbar Editing sheet displays when you create or edit a QuicKeys toolbar. There are three tabs 
in the Toolbar Editing sheet: Toolbar, View and Tabs. The Toolbar Editing Sheet is discussed in 
greater detail on page 86.

�    Toolbar—Specify the name, Hot Key and scope of the toolbar.

�    View—Choose the Toolbar type, icon size and other display options.

�    Tabs—Create, name or delete toolbar tabs.

FIGURE 12. The Toolbar Editing sheet
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The QuicKeys Menu
The QuicKeys Menu is available when you have the corresponding preference set and the QuicKeys 
application is running. You can display the QuicKeys Menu by clicking the QuicKeys icon in the upper 
right corner of your screen. The QuicKeys Menu provides quick access to basic QuicKeys components 
including:

�    QuicKeys—Opens the QuicKeys Editor. 

❖Note: The QuicKeys Editor can be closed even while the QuicKeys application is 
running.

�    Toolbars—Shows or hides toolbars.

�    Edit Toolbars—Opens the QuicKeys Editor Toolbars window.

�    Pause Playback—Pauses the playback of Shortcuts.

�    Stop Playback—Stops the playback of Shortcuts

�    Start Recording Me—Starts the recording process.

�    Cancel Recording—Cancels recording without saving the recording.

�    Shortcuts you assigned to the QuicKeys Menu trigger are available in the QuicKeys Menu. 
Shortcuts that are scoped to a specific application will only display in the QuicKeys Menu when 
that application is active.

FIGURE 13. The QuicKeys Menu lists Shortcuts alphabetically.
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QuicKeys Dock Menu
If QuicKeys is running and you have the Show QuicKeys Menu in Dock preference set, the QuicKeys 
menu is available from the Dock. You can click and hold on the QuicKeys Dock icon to display 
many of the same options available in the QuicKeys Menu.

FIGURE 14. Use the QuicKeys Dock menu for quick access to QuicKeys options.
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Chapter 4: 
Single-step Shortcuts
QuicKeys offers two types of Shortcuts: Single-step and Multi-step. Single-step Shortcuts can automate simple 
one-step tasks, such as opening a document. Multi-step Shortcuts automate longer, multi-step tasks, such as 
opening a Word document, pasting text into it and saving the document in a specific folder. This chapter will pro-
vide you with basic information on creating, using, and deleting Single-step Shortcuts. Chapter 5 contains infor-
mation regarding Multi-step Shortcuts. 

If you see terms or concepts in this chapter that are unfamiliar to you, you may need to refer to the glossary or the 
index of this manual for more information.

The Shortcut Editing Window

The Shortcut Editing window is where you create and edit all your Shortcuts. The Shortcut Editing window dis-
plays when you:

�   Select an item from the Create menu. The Create menu lists all available QuicKeys Shortcut Types. 
Each Shortcut Type is categorized by functionality in submenus.

�   Double-click one of the Shortcuts listed in the Shortcut List of the QuicKeys Editor.

�   Select a Shortcut from the Shortcut List and select Shortcuts>Edit Shortcut.

�   Select a Shortcut from the Shortcut List and press the Return or Enter key. 

�   Drag an item onto the QuicKeys Editor. For example, if you drag an application icon onto the Shortcut 
List in the QuicKeys Editor, an Open Files Shortcut is created.
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The Steps Drawer

Steps are listed in the Steps Drawer, which slides out from behind the Shortcut Editing window. 
The Steps Drawer shows step numbers, step names, and result options that are set for each step in a 
Shortcut. You may need to use the horizontal scroll bar in the Steps Drawer to view the step num-
bers or Step Results for your steps.

You can show or hide the Steps Drawer by clicking the Steps button in the Shortcut Editing window 
or by selecting Show Steps Drawer or Hide Steps Drawer in the View menu. The Steps Drawer retains an 
open or closed state on a per Shortcut basis. This means that if you created a Web Address Shortcut 
and left the Steps Drawer open, the drawer will be open next time you open the Shortcut Editing 
window for this particular Shortcut.

FIGURE 15. The Shortcut Editing window
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Step Results

To view the Step Results window, open a Shortcut Editing window and select Shortcuts>Edit Step Results or 
click the Steps button and click the Result icon for the step in the Steps Drawer. Use the Step Results 
window to choose how you want each step of your Shortcut to react to a success or failure using If step 
succeeds or If step fails pop-up lists. 

In the If step succeeds and If step fails pop-up menus, you can direct a particular step to Continue to next step, Skip 
next step, Stop shortcut, or Stop shortcut and notify me. Each result handling option is represented by a different 
icon that displays in the Steps Drawer of the Shortcut Editing window.

FIGURE 16. The Step Results options

Icon Step Options Description

Continue to next step Continues to the next step.

Skip next step Skips the next step of the current Shortcut.

Stop Shortcut Stops the Shortcut that is playing.

Stop Shortcut and notify me Stops the Shortcut that is playing and noti-
fies you that the step succeeded or failed.

FIGURE 17.  Step Result Icons
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Stop Shortcut and Notify Me

If there are any problems with the playback of your Shortcut and the Step Results are set 
to Stop Shortcut and notify me, a dialog similar to the one shown in Figure 18 appears.

Shortcut Triggers

When you create a QuicKeys Shortcut, you can assign one or more triggers to it. A trigger is a user-
specified signal that directs QuicKeys to play a specific Shortcut. For example, you can assign 
Control+Shift+W as a Hot Key trigger that launches Microsoft Word.

The trigger you choose may be a Simple trigger or an Advanced trigger. This section provides 
information about each type of trigger that is available to you as well as instructions for assigning 
triggers.  

FIGURE 18. A dialog will appear if your Shortcut encounters problems.

FIGURE 19. The Simple vs. Advanced trigger options
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Simple Triggers

Simple triggers include Hot Keys and the QuicKeys Menu. These triggers are used frequently by most 
QuicKeys users and they appear by default in the Add Trigger pop-up list in the Shortcut Editing window.

Hot Key

You can assign a Hot Key to play a QuicKeys Shortcut. To assign a Hot Key to a Shortcut, 
select Hot Key from the Add Trigger pop-up list and click in the Hot Key field. Press the key combi-
nation you want to use as your Hot Key. If the key combination appears in red text, that key 
combination has already been used by another Shortcut, so you should consider using a differ-
ent key combination.

FIGURE 20. The Shortcut Editing window in Simple Triggers mode

FIGURE 21. Assign a Hot Key in the Hot Key field of the Shortcut Editing window.
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QuicKeys Menu

The QuicKeys Menu trigger provides access to Shortcuts from the QuicKeys Menu in the 
upper right corner of your screen. This menu appears when the Show QuicKeys Menu in menu bar 
preference is turned on. Shortcuts in the QuicKeys Menu are listed alphabetically. Scoped 
Shortcuts only appear in the QuicKeys Menu when that application is active. Scoped 
Shortcuts will display above Shortcuts scoped to All Applications.

Deleting Simple Triggers

To delete a Simple Trigger, click the Subtract button in the Shortcut Triggers area of the 
Shortcut Editing window. Figure 5 on page 13 shows the Subtract button.

FIGURE 22. The QuicKeys Menu
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Advanced Triggers

Advanced triggers include After Open, Day and Time, and Repeat triggers in addition to the two Simple 
triggers (Hot Keys and QuicKeys Menu).

Switching to Advanced Trigger Editing Mode

To switch to Advanced triggers, display the Shortcut Editing window for one of your Shortcuts 
and then select View>Switch to Advanced Shortcuts. When you switch between Simple and Advanced 
Triggers mode, QuicKeys displays the prompt shown in Figure 24. Switching to Advanced 
Triggers mode only affects the Shortcut that is currently open. 

❖Note: You can also switch to Advanced Trigger mode by selecting New Shortcuts have advanced trig-
gers in the Preferences window. See page 76 for more information

FIGURE 23. The Shortcut Editing window in Advanced Triggers mode

FIGURE 24. QuicKeys asks you to confirm your trigger editing mode.
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Hot Key

The Hot Key trigger is available as an Advanced trigger as well as a Simple trigger. When 
you switch to Advanced Triggers mode, special Hot Key options appear.

Hot Key Info Options

If you assign a Hot Key to a Shortcut when Advanced triggers are enabled, the QuicK-
eys Info window appears with two Hot Key options.

�   Hot Key is sticky—This option enables you to combine multiple Hot Key triggers, giv-
ing you more Hot Key options.

�   Hot Key repeats—This option allows you to execute your Shortcut repeatedly by keep-
ing the Hot Key pressed down.

Sticky Requirements   

To function properly, the Sticky feature requires the following conditions:

�   The Hot Key triggers that use the Sticky option need to be followed by an “and” 
conditional statement. (See page 35 for information on conditional triggers.) If a 
Sticky key is followed by an “or” statement, the Sticky option is ignored. You can 
specify “or” conditional statements by switching to the Advanced trigger view and 
assigning multiple triggers on different lines. You can specify “and” conditional 
statements by assigning multiple triggers on the same line.

�   The Sticky option only applies to Hot Key triggers that are part of the same scope. 
Both Hot Key triggers should be assigned to an application-specific scope or the All 
Applications scope.

FIGURE 25. Hot Key settings



29
�   Hot Keys must be pressed in the order they are displayed in the Shortcut Editing win-
dow. The Triggers field in the Shortcut Editing window must display two Hot Key trig-
gers listed next to each other; a different type of trigger (such as QuicKeys Menu) cannot 
separate the Hot Key triggers set up for the Sticky option.

�   The Hot Key trigger listed last in the Triggers field of the Shortcut Editing window can-
not have the Sticky option selected. QuicKeys will not play a Shortcut if the Hot Key 
trigger is waiting for a Sticky Key.

After Open 

The After Open trigger sets a timer that plays a Shortcut <X> seconds after the QuicKeys 
application is launched (when All Applications is the scope) or <X> seconds after the scoped 
application is launched. For example, if you are a graphic designer and you need to save all 
your Photoshop files to a network server, you can set up QuicKeys to login to the network 
server 30 seconds after launching Adobe Photoshop.

FIGURE 26. After Open trigger
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Day & Time 

Use the Day & Time trigger to set the day and time you want your Shortcuts triggered. 
You can choose one or more days of the week and you can specify the time of day you 
want the Shortcut to be triggered. For example, if you have a Web Address Shortcut that 
opens your favorite stock tracking Web site, you can use the Day & Time trigger to play 
that Shortcut Mondays, Wednesdays and Fridays at 12:45 PM. 

❖Note: Day & Time triggers do not execute when the computer is in Sleep mode.

The Day & Time Info Options

You can use the Trigger options in the QuicKeys Info window to specify the day and 
time you want to launch your Shortcut. These options appear when you select Day & Time 
from the Add Trigger pop-up list in the Shortcut Editing window.

FIGURE 27. Day and Time trigger

FIGURE 28. The Date and Time Info window
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Repeat

The Repeat trigger allows you to set the interval that a Shortcut is repeated. You can choose 
from <X> seconds, minutes, hours or days. You can use the Repeat trigger to automate tasks 
like backing up files every two days.

Trigger Requirements

�    To trigger Shortcuts, the QuicKeys application must be running; however, the QuicKeys Editor 
window does not need to be open.

�    You cannot trigger a QuicKeys Shortcut when the Shortcut Editing window is open for that par-
ticular Shortcut.

�    You cannot trigger any QuicKeys Shortcuts when the Hot Key field (in the Shortcut Editing win-
dow) is active.

FIGURE 29. The Repeat trigger
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Setting the Scope

Scope is the range of operation for a trigger. You can specify scope to control or limit when a Short-
cut is available.

Multiple scopes with multiple triggers for the same Shortcut allow you to set up different operating 
environments for each trigger and each Shortcut. For example, you can limit the trigger so it only 
functions when a specific application is active.

To create a scope for a trigger, follow these steps:

1. In the QuicKeys Editor, double-click a Shortcut in the Shortcut List to open the Shortcut Editing 
window.

2. Click the Add Scope pop-up list and select an application. The pop-up list is populated by cur-
rently running applications. 

❖Note: You can also choose the Select Application option from the Add Scope pop-up menu and 
select the application in which you want this Shortcut to function. Click Choose when you are 
finished selecting an application.

The application you select appears as an item in the Shortcut Scopes List. Now you can assign a 
trigger to the new application scope.

FIGURE 30. Choose a scope from the Add Scope pop-up menu.
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Exclude Applications

With QuicKeys, you have the capability of turning off the All Applications scope in specific 
applications. This functionality enables users who have several Shortcuts scoped to All Appli-
cations to suppress the Shortcuts in specific applications. For example, if you want to reserve 
specific Hot Keys for one of your gaming applications, you can use the Exclude Applications 
option to suppress your All Applications scope when you are playing your favorite game.

To set up the Exclude Applications feature, follow these steps: 

1.  Select Window>Excluded Applications.

2.  Click the Exclude Application pop-up list and select an application. The pop-up list is populated 
by currently running applications. 

❖Note: You can also choose the Select Application option and select the application in which 
you want this Shortcut to function. Click Choose when you are finished selecting 
an application

3.  Close the Excluded Applications window. The QuicKeys Editor shows All Applications (except 
excluded) in the Scope List when you specify an excluded application. See Figure 31.

FIGURE 31. The Excluded Applications option
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Reassigning Scope

You can reassign scope for a single Shortcut or you can reassign all the Shortcuts scoped 
to a particular application. 

Reassigning Shortcut Scope

The instructions for reassigning Shortcut scope differ depending upon whether you are 
in Simple Triggers mode or Advanced Triggers mode. If you are in Simple Triggers 
mode, open the Shortcut and select a different scope in the Shortcut Scope pop-up list. 
When you close the Shortcut Editing window, QuicKeys saves your scope selection. In 
the QuicKeys Editor, select the All Shortcuts scope to view the new scope assignment for 
your Shortcut.

If you are in Advanced Triggers mode, select the scope in the Shortcut Scopes area of 
the Shortcut Editing window and select File>Reassign Scope. Choose another scope from 
the pop-up list that appears and click OK.

Scopes for Applications

There are times when you will want to reassign the scope for all Shortcuts assigned to a 
specific application. For example, if you have an application that is named XYZ 1.0 
and the application upgrade is named XYZ 2.0, you can change the scope of all your 
XYZ 1.0 Shortcuts to the new application in one operation.

1. Select XYZ 1.0 from the Scope List.

2. Select File>Reassign Scope.

3. Select XYZ 2.0 from the New Scope pop-up list if the application is currently running. 
If it is not currently running, choose Select Application and select XYZ 2.0.

4. Click OK to reassign the scope.

FIGURE 32. You can reassign scope for multiple Shortcuts.
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Conditional Triggers

If you are in Advanced Triggers mode, you can assign multiple triggers to a Shortcut. For example, if 
you want two ways to open a specific Web page, you can set up QuicKeys so that you can launch that 
Web page on a certain day and time or you can launch it with a Hot Key. The triggers will appear on 
separate lines in the Shortcut Trigger area of the Shortcut Editing window. You will also see an “or” 
condition appear between the different triggers. The “or” condition indicates that you can use either the 
Hot Key trigger or the Day & Time trigger to play the scoped Shortcut. See Figure 33.

FIGURE 33. The “or” condition for triggers scoped to Internet Explorer
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You can also set up triggers with the “and” condition. The “and” condition requires that all triggers 
assigned to a particular Shortcut are used to play that Shortcut. When the “and” condition is speci-
fied, the assigned triggers appear on the same line in the Shortcut Triggers area of the Shortcut 
Editing window. See Figure 34.

FIGURE 34. The “and” condition for triggers scoped to Mail
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Deleting Advanced Triggers

To delete a specific trigger, Control+click the trigger you want to delete and select the Delete option from 
the contextual menu. You can also delete a trigger by selecting the trigger icon and pressing the Delete 
key.

Deleting Multiple Triggers

To delete all triggers for a particular Shortcut, click to the left of the first trigger icon. The 
entire line becomes highlighted. With the trigger line selected, select Edit>Delete to delete all the 
triggers on that line.

FIGURE 35. Control+click a trigger in the Shortcut Editing window to delete it.

FIGURE 36. A highlighted trigger line
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Creating a Single-step Shortcut
In the following steps, you will create a Single-step Shortcut that will open the TextEdit applica-
tion.

❖Note: This example assumes you are in Simple Trigger editing mode.

1. Open the QuicKeys Editor.

2. Select Create>Files>Open Items. The Shortcut Editing window displays with options specific to the 
Open Items Shortcut Type.

3. Click the Select button in the Open Items Shortcut Editing window.

4. Navigate to the Applications folder.

5. Select the TextEdit application and click Choose. If the Automatically name single step shortcuts prefer-
ence is set, QuicKeys automatically provides a name for your Shortcut.

6. Choose All Applications from the Shortcut Scope drop-down list. This selection will enable you to 
launch the Open TextEdit Shortcut from any application.

7. Select Hot Key from the Add Trigger drop-down list.

FIGURE 37. Select Create>Files>Open Items.
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8. Press the key combination you want to use to trigger the Shortcut. For example, press Com-
mand+Shift+9. The key combination appears in the Hot Key field. The Hot Key text will be red if 
the key combination you used conflicts with another Shortcut.

9. Select File>Rename Shortcut or click the Rename button in the Shortcut Editing window.

10. Type a new name for the Shortcut and click OK. 

11. Close the Shortcut Editing window. The newly renamed Shortcut appears in the Shortcut List of the 
QuicKeys Editor.

❖Note: You can also drag application icons, files and folders, text or URLs onto the Shortcut List 
of the QuicKeys Editor to create Single-step Shortcuts.

FIGURE 38. Navigate to the TextEdit application.
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Playing Shortcuts
Shortcuts can be played using the assigned trigger or the Play button in the QuicKeys Editor. When 
you play a Shortcut, the Playback palette appears. Use the palette to monitor the progress of Short-
cuts that are playing.

Deleting Shortcuts and Steps
There are several ways to delete a Shortcut or steps in a specific Shortcut:

�    Select Shortcuts>Delete Shortcut to delete the selected Shortcut.

�    Select the Shortcut you want to delete and press Control+click. Select Delete from the menu 
that appears.

�    Select the Shortcut and press the Delete key.

�    Select the Shortcut and select Edit>Delete.

FIGURE 39. The Playback Palette
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Multi-step Shortcuts
Multi-step Shortcuts automate longer, multi-step tasks that contain several Shortcuts. They can be as easy or 
complex as the task you need to automate. Creating a Multi-step Shortcut is much easier than the alternative - 
learning a scripting language. 

See Figure 40 for an illustration of how Multi-step Shortcuts work. This particular Multi-step Shortcut will 
enable you to grab a cup of coffee while QuicKeys prepares your list of mail; all you have to do is use the 
assigned QuicKeys trigger. When you return to your desk, your mail will be ready for you to read and QuicKeys 
will have retreated into the background until it’s directed to complete other tasks.

This chapter provides instructions for creating, using, and editing Multi-step Shortcuts. If you see terms or con-
cepts that are unfamiliar to you, you may need to refer to the glossary or the index of this manual for more infor-
mation.

Building Multi-step Shortcuts
Building a Multi-step Shortcut can be challenging unless you have a task clearly mapped out in your mind. Even 
then, it’s important to know how QuicKeys Multi-step Shortcuts work so you can make the most of their power 
and flexibility.

There are two basic tasks you must complete when you build a Multi-step Shortcut: 

�    Record or manually create every individual step you want to include in the Multi-step Shortcut. (See 
Chapter 6 for more information on recording.)

�    Test and manually adjust your Multi-step Shortcut.

FIGURE 40. Multi-step Shortcuts consolidate several individual steps.

1. Start your E-mail 
program.

2. Type your user 
name and password 
at the prompt.

4. Check for new 
mail.

3. Click the OK 
button to close the 
login window.

Combine these 
steps using 
QuicKeys.

Replace the 4-step 
task with a QuicKeys 
trigger such as a Hot 
Key.

A
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The Multi-step Shortcut Icon

In the QuicKeys Editor, you can tell the difference between Single- and Multi-step Shortcuts by 
looking at the Shortcut icons. By default, Multi-step Shortcuts display an icon that looks like two 
shoe prints, while Single-step Shortcuts use the icon associated with a particular Shortcut Type.

Editing Multi-step Shortcuts
There are several ways to edit Multi-step Shortcuts:

�    Select a step in the Steps Drawer. The Shortcut Editing window will change to reflect the 
options for the selected step. Make changes to the step in the Shortcut Editing window.

�    Drag a step in the Steps Drawer to a different position or “step” in the Steps Drawer. A black 
line will appear as you drag the step to make it easier to track where the Shortcut is being 
moved in the Multi-step Shortcut.

�    Open multiple Shortcut Editing windows and drag steps from the Steps Drawer in one win-
dow to the Steps Drawer of another window.

�    Select Shortcuts>Delete Shortcut to delete the selected Multi-step Shortcut.

�    Select Shortcuts>Delete Step to delete the selected step in a Multi-step Shortcut.

�    Select the step you want to delete and press Control+click. Select Delete from the menu that 
appears.

FIGURE 41. By default, Multi-step 
Shortcuts use a shoe print icon.
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Example: Typing in TextEdit
Multi-step Shortcuts are a collection of QuicKeys steps that automate more complex tasks. The follow-
ing instructions build on the Single-step Shortcut you created on page 38. In this part of the example, 
you will add steps to the TextEdit Shortcut that will type text in an open TextEdit document. 

❖Note: To create a Multi-step Shortcut, the Shortcut Editing window must be active.

1. In the Shortcut List of the QuicKeys Editor, double-click the TextEdit Shortcut you created on 
page 38. The Shortcut Editing window appears. 

❖Note: You may need to add a Pause step to this Shortcut so that the operating system can keep up 
with QuicKeys.

2. Select Create>Text>Type Text. The TextEdit Shortcut Editing window should now have two steps listed 
in the Steps Drawer.

3. Type the following text in the Text to insert/type field of the Shortcut Editing window: CE Software Technical 
Support Document. 

FIGURE 42. Select Create>Text>Type Text.
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4. Select the Insert Text option at the bottom of the Shortcut Editing window. More information on 
the Insert Text and Type Text options is available on page 121. 

5. Select Create>User Actions>Type Keystroke. With the Type Keystroke Shortcut Editing window active, 
click the Keystroke field and press the Return key on your keyboard.

FIGURE 43. The Type Text step appears in the Steps Drawer.
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6. Select Create>Text >Type Text.

7. Type Created on in the Text to insert/type field. Make sure there is a space after the word “on”.

❖Note: Text can be typed as two separate steps as shown in this example or you can use a single 
Type Text Shortcut with a carriage return separating the lines of text in the Text to insert/type field.

8. Select Create>QuicKeys>Pause.

FIGURE 44. Type additional text in the Shortcut Editing window.
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9. Set up the pause to last one second. See Figure 45.

10. Select Create>Text>Date & Time.

FIGURE 45. The Pause Shortcut Editing window
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11. Select Short Date from the pop-up list.

12. Click the Close button to close the Shortcut Editing window. Your new Multi-step Shortcut appears 
in the Shortcut List. Note that the Shortcut icon now has a special icon indicating it is a Multi-step 
Shortcut.

FIGURE 46. Short Date step
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13. To play your new Multi-step Shortcut, press Command+Shift+9. (This is the same trigger you 
assigned in the Single-step Shortcut instructions). If the Show Playback palette preference is on, 
the Playback palette appears while QuicKeys launches the TextEdit application and types the 
information about CE Software Technical Support in the open document. See Figure 47.

FIGURE 47. The result of your Multi-step Shortcut.
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Example: Resizing Your Browser Window
Sometimes Web sites adjust your browser window size, forcing you to constantly click and drag the cor-
ner of your window to resize it. This process can be tedious and frustrating if you spend a lot of time on 
the Web. Fortunately, a simple two-step QuicKeys Shortcut can streamline the process.

In the following example, the first step moves the window to the upper left corner of your screen and 
the second step resizes the window to 750 pixels wide by 550 pixels tall. This example assumes that you 
are in Simple Triggers mode.

1. Select Create>User Actions>Clicks>Click.

2. In the Click Location area of the Click Shortcut Editing window, type 100 in the Horizontal field and 
-10 in the Vertical field. These coordinates are in the title bar of the window, about one inch from the 
left end.

3. In the Release Location area of the window, type 102 in the Horizontal field and 33 in the Vertical 
field. Release location is shown as defined at 102 horizontal by 33 vertical, relative to the main dis-
play. In this step you are grabbing the window by the title bar and moving it to the upper left corner 
of the screen.

FIGURE 48. Type your Click coordinates in the Click Shortcut Editing window.
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4. Click the Details button in the Shortcut Editing window.

5. Select the Click tab.

6. Select Window from the Click relative to pop-up list.

7. Select Frontmost from the Identify by pop-up list.

8. Click OK to close the Details window.

9. Select Create>User Actions>Clicks>Click to add another step to your Shortcut.

10. Click the Details button in the Shortcut Editing window.

FIGURE 49. Select “Click Relative to Window” in the Click tab.
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11. Type -5 in the Horizontal field and -5 in the Vertical field.

12. Select Window from the Click relative to pop-up list.

13. Select Frontmost from the Identify by pop-up list.

14. Click the lower right corner in the screen diagram. This selection will grab the window in the resize 
region. 

15. Click the Release tab.

FIGURE 50. Specify your Click settings in the Click tab.
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16. Type 750 in the Horizontal field and 550 in the Vertical field. This setting will resize the window.

17. Select Window from the Release relative to pop-up list.

18. Select Frontmost from the Identify by pop-up list.

FIGURE 51. Select “Release relative to Window” in the Release tab.
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19. Click OK to close the Details sheet and return to the Shortcut Editing window.

20. Select File>Rename and type a name for your new Multi-step Shortcut.

21. If the Shortcut trigger area is hidden, click the Show/Hide button in the Shortcut Triggers area of the 
Shortcut Editing window. See Figure 5 on page 13 for an illustration of the Shortcut Editing win-
dow.

22. Select QuicKeys Menu from the Add Trigger pop-up list.

23. Select Internet Explorer from the Shortcut Scope pop-up list.

24. Close the Shortcut Editing window.

25. Make Internet Explorer your active application and select the Shortcut from the QuicKeys Menu to 
test it.

❖Note: Depending on the speed of your machine, you may need to insert a Pause step between the 
two Click steps for this Shortcut to work properly.

FIGURE 52. The Resize Browser Shortcut Editing window
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Example: Customizing Your “Get Info” Window
Whenever you select a file or folder and press Command+I, your computer displays a Get Info win-
dow that contains details about the selected file or folder. The Get Info window has several options 
that can only be displayed by clicking a display triangle. If you want the Get Info window to always 
have the “Ownership & Permissions” triangle toggled open whenever your press a Hot Key, use the 
following instructions. 

❖Note: This example assumes you are using the Simple Triggers mode. See page 25 for more 
information on Simple Triggers mode.

1. Before you create this Multi-step Shortcut, make the Finder active and select File>Get Info to open 
the Get Info window.

2. In the QuicKeys Editor, select Create>User Actions>Type Keystroke.

3. In the Keystroke field, press Command+I. This step will open the Get Info window.

FIGURE 53. The Type Keystroke Shortcut Editing window with the drawer displayed
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4. Select Create>QuicKeys>Wait. Notice that the steps drawer opens to the side of the QuicKeys Editor with 
the Wait step listed below the Type Keystroke step.

5. In the Wait Shortcut Editing window, select Window from the Wait until pop-up list.

6. In the Window Name pop-up list, select Contains and type Info in the text field that appears.

7. Select Any Type of Window from the Window Type pop-up list. The Wait step will ensure that the Multi-step 
Shortcut will wait for the Get Info window to appear before proceeding to the next step of the Short-
cut.

8. Select Create>QuicKeys>Pause.

FIGURE 54. Specify window positioning in the Wait Shortcut Editing window.
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9. Choose to pause for 0.5 seconds. This step is needed because the “Get Info” window may not be 
fully displayed by the System even though it appears to be open.

10. Select Create>User Actions>Button.

FIGURE 55. Specify a pause in the Pause Shortcut Editing window.

FIGURE 56. The Button Shortcut Editing window



57
11. Click Set Button. The Select Button window displays.

12. Leave the QuicKeys Editor and click the Ownership & Permissions display triangle in the Get Info 
window.

13. To set the location of the button click, press the Caps Lock when the QuicKeys selection rectangle 
covers the Ownership & Permissions display triangle.

FIGURE 57. Use the Select Button window to direct the QuicKeys Button step.

FIGURE 58. Use the Caps Lock to set the Button information.

Click Ownership & 
Permissions
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14. In the Select Button window, the name should be prefilled with the word “Triangle.”

15. Click OK when you are finished in the Select Button window.

FIGURE 59. Button information

FIGURE 60. Set your Button options
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16. In the Shortcut Editing window, select File>Rename Shortcut.

17. Specify a name for this Multi-step Shortcut.

18. If the Shortcut trigger area is hidden, click the Show/Hide button in the Shortcut Triggers area of the 
Shortcut Editing window. See Figure 5 on page 13 for an illustration of the Shortcut Editing win-
dow.

19. Select Hot Key from the Add Trigger pop-up list.

20. Press the Hot Key you want to use to display the Owners & Permissions area of the Get Info win-
dow.

21. Select Finder from the Shortcut Scope pop-up list. This setting ensures that this Shortcut will only work 
in the Finder.

22. Close the Shortcut Editing window when you are finished.

23. Switch to the Finder and press the Hot Key you assigned to play your new Multi-step Shortcut.

Drag-and-Drop Functionality
You can also build Multi-step Shortcuts by opening multiple Shortcut Editing windows and dragging 
steps from the Steps Drawer in one window to the Steps Drawer of another window.
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Chapter 6: 
Recording Shortcuts
QuicKeys offers a recording feature that enables the application to mimic your computer actions. Simply tell 
QuicKeys to watch and record what you do. Then play back that task with any trigger you specify. This chapter 
provides basic information on the recording feature along with a recording example. While the example may not 
directly apply to how you intend to use QuicKeys recording, it does provide an illustration of how QuicKeys can 
save time for anyone who uses a computer. For additional examples of QuicKeys recording, visit the QuicKeys 
Web site at http://www.quickeys.com/.

Recording Options
When you want to record a Single-step or Multi-step Shortcut, you can use one of several methods to initiate the 
recording:

�    Select Create>Start Recording Me.

�    Click the Record More button in the Shortcut Editing window.

�    Click the Record button in the QuicKeys Editor Toolbar.

Stop Recording

When you want to end or cancel a recording, use one of the following options:

�    Select Create>End Recording Me or click End Recording in the QuicKeys Recording window to stop recording 
and display the Shortcut Editing window.

�    Select Create>Cancel Recording Me or click the Cancel Recording button in the QuicKeys Recording window to 
cancel your recording. None of your actions are saved if you choose this option.

Recording Preferences

Select QuicKeys X2>Preferences and click the Recording tab to view QuicKeys Recording preferences. Select Do 
exhaustive click and typing analysis when you are experiencing problems typing or clicking in a sheet or drawer. Select-
ing this option slows down recording so you must click and type very slowly when you use it. Most of the time 
you will reserve the use of this preference for specific recordings that require interaction with a sheet or drawer.

FIGURE 61. The QuicKeys Recording window
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❖Note: If you press the Option key when you start a recording, the Do exhaustive click and typing 
analysis preference will toggle to the opposite setting for the current recording. 

QuicKeys Recording Tutorial
When you choose to record a Shortcut, the QuicKeys Recording Tutorial appears. Practice clicking 
and typing in the areas provided before you record your first Shortcut.

FIGURE 62. The QuicKeys Recording Tutorial
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Example: Filing E-mail Messages
If you use QuickMail Pro, you can use QuicKeys to quickly file messages into a specific personal mail 
folder. In this example, you will file an open message into a folder entitled “Status Reports.”

These instructions assume you are using QuickMail Pro and you have a mail folder in QuickMail Pro 
entitled “Status Reports.”

1. Open a message in QuickMail Pro.

2. Select Create>Start Recording Me. The QuicKeys Recording window appears.

3. In QuickMail Pro, click the File button to display the Message Filing dialog.

4. When the Message Filing dialog appears, type “stat.” The QuickMail Pro Message Filing dialog 
jumps to the Status Reports folder.

5. Press the Enter key to file the opened message in the Status Reports folder.

FIGURE 63. The QuicKeys Recording window
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6. Click the End Recording button on the QuicKeys Recording window. A Shortcut Editing window 
appears. Notice that the Steps Drawer is open and it contains all the Steps that make up your 
recording.  

7. Review the Step Results column of the Steps Drawer. This will help you follow the anticipated 
flow of the Multi-step Shortcut.

8. Select File>Rename and type a name for your recording.

9. Select your mail program from the Shortcut Scope list.

10. Close the Shortcut Editing window to save your new recording.

11. Play the Shortcut and make any necessary adjustments. (See “Editing Multi-step Shortcuts” on 
page 42.) 

Additional Recording Examples
For additional recording examples, refer to the QuicKeys X2 CD or the QuicKeys Community 
forum at http://forum.cesoft.com/. 

FIGURE 64. The Shortcut Editing window for the e-mail recording.
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Playing Shortcuts
When you play a QuicKeys recording, the Playback palette appears. Use one of the following methods 
to play your QuicKeys recordings:

�    Select a recorded Shortcut in the QuicKeys Editor and select Shortcuts>Play.

�    Use the trigger you assigned to the QuicKeys recording.

QuicKeys Debugging
QuicKeys offers a debugging tool that can help you troubleshoot your recordings. Select Shortcuts>Turn on 
Shortcut Debugging to turn on this tool. When debugging is enabled, QuicKeys guides you through each 
step of your Multi-step Shortcut to help you verify that the Shortcut will perform properly. The Debug-
ging option is available for Click, Windows, Buttons, Pop-up Menu, and Wait Shortcut Types.

�    If the step shown by the debugger is correct, click the Continue button. 

�    If the step shown is not accurate, click the Stop & View step button and the Shortcut Editing window 
will appear with the questioned step highlighted. 

�    Click the Stop button during debugging when you are not interested in verifying the Multi-step 
Shortcut and you want to stop the playback process.

FIGURE 65. The Playback palette
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Shortcut Debugging

When Shortcut debugging is turned on, the debugging window appears. While in Shortcut Debug-
ging mode, click the Execute next step button to play the steps of the Shortcut one at a time. Clicking 
the Play Shortcut button plays the Shortcut at normal speed. If a Shortcut is paused after clicking the 
Play Shortcut button and the Execute next step button in the Playback palette is clicked, the Shortcut 
will continue in step-by-step mode.

Step-by-Step Debugging

When Shortcut debugging is turned off, clicking the Execute next step button will cause the Shortcut to 
play back each step of the Shortcut. Clicking the Play button will continue playing the Shortcut at 
normal speed.

Notes About Debugging

�    The Playback palette will always appear if you are in debug mode, regardless of how your 
QuicKeys preferences are set.

�    As long as you are in Shortcut Debugging mode, the Shortcut will play in step-by-step 
mode.

FIGURE 66. Debugging shades the screen to pinpoint each Shortcut step.
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Recording Shortcuts: Tips and Troubleshooting
You may need to edit some steps of your recording for it to work properly. This section contains a few 
tips on things you can do to get the most out of QuicKeys recording.

�    If your recording does not properly capture your mouse movements, create a separate Mouse 
Recording Shortcut to capture a particular segment of your Multi-step Shortcut. When you have 
verified the Mouse Recording Shortcut functions properly, insert it into your Multi-step Short-
cut. See page 140 for more information on Mouse Recording.

�    Record your actions slowly.

�    By default, when a Shortcut is played and doesn’t function properly, QuicKeys displays a dialog 
with information that helps you troubleshoot the problem. See Figure 67. 

Inserting Steps

You may need to insert steps, such as a Pause, in your recording to make it function properly. To insert a 
step in a recording, follow these steps:

1. Open the Shortcut Editing window for the recording.

2. Select a step in the Shortcut Editing drawer. The new step will be inserted directly after the selected 
step.

3. Select a Shortcut Type from the Create menu. The new step appears in the Shortcut Editing drawer.

4. Close the Shortcut Editing window and play the Shortcut to test it.

FIGURE 67. The Results dialog appears when an error has occurred in your Multi-step Shortcut.
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Managing QuicKeys
This chapter discusses standard procedures for managing QuicKeys on a day-to-day basis. It also provides infor-
mation on setting QuicKeys preferences, and importing and exporting Shortcuts.

Saving Shortcuts
By default, QuicKeys prompts you to save your Shortcuts when closing a Shortcut Editing window.

Backing Up Shortcuts
To back up your QuicKeys Shortcuts, copy your personal QuicKeys folder to another drive or to removable 
media. Your QuicKeys folder is located in the Users:<yourname>:Library.

You can also export your Shortcuts to removable media to back up your data, however this method does not 
archive toolbar information. See page 78 for more information on exporting Shortcuts.

Customizing Editor Toolbars
You can customize your QuicKeys Editor and Shortcut Editing Toolbars by adding or removing toolbar buttons. 
You can place a button on the toolbar for each Shortcut Type available or you can simply drag the default toolbar 
button set to the QuicKeys Editor or Shortcut Editing Toolbar area. If you have more buttons on the toolbar than 
the windows can display, an arrow appears on the toolbar with a pop-up menu that enables you to select the tool-
bar buttons that are not visible.

❖Note: All statements referring to the functionality of the QuicKeys Editor Toolbar can also be applied to 
the Shortcut Editing Toolbar.

The QuicKeys Editor Toolbar and the Shortcut Editing Toolbar can display different buttons to better accommo-
date the way you work. However, changing a built-in toolbar in one Shortcut Editing window will change all 
Shortcut Editing windows.
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Adding Buttons

1. To add a button to the QuicKeys Editor Toolbar, select View>Customize Editor Toolbar.

2. Drag one or more items to the QuicKeys Editor Toolbar. A button representing the Shortcut 
Type appears on the QuicKeys Editor Toolbar.

3. Click Done in the Customize Editor Toolbar sheet. 

FIGURE 68. Customize the QuicKeys Editor Toolbar with the Customize Editor Toolbar sheet.
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Rearranging Buttons

There are two different ways to rearrange buttons on the QuicKeys Editor Toolbar:

�    If the Customize Editor Toolbar sheet is open, you can drag-and-drop the buttons to rearrange 
them.

�    If the Customize Editor Toolbar sheet is not open, you can rearrange buttons on the QuicKeys 
Editor Toolbar by pressing the Command key while dragging a button to a new location on the 
toolbar.

Deleting Buttons

You can delete buttons from the QuicKeys Editor Toolbar using the contextual menu option, by Com-
mand+dragging buttons off the toolbar or by following these steps:

1. Select View>Customize Editor Toolbar. The Customize Toolbar sheet appears.

2. Drag one of the items off of the QuicKeys Editor Toolbar and view your changes in the QuicKeys 
Editor Toolbar.

3. Click Done.

Adjusting Icons and Text

You can adjust the QuicKeys Editor Toolbar icons and text using the contextual menu or by following 
these steps:

1. Select View>Customize Editor Toolbar. The Customize Toolbar sheet appears.

2. Select an option from the Show pop-up list on the Customize Editor Toolbar sheet. Choose from Icon & 
Text, Icon Only or Text Only.

3. Click Done.

FIGURE 69. Adjust the appearance of the QuicKeys Editor Toolbar using the Show pop-up menu in the 
Customize Editor Toolbar sheet.
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Hiding the QuicKeys Editor Toolbar

Use one of the following methods to hide the QuicKeys Editor Toolbar:

�    Click the button in the upper right corner of the QuicKeys Editor window.

�    Display the QuicKeys Editor and select View>Hide Editor Toolbar.

Showing the QuicKeys Editor Toolbar

To show the QuicKeys Editor Toolbar, display the QuicKeys Editor and select View>Show Editor Toolbar 
or you can click the button in the upper right corner of the QuicKeys Editor window.

Setting Preferences
To set QuicKeys preferences, select QuicKeys X2>Preferences. The Preferences window is divided into 
three tabs: General, Triggers, and Recording.

General Tab

This section describes the General options in the QuicKeys Preferences.

FIGURE 70. The General Preferences tab
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Show Playback Palette

If the Show Playback Palette preference is set, the Playback palette appears when QuicKeys is play-
ing a Shortcut.

Automatically name single step Shortcuts

Select the Automatically name single step Shortcuts checkbox to allow QuicKeys to automatically 
name your Shortcuts. For example, if you create a Change Folder Shortcut that selects your 
Pictures folder, QuicKeys will automatically name the Shortcut “Pictures.” However, if you do 
not have this preference selected, QuicKeys would name that same Shortcut “Change Folder.”

The following Shortcuts do not automatically rename, regardless of how the preference is set: 
AppleScript (text only), Click, E-mail, Manage Files, Pause, Insert Shortcut, Mouse Recording 
(if there is no description), Terminal Command and Type Text.

Automatically save Shortcuts

When this preference is not enabled, QuicKeys prompts you to save the Shortcut when closing 
the Shortcut Editing window. Disabling this preference is useful when you do not want to save 
the changes you made to a Shortcut.

FIGURE 71. The Playback palette
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Show QuicKeys Menu

Select this option when you want to display the QuicKeys Menu in the upper right corner 
of your screen.

Show QuicKeys Icon on Dock

When this preference is selected, the QuicKeys icon displays on the Dock when QuicKeys 
is active. You may want to deselect this preference if you don’t need to display the QuicK-
eys Editor very frequently and you want the QuicKeys application to be completely trans-
parent. Any changes you make to this preference affect all users and only take effect after 
relaunching QuicKeys.

Show QuicKeys Menu in Dock

If this preference is set, a menu appears when you click and hold the QuicKeys icon in the 
Dock.

FIGURE 72. The QuicKeys Menu

FIGURE 73. QuicKeys options displayed from the Dock
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Animate Dock icon when playing Shortcuts

If you have a QuicKeys icon in your Dock and this preference is selected, the Dock icon is ani-
mated while Shortcuts are playing.

Open QuicKeys at log in

Select this preference when you want the QuicKeys application to launch when you login to 
your computer. If this option is not selected, you must manually launch the QuicKeys applica-
tion.

Display QuicKeys Editor window on open

When this preference is set, the QuicKeys Editor window opens when you launch QuicKeys. If 
this preference is not selected, you may open the QuicKeys Editor by selecting it from the 
QuicKeys Menu, from the Dock menu, or by double-clicking the QuicKeys application in the 
Applications folder.

Display warning when quitting

Select this option to show a warning that QuicKeys is unable to trigger Shortcuts when the 
QuicKeys application isn’t running. This warning appears each time you quit the QuicKeys 
application.

Reset “Do Not Show Again” messages

Click the Reset button when you want to reset all your Do not show again QuicKeys checkboxes. 
For example, if you click Do not show again in the Delete dialog when you delete a Shortcut, that 
dialog will not display again unless you click the Reset button in the Preferences window.
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Triggers Tab

This section describes the Triggers options in the QuicKeys Preferences.

Advanced Triggers

Select the New Shortcuts have advanced triggers option when you want all the Shortcut Editing 
windows for new Shortcuts to display the Advanced Triggers list rather than the Simple 
Triggers list.

Hot Key Sticky Duration

When you select the Hot Key is Sticky checkbox in the Info window, QuicKeys will use the 
duration setting you specify in the QuicKeys Preferences dialog. The Sticky option allows 
you to assign sequential key presses. For example, if you select the Sticky option and assign 
Shift+F1 and Shift+F2 in the Triggers area, QuicKeys will play that Shortcut when you 
press Shift+F1, release Shift+F1 and press Shift+F2. Adjust the slider to Short for a brief 
pause between key presses or select Long if you require additional time between your 
sequential key presses.

FIGURE 74. The Triggers Preferences tab
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Recording Tab

This section describes the Recording options in the QuicKeys Preferences.

Action Analysis

Select the Do exhaustive click and typing analysis option when you are experiencing problems typing 
or clicking in a sheet or drawer. Selecting this option slows down recording so you must click 
and type very slowly when you use it. Most of the time you will reserve the use of this prefer-
ence for specific recordings that require interaction with a sheet or drawer.

❖Note: If you press the Option key when you start a recording, the Do exhaustive click and typing analysis 
preference will toggle to the opposite setting for the current recording. 

FIGURE 75. The Recording Preferences tab
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Printing Shortcuts

To print a list of displayed Shortcuts, select File>Print.

Importing Shortcuts
You can import QuicKeys Shortcuts when you receive them from other QuicKeys X users. When 
you import Shortcuts, you import all the attributes originally assigned to those Shortcuts (such as 
triggers and descriptions).

To import Shortcuts, follow these steps:

1. Select File>Import Shortcuts.

2. Navigate to the exported Shortcut file, select the Shortcut file and click Open.

Exporting Shortcuts
Export Shortcuts when you want to share them with other QuicKeys X users.

1. Select one or more Shortcuts or a Scope in the QuicKeys Editor window.

2. Select File>Export Shortcuts.

3. Name the export file, navigate to the location where you want to store the exported Shortcuts 
and click Save.

FIGURE 76. The Exported Shortcuts window
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QuicKeys Toolbars
QuicKeys toolbars enable you to play QuicKeys Shortcuts with a single click. QuicKeys toolbars have three 
components: the toolbar itself, the buttons on the toolbar and the toolbar tabs. You can create or edit these com-
ponents using the Toolbar Editing sheet.

It’s important to note that the QuicKeys toolbars discussed in this chapter are toolbars you create to play QuicK-
eys Shortcuts. The QuicKeys Editor and Shortcut Editing Toolbars discussed in Chapter 3 are built into the 
QuicKeys application.

Creating Toolbars
You can create QuicKeys toolbars by selecting Toolbars>New Toolbar when the QuicKeys Editor is open. When you 
choose to create or edit a QuicKeys toolbar, the Toolbar Editing sheet appears. Any changes to toolbars are saved 
as soon as you click the OK button.

This section highlights the different options available in the Toolbar Editing sheet.

❖Note: Toolbar buttons are limited to a single row.

Toolbar Name

When you create a QuicKeys toolbar you can type a name for the toolbar in the Toolbar tab Name field. 

FIGURE 77. The Toolbar tab in the Toolbar Editing sheet
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Toolbar Hot Key

You can show or hide a QuicKeys toolbar with a Hot Key. Position your cursor in the Hot Key field 
and press the key(s) you want to use to display the selected toolbar. Click the Clear button to remove 
your Hot Key selection. 

❖Note: If the Hot Key field is active, all QuicKeys Hot Keys are turned off until you move your 
cursor out of the Hot Key field. This functionality ensures that QuicKeys does not play a 
Shortcut while you are assigning a toolbar Hot Key.

Toolbar Scope

Toolbar Scope is the range of operation for a toolbar. For example, you can choose whether a spe-
cific toolbar displays only when Microsoft Word is frontmost, or whether it appears regardless of 
which application is frontmost. Choose All Applications to display a toolbar regardless of which appli-
cation is frontmost. 

Toolbar Types

There are two types of toolbars available with QuicKeys X: Standard and Docked.

Standard Toolbars

Standard toolbars can be moved anywhere on your desktop. With Standard toolbars, you 
can click on the title bar of the toolbar and drag it to another desktop location. 

FIGURE 78. The View tab
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Docked Toolbars

A Docked toolbar attaches to the edge of the computer screen. This type of toolbar is useful 
when you want to keep your toolbar out of the way along the side of your screen. You can drag 
Docked toolbars from one side of your screen to another. Docked toolbars will spring back to 
the closest screen edge when you drag them across your screen and you release, or stop mov-
ing, your mouse.

Always on top

Select the Always on top checkbox to ensure that QuicKeys toolbars always display on top of other active 
application windows. This option is useful because it gives you easy access to the toolbar without hav-
ing to move windows around to get to the toolbar.

Icon Size

Use the slider bar to specify the size of icons in your toolbar. The dimensions of your icons appear next 
to the slider.

Placement

Make a selection in the Placement pop-up list to customize the appearance of your toolbar buttons. After 
you make a selection from the pop-up menu, use the slider bar to specify the size of your icons. See the 
following examples of Placement options.
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Name Only (No Icon)

Icon Only (No Name)

Name Right of Icon

Name Left of Icon

Name Above Icon

Name Below Icon

Name Overlaps Icon
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Resize 

Select the Automatically checkbox when you want your toolbars to resize to accommodate a change on a 
toolbar. 

Turning off the Automatically checkbox disables your ability to automatically resize when toolbar buttons 
are added or removed. If you have turned off the Automatically option, you can resize a toolbar by clicking 
on the lower right corner of the toolbar and dragging.

❖Note: When you drag an item onto a toolbar that has the Automatically option turned on, you can 
press the Command+Option keys to temporarily disable auto-resizing. This prevents the buttons 
from shifting around when you are dragging an item onto a toolbar button.

Orientation

Choose whether you want your toolbar to display vertically or horizontally.

❖Note: Toolbar buttons are limited to a single row. 

Setting the Toolbar Tabs Orientation

Choose whether you want the Toolbar Tabs to display on top of the toolbar buttons, on the bottom, to 
the left, or to the right.
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Toolbar Tabs

You can create multiple tabs for your QuicKeys toolbars using the Tabs area of the Toolbar Editing 
sheet. Multiple tabs enable you to better organize the buttons on your toolbar. Click the Add Tab but-
ton to add a tab and provide a name for the tab in the Tab Name field.

Renaming Toolbar Tabs

To rename a Toolbar tab, make sure the toolbar is open and follow these instructions:

1.  Select Toolbars>Edit Toolbar.

2.  Click the Tabs area of the Toolbar window. See Figure 79.

3.  Select the tab you want to rename from the Tabs pop-up menu.

4.  Type a new name for the tab in the Tab Name field and click OK.

Deleting Toolbar Tabs

There are two ways to delete Toolbar tabs:

�   Select the tab you want to delete and click the Delete Tab button in the Toolbar Editing 
sheet Tabs area.

�   Control+click the tab you want to delete and select Delete Tab from the contextual menu 
that appears.

FIGURE 79. The Tabs area of the Toolbar Editing sheet
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Adding Shortcuts to Toolbars
You can add Shortcuts to QuicKeys toolbars using one of the following methods:

�    Drag Shortcuts from the Shortcut List and drop them onto a toolbar.

�    Drag application icons, files and folders to toolbars to create Open Items buttons. This action 
will create a button on the toolbar and a new Shortcut in the QuicKeys Editor. Dropping a file 
onto an existing Open Items Shortcut opens the file in that application, as long as the application 
recognizes the file. 

�    Drag text onto a toolbar to create a Type Text Shortcut.

�    Drag a fully qualified Uniform Resource Locator (URL) onto a toolbar to create a Web Address 
Shortcut.

Displaying Toolbars
You can display QuicKeys toolbars by selecting them from the QuicKeys Menu or from the Dock 
menu. You can also assign a Hot Key trigger for a toolbar in the Toolbar Editing sheet and display the 
toolbar by pressing the Hot Key.

Hot Help

Hot Help is descriptive text that appears over toolbar buttons, helping you 
identify the purpose of each toolbar button. To display Hot Help text, hover 
over a toolbar button.
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Viewing the Toolbars Window
To view a list of your toolbars, select Window>QuicKeys Toolbars.

Editing Toolbars
You can display the Toolbar Editing sheet by selecting a toolbar in the QuicKeys Toolbars window 
and selecting Toolbars>Edit Toolbars.

There are a number of things you should know about editing QuicKeys toolbars:

�    Multiple toolbars can be edited concurrently.

�    Control+click on a toolbar and select Edit Toolbar or one of the other options that are shown in 
Figure 81. 

❖Note: Control+click does not work on the title bar of the toolbar.

�    When the Toolbar Editing sheet is open, the trigger for that particular toolbar is disabled.

FIGURE 80. The Toolbars window

FIGURE 81. Use the contextual menu that appears when you Control+click toolbars.
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�    When you edit the Hot Key trigger for a toolbar, all Hot Keys are disabled until the Hot Key 
field is no longer active. When Hot Keys are disabled, an “X” appears over the QuicKeys Dock 
icon.

�    Buttons cannot be dragged from one toolbar tab to another.

Closing Toolbars

Use one of the following methods to hide a toolbar:

�    Click the close button on the toolbar.

�    Select the toolbar from the QuicKeys Menu.

�    Press the Hot Key assigned to the toolbar.

Deleting Toolbars and Toolbar Components
You can use the following methods to delete toolbars, toolbar buttons and toolbar tabs:

�    Control+click anywhere on a toolbar and select Delete Toolbar.

�    With a toolbar selected and the Toolbars window frontmost, select Toolbars>Delete Toolbar.

�    Toolbar buttons are automatically deleted when the Shortcut represented by that button is 
deleted.

�    Toolbar buttons can be removed from the toolbar by Command+dragging them off the toolbar.

�    Control+click anywhere on a multi-tab toolbar and select Delete Tab.

FIGURE 82. You must verify your selection when you delete any toolbar components.
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File and Folder Tools
All computer users must learn how to manipulate files and folders early in their computer experience. Navigating 
through countless directories searching for that one file soon becomes second nature out of necessity, but such 
tasks can also become quite time-consuming. QuicKeys can automate these tedious tasks with Shortcut Types 
such as Change Folder, Manage Files and Open Items.

Change Folder
The Change Folder Shortcut Type enables you to switch to a different folder in any standard Open or Save dia-
log. This capability saves you time because it allows you to quickly jump to frequently-used folders. To open the 
Change Folder Shortcut Editing window, select Create>Files>Change Folder. The Shortcut Editing window appears 
with the Change Folder options listed.

Change Folder Options

When you create a Change Folder Shortcut, click the Select button and navigate to the folder you want to use in 
your Shortcut. Select the folder and click the Choose button.

You can also drag files or folders over the icon shown in Figure 83 to add or change the location of the file or 
folder.

❖Note: The path of the item you selected will appear if you hold your pointer over the file or folder icon in 
the Shortcut Step area of the Shortcut Editing window.

FIGURE 83. The Change Folder Shortcut Type options
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Manage Files
The Manage Files Shortcut Type is useful when you want to copy or move files and folders with a 
QuicKeys trigger. For example, you can use this Shortcut Type to copy files or folders from your 
personal directory to your shared directory. To open the Manage Files Shortcut Editing window, 
select Create>Files>Manage Files. The Shortcut Editing window appears with the Manage Files options 
listed.

Manage Files Options

This section describes the Shortcut-specific options available with the Manage Files Shortcut Type.

Action pop-up list

�   Copy - Copies the specified target item to the specified destination folder.

�   Move - Moves the specified target item to the specified destination folder.

Target Item

Choose between Finder Selection or Specified targets. If you choose Specified, click the Select but-
ton and navigate to the item you want to copy or move. Click Choose after you select the 
item.

FIGURE 84. The Manage Files Shortcut Type options
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Destination Folder

Click the Select button and navigate to the destination folder where you want to copy or move 
the selected items. Select the destination folder and click Choose.

Replace existing files

To replace existing files during the copy or move action, click the Replace existing files checkbox.

❖ Note: The path of the item you selected will appear if you hold your pointer over the folder 
or file icon in the Shortcut Step area of the Shortcut Editing window.

Open Items
The Open Items Shortcut Type is useful when you want to open files, folders or applications with a 
QuicKeys trigger. For example, you can use this Shortcut Type to open your Documents folder. To open 
the Open Items Shortcut Editing window, select Create>Files>Open Items. The Shortcut Editing window 
appears with the Open Items options listed.

Open Items Options

When you create an Open Items Shortcut, you must click the Select button and navigate to the 
item you want to open with QuicKeys. Select the item and click the Open button.

❖ Note: The path of the item you selected will appear if you hold your pointer over the folder 
or file icon in the Shortcut Step area of the Shortcut Editing window.

Other Ways of Creating Open Items Shortcuts

�   Drag-and-drop a file or folder onto the Shortcut List of the QuicKeys Editor.

�   Drag-and-drop a file or folder onto a QuicKeys toolbar.

FIGURE 85. The Open Items Shortcut Type options
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Chapter 10: 
Internet and Network Tools
If your computer does not have access to other computers or to the Internet, the information in this chapter will 
not be applicable to you. If, however, your computer does have Internet or network access, there are several tasks 
that QuicKeys can help with. These tasks include preparing e-mail messages, opening Web sites and mounting 
other servers.

E-mail
QuicKeys helps you make the best use of your time by providing the ability to create and send messages with a 
simple QuicKeys trigger. To open the E-mail Shortcut Editing window, select Create>Internet>E-mail. The Shortcut 
Editing window appears with the E-mail options listed.

When you create an E-mail Shortcut, you can type the E-mail address you want to send to, the subject of the mes-
sage and/or the body of the message.

FIGURE 86. The E-mail Shortcut Type options
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Web Address
The Web Address Shortcut Type is useful when you want to display Web sites with a simple QuicK-
eys trigger. Using QuicKeys is easier than using browser bookmarks because you do not have to 
use your mouse and your Web browser doesn’t even have to be running. To open the Web Address 
Shortcut Editing window, select Create>Internet>Web Address. The Shortcut Editing window appears 
with the Web Address options listed.

❖Note: You can drag-and-drop a URL from other documents into the QuicKeys Editor or 
onto a QuicKeys toolbar to create a Web Address Shortcut. 

Web Address Options

This section describes the Shortcut-specific options available with the Web Address Shortcut.

Open URL

Selecting Open URL will open the location specified in the Web address to open field.

Open Selected Text as URL

Selecting Open Selected Text as URL will open text you select as if it were a URL.

Selecting the Make applications share selection option will force different applications to recog-
nize clipboard text as a URL.

FIGURE 87. The Web Address Shortcut Type options
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Servers
The Servers Shortcut Type is useful when you want to mount network servers quickly. Once you set up 
a few Servers Shortcuts, you can say goodbye to endless logins and password prompts. To open the 
Servers Shortcut Editing window, select Create>Network>Servers. The Shortcut Editing window appears 
with the Servers options listed.

Servers Options

This section describes the Shortcut-specific options available with the Servers Shortcut Type.

Server Type

Choose whether the server uses AppleShare (IP) or AppleShare (AppleTalk).

Zone

You can specify a zone for your AppleTalk server.

Server

Type the name of the server you are using when you select AppleShare (AppleTalk) from the Server 
Type pop-up list.

FIGURE 88. The Servers Shortcut Type options



96 Chapter 10
Internet and Network Tools
Address

The IP address (206.123.456.1) or DNS entry (servername.companyname.com) of the 
server you want to access. This option is available when you select AppleShare (IP) from the 
Server Type pop-up list.

Volume

The volume name on the server you want to access.

User Name

Type your user name in the User Name field. You can leave the name and password fields 
blank if you are logging in as a guest.

Password

Type your password in the Password field. You can leave the name and password fields 
blank if you are logging in as a guest.

FIGURE 89. The AppleShare (IP) options
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QuicKeys Tools
QuicKeys tools give you special controls over the QuicKeys application. You can use QuicKeys tools to insert 
Shortcuts, pause Shortcuts, open the QuicKeys Editor, pause/continue playback of a Shortcut or show/hide tool-
bars. This chapter provides information about each of the Shortcut Types within the QuicKeys tools category.

Insert Shortcut
Use the Insert Shortcut Type to insert existing Shortcuts in your Multi-step Shortcuts. You can choose to repeat 
the Shortcut several times within the Multi-step Shortcut. To open the Insert Shortcut Editing window, select 
Create>QuicKeys>Insert Shortcut. The Shortcut Editing window appears with the Insert Shortcut options listed.

Insert Shortcut Options

To create an Insert Shortcut, drag a Shortcut from the QuicKeys Editor to the box in the Shortcut Step area of the 
Shortcut Editing window. Then, specify how many times you want the Shortcut repeated in the Play X times box.

FIGURE 90. The Insert Shortcut Type options
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Message
Use the Message Shortcut Type to create a custom dialog that displays at a designated point in a 
Multi-step Shortcut.

Message Options

�    Message—Type the message text you want displayed in the QuicKeys Message dialog or 
spoken by your computer.

�    Display message in window—Click this checkbox when you want the provided message 
text to appear in the QuicKeys Message dialog.

�    Display cancel button—Click this checkbox when you want a Cancel button to appear in the 
QuicKeys Message dialog.

�    Continue automatically after X seconds —Specify how long you want QuicKeys to wait 
after displaying the QuicKeys Message dialog.

�    Speak message—Click this checkbox to direct your computer to speak the text you pro-
vided.

FIGURE 91. The Message Shortcut Type options
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�    Sound—Choose the sound you want QuicKeys to make when the Message Shortcut is played.

�    Play sound—Click this checkbox when you want QuicKeys to make a sound when the Message 
Shortcut is played.

Pause 
Use the Pause Shortcut Type to pause a Multi-step Shortcut for a user-specified amount of time. To open 
the Pause Shortcut Editing window, select Create>QuicKeys>Pause. The Pause Shortcut Editing window 
appears with the Pause options listed.

Pause Options

When you create a Pause Shortcut, you must specify how many seconds you want QuicKeys to pause.

❖Note: Pause Shortcuts are especially helpful when a Multi-step Shortcut needs to be slowed 
down so the operating system can make necessary items available.

FIGURE 92. The Pause Shortcut Type options
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QuicKeys Actions
You can use the QuicKeys Actions Shortcut Type to control parts of the QuicKeys application with 
QuicKeys triggers. You can open the QuicKeys Editor; pause or continue the playback of a Short-
cut; and show, hide or toggle QuicKeys toolbars. To open the QuicKeys Actions Shortcut Editing 
window, select Create>QuicKeys>QuicKeys Actions. The Shortcut Editing window appears with the 
QuicKeys Actions options listed.

QuicKeys Action Options

This section describes the Shortcut-specific options available with the QuicKeys Actions Shortcut 
Type.

�    Open QuicKeys Editor—Opens the QuicKeys Editor.

�    Pause Playback/Continue Playback—Pauses and continues playback of Shortcuts.

�    Show Toolbars/Hide Toolbars/Toggle Toolbars—Controls QuicKeys toolbars by showing or 
hiding them. Use the Toggle Toolbars option to alternately show and hide the toolbars with 
the same trigger. 

The Show All Toolbars option may not display all the toolbars you have created. Instead, it dis-
plays the toolbars that have a scope set for the active application as well as the toolbars that 
have a scope of All Applications.

FIGURE 93. The QuicKeys Actions Shortcut Type options
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Repeat Loop
You can use the Repeat Loop Shortcut Type to replay steps in a Multi-step Shortcut. You can also use 
the Repeat Loop Shortcut Type to terminate repeat loops. To open the Begin Repeat Loop Shortcut Edit-
ing window, select Create>QuicKeys>Repeat Loop>Begin Repeat Loop. To open the End Repeat Loop Shortcut 
Editing window, select Create>QuicKeys>Repeat Loop>End Repeat Loop. The Shortcut Editing window appears 
with the Repeat Loop options listed.

Repeat Loop Options

Repeat Action—Select Begin repeat loop to repeat the steps between the Begin Repeat Loop 
Shortcut and the End Repeat Loop Shortcut. 

Select End repeat loop to terminate a Begin Repeat Loop Shortcut. You must create an End Repeat 
Loop Shortcut in Multi-step Shortcuts to terminate a Begin Repeat Loop Shortcut.

If you select Begin repeat loop, the following options appear.

�   Repeat X times—Specify how many times you want the steps between the Begin Repeat 
Loop Shortcut and the End Repeat Loop Shortcut to repeat.

�   Prompt for repeat count—Select this option if you want QuicKeys to display a prompt 
where you can choose how many times you want the steps between the Begin Repeat 
Loop and the End Repeat Loop to repeat.

Wait
You can use the Wait Shortcut Type to specify which window or what type of window you want QuicK-
eys to look for when it is playing a Multi-step Shortcut. To open the Wait Shortcut Editing window, 
select Create>QuicKeys>Wait. The Shortcut Editing window appears with the Wait options listed.

FIGURE 94. The Repeat Loop Shortcut Type options
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Wait Options

Select Button, User Action, or Window from the Wait Until pop-up list. The options shown in the Shortcut 
Editing window will change depending upon which Wait option you select.

Button

If you select Button from the Wait until pop-up list, different pop-up lists appear.

�   Button Name—Select Is, Contains, Starts with, or Ends with from this pop-up list. Type the 
name, or partial name, of the button in the provided text box. 

�   Ignore case checkbox—Click this option if you want QuicKeys to ignore whether 
the button name is upper or lower case.

�   Which button if multiple matches—For most Shortcuts, “1” will remain the value of 
this field, but you may need to change the value if multiple buttons have similar 
names. For example, if you want QuicKeys to click a “Save” button, and there is a 
dialog that has three buttons that say “Don't Save,” “Save” and “Cancel” you would 
need to change the number to “2” since you want the second button (Save) to be 
selected. This adjustment is necessary since there are two buttons in the same dialog 
that contain the word “Save”.

�   Exists—Select Yes or No from the pop-up list to indicate whether or not the button 
exists.

FIGURE 95. The Button options for the Wait Shortcut Type
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�   Enabled—Choose Yes, No, or Do Not Care from the pop-up list.

�   Selected—Select Yes, No, or Do Not Care from the pop-up list.

�   Button Window—Choose which window will contain the button. You can chose from 
the Front Window, Front Document Window, Front Palette Window, Sheet on Front Window, Sheet on Front 
Document Window, Sheet on Front Palette Window, Drawer on Front Window, Drawer on Front Document Win-
dow, and Drawer on Front Palette Window. Use the Glossary for definitions of these terms.

User Action

If you select User Action from the Wait until pop-up list, you can select an option from the User Action 
pop-up list.

�   Click with Main Button—The left button on a three-button mouse.

�   Click With Second Button—The right button on a three-button mouse.

�   Click With Third Button—The middle button on a three-button mouse.

FIGURE 96. The User Action options for the Wait Shortcut Type
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�   Any Keystroke, Return, Enter, Space, Escape, Tab—Choose one of these options 
when you want QuicKeys to wait until one of these keys is pressed.

Window

If you select Window from the Wait until pop-up list, several window-specific pop-up lists 
appear.

�   Window Name—Select Is, Contains, Starts with, or Ends with from this pop-up list. Type 
the name, or partial name, of the window in the provided text box. Click the Ignore 
case checkbox if you want QuicKeys to ignore whether the window name is upper or 
lower case. See page 127 for more information on these options.

�   Window Type—Select Any Type of Window, Document Window, Palette Window, Sheet on Any Type 
of Window, Sheet on Document Window, Sheet on Palette Window, Drawer on Any Type of Window, 
Drawer on Document Window, or Drawer on Palette Window. See page 126 for more information 
on these options.

�   Window Level—Select Frontmost window when you want QuicKeys to identify the 
window by whether it is frontmost or select Any level when the window level isn’t rel-
evant.

�   Window State—Select Exists, Does Not Exist (closes), or Changes Order to indicate when 
you want QuicKeys to wait or continue.

FIGURE 97. The Window options for the Wait Shortcut Type
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Scripting Tools
QuicKeys enables you to enhance the functionality of your AppleScripts with time-saving QuicKeys triggers. 
For example, using the AppleScript Shortcut Type you can write a script that opens the System Preferences win-
dow with a Hot Key.

AppleScript
AppleScript is a programming language designed for controlling applications via Apple Events. It provides sim-
ple commands you can use to customize and automate your Mac. To open the AppleScript Shortcut Editing win-
dow, select Create>Scripting>AppleScript. The Shortcut Editing window appears with the AppleScript options listed.

AppleScript Shortcut Options

This section describes the Shortcut-specific options available with the AppleScript Shortcut Type.

FIGURE 98. The AppleScript Shortcut Type options
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Text

Clicking the Text option makes the Edit Text button active. Click the Edit Text button to display 
the AppleScript text sheet. Type your script in the Script Text sheet and click OK when you 
are done.

� Check Script—Checks the syntax of the text you provided. If there is a problem with your 
script, QuicKeys will notify you with a dialog similar to the one in Figure 100.

File

Click the File button to display a standard Open dialog and navigate to the script you want 
to play with QuicKeys. Select the Script and click Choose.

FIGURE 99. AppleScript in the Script Text field.

FIGURE 100. The AppleScript Compile Error window
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System Tools
System tools are invaluable if you like to control or change the behavior of the Mac environment. You can use 
the System Shortcut Types to gather Clips, log out, shut down or restart your computer, change Finder views, 
switch between applications or run terminal commands.

Clips
The Clips Shortcut Type enables you to gather and store Clips in a Clips Group. The Clips Shortcut is useful if 
you ever use Command+X, Command+C, Command+V key combinations to cut, copy, or paste text and graph-
ics to and from your system clipboard. Unlike items on your system clipboard, QuicKeys Clips are saved even if 
you restart your computer or quit QuicKeys. It is a permanent compilation of boilerplate text (formatted or unfor-
matted) and/or graphics that you can retrieve at any time to paste into a document.

The Clips Shortcut Type requires that you make at least two different types of Clips Shortcuts: one to gather text 
and graphic selections and one to display a list of clippings that you can choose to insert. You can use the exam-
ple discussed later in this section to learn more about creating each type of Clips Shortcut.

To open the Clips Shortcut Editing window, select Create>System>Clips. The Shortcut Editing window appears with 
the Clips options listed.

Make new Clip in selected group

Select this option when you want to set up a Clips Shortcut to gather Clips.

FIGURE 101. Clips Shortcut Type options for making Clips
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Use selection in front application

Select this option when you want to gather a Clip directly from an application.

Use contents of clipboard

Select this option when you want to gather Clips from your system clipboard. Use this 
option if some of your applications are not working properly with the Mac OS X built-in 
Clipboard. Creating a second copy/gather Shortcut to handle these situations might be 
necessary.

Insert selected Clip

Select this option when you want to set up a Clips Shortcut to insert Clips.

Paste Clip when inserting

Paste Clip when inserting functions similarly to a Command+V action. Select this option to 
paste the Clips into a selected document or window. This option is useful for pasting pic-
tures, icons, etc.

❖Note: In the Clips Shortcut Type window, choose an individual Clip from the list. 
QuicKeys will then paste that Clip without asking you to select a Clip from a Clips 
Group.

FIGURE 102. Clips Shortcut Type options for pasting Clips
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Type Clip when inserting

Select this option to type the Clip information rather than pasting it. This option is typically 
used for text or graphics where pasting isn’t available. 

�   Simulate keyboard when typing—Select this option when you want QuicKeys to simu-
late typing. This feature allows you to enter text in specific dialogs that don’t accept 
pasted text (such as Password fields and authentication dialogs).

New Clip Group

Clip Groups enable you to organize your Clips. Click the New Clip Group button to create a new Clip 
Group in which to store your Clips. To edit and organize your Clips list you can use the New Clip 
Group, Rename, and Delete buttons.

Rename

Click the Rename button to rename the selected Clip or Clip Group.

Delete

Click the Delete button to delete the selected Clip or Clip Group.

Make applications recognize Clip actions

Select this option when you want the Clips Shortcut Type to force target applications to recognize 
changes to the clipboard. If you have problems pasting a Clip into a particular application, selecting this 
checkbox may solve the problem.

FIGURE 103. Group your Clips so that you can easily reference them at a later time.
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Creating a “Gather Clip” Shortcut
When you set up a Clips Shortcut, you must create a Shortcut that copies Clips and a Shortcut that 
pastes Clips. The following set of instructions provides information on collecting Clips.

1. Select Create>System>Clips.

2. Select Make new clip in selected group.

3. Select Use selection in front application.

4. In the Add Trigger pop-up list, select Hot Key.

5. Assign a Hot Key. For example, press Control+C.

6. In the Shortcut Scope pop-up list, select All Applications. 

7. Rename the Shortcut and click OK.

8. Click the New Clip Group button at the bottom of the Clips Shortcut Editing window if you want to 
create a new group.

9. Name the Clips Group “Contact Info.”

10. Close the Shortcut Editing window.

FIGURE 104. Name your Clips Shortcut “Gather Clips”.

FIGURE 105. Name your Clips Group “Contact Info”.
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Using the Clips Shortcut to Gather Clips

Now that you have created your “Gather Clip” Shortcut, it’s time to populate your new Clips Group 
with Clips using the “gather” Shortcut.

1. Open a text editor, such as TextEdit.

2. Type a few lines of text. For example, type your name, address, phone and e-mail.

3. Use your mouse to highlight your name and press Control+C. The Save QuicKeys Clip window 
appears.

4. Type a name for your new Clip.

5. Select a Clip Group to assign your new Clip.

6. Click the Save button.

7. Repeat the steps in this section, selecting a different Clip each time. 

FIGURE 106. Save your Clips to a Clip Group.
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Creating a “Paste Clip” Shortcut

Now it’s time to create a “Paste Clip” Shortcut so you can paste the different Clips you gathered in 
the previous set of instructions.

1. Select Create>System>Clips.

2. Click Insert selected clip/prompt for clip from selected group.

3. Click Paste clip when inserting.

4. In the Add Trigger pop-up list, select Hot Key.

5. Assign a Hot Key. For example, press Control+V.

6. In the Shortcut Scope pop-up list, select All Applications. 

7. Rename the Shortcut, “Paste Clip.”

8. Close the Shortcut Editing window.

Pasting Text in Your Text Document

In this section you will use your new “Paste Clip” Shortcut to paste text from your Clip Group into 
a new document.

1. Open a new document in your Text Editor and position your cursor in it.

2. Press Control+V (your Clip Insert Hot Key). The Insert Clip dialog appears with the names of 
the Clips you have stored (address, name, e-mail, phone) on the left, and the contents of the 
selected Clip on the right.

FIGURE 107. Select a Clip to insert.



113
3. Select the name of the Clip you want to paste from the list.

❖Note: You can type the first few letters of a Clip name and QuicKeys will jump to the first occur-
rence of those letters.

4. Press the Return key to paste your name into the opened TextEdit document.

Deselecting Clips

To deselect an item in the Clips area, Command+click the item.

Computer 
The Computer Shortcut Type enables you to automate the process of logging out, putting your computer 
to sleep, restarting or shutting down your computer. To open the Computer Shortcut Editing window, 
select Create>System>Computer. The Shortcut Editing window appears with the Computer options listed.

Computer Shortcut Type Options

This section describes the Shortcut-specific options available with the Computer Shortcut Type.

�   Shut Down—Shuts down your computer.

�   Restart—Restarts your computer.

�   Sleep—Puts your computer to sleep.

�   Log Out—Logs out of the current user account.

�   Hide Front Application—Hides the frontmost application.

�   Hide Other Applications—Hides all but the frontmost application.

�   Show All Applications—Shows all open applications.

�   Bring All Windows to Front—Displays all windows associated with the selected application 
to the front.

�   Start Classic—Starts the Mac OS Classic operating system (if available).

FIGURE 108. The Computer Shortcut Type options



114 Chapter 13
System Tools
�   Stop Classic—Quits the Mac OS Classic operating system.

�   Start Screen Saver—Starts the user’s selected screen saver.

Finder Views
The Finder Views Shortcut Type enables you to adjust the appearance of Finder windows with a 
QuicKeys trigger. To open the Finder Views Shortcut Editing window, select Create>System>Finder 
Views. The Shortcut Editing window appears with the Finder Views options listed.

Finder View Options

When you set up a Finder Views Shortcut, you can choose to view windows in the Icons view, List 
view, or Columns view. Select the Change view in all open windows checkbox if you want your Finder View 
Shortcut to change the view of all your open Finder windows. If you do not select the checkbox, 
QuicKeys will only change the display of the active Finder window.

FIGURE 109. The Finder Views Shortcut Type options
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Switch Applications
The Switch Applications Shortcut Type enables you to move between applications with a Hot Key 
rather than a series of mouse clicks. You can create Shortcuts that switch to a particular application, 
move through all open applications in succession or toggle between two open applications.

To open the Switch Applications Shortcut Editing window, select Create>System>Switch Applications. The 
Shortcut Editing window appears with the Switch Applications options listed.

Switch Applications Options

This section describes the Shortcut-specific options available with the Switch Applications Shortcut. 

Switch to Next/Switch to Previous

Switching to the next or previous application is based on the order applications are listed in the 
Dock.

Switch to Specified

Choose which application to open. The pop-up menu that displays is populated with currently 
open applications. If the desired application is not listed, select Other. A standard navigation 
window appears where you can navigate to an application and click Choose.

�   Open if not running—Select the Open if not running checkbox if you want to open an application 
that isn’t currently running. This option is only available when Switch to Specified is selected.

FIGURE 110. The Switch Applications Shortcut Type options
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Switch Back

Switch Back returns to the application that was active before you performed your last 
Switch Applications Shortcut.

After Switch

Choose how the currently running application will be displayed when the application 
switch is complete. Choose Leave other applications visible, Hide previous application, or Hide other appli-
cations.

Terminal Command
The Terminal Command Shortcut Type executes UNIX commands. To open the Terminal Shortcut 
Editing window, select Create>System>Terminal Command. The Shortcut Editing window appears with 
the Terminal Command options listed.

Terminal Command Options

When you create a Terminal Command Shortcut, you must type your commands in the text box. 
Close the Shortcut Editing window when you are finished.

FIGURE 111. The Terminal Command Shortcut Type options
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Text Tools
The QuicKeys Date & Time and Type Text Shortcut Types save you time by typing the information you need 
with a QuicKeys trigger. This chapter provides information on using these Shortcut Types to type text and type 
the date and time.

Date & Time
The Date & Time Shortcut Type is useful when you want to insert the date and/or time into documents. For 
example, you can use this Shortcut to insert the date and time in your weekly reports. To open the Date & Time 
Shortcut Editing window, select Create>Text>Date & Time. The Shortcut Editing window appears with the Date & 
Time options listed.

Date & Time Standard Options

The options available in the Date & Time Shortcut Editing window are dependent upon what is selected in the 
Type pop-up menu. An example of the selected format appears in the preview section of the Shortcut Editing win-
dow.

Standard Date & Time Options

The following options are available in each of the Date & Time Shortcut options:

�    Insert Text—Select this option to insert the date or time.

�   Make applications accept insert—Some applications do not notice when there has been a change to the 
System clipboard, which can cause problems with the Insert Text Shortcut. Selecting this preference 
enables the Insert Text Shortcut to function properly even if the targeted application does not recog-
nize the clipboard changes.

�    Type Text—Select this option to type the date or time.

�   Simulate keyboard when typing—Select this option when you want QuicKeys to simulate typing.

❖Note: The Shortcut will use the International System Preferences that were set on your computer when 
the Shortcut was created.



118 Chapter 14
Text Tools
Short Date

Select an option in the Format pop-up menu and choose a separator for your Short Date Shortcut. For 
example, the Short Date format is 1/02/03.

�    Separator—Use the Separator field to provide a separator character, such as a slash or a 
colon for the date format.

�    Leading zero for day - You can provide a leading zero for single-digit days. For example, 
January 1, 2003 would be shown as 1/01/2003.

�    Leading zero for month - You can provide a leading zero for single-digit months. For exam-
ple, March would be shown as 03 rather than 3.

�    Show century - Select this checkbox when you want to display the four digit year, rather 
than the two digit year abbreviation.

�    Adjust by—Select this option to type the future date <X> years, months, or days from the 
current date. For example, if you are a member of a Sales Department and you send an e-
mail to a customer, you may want to insert a date in the message stating when you will be 
contacting that customer again.

FIGURE 112. The Date & Time Shortcut Type options
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Long Date & Abbreviated Date

The difference between Long Date and Abbreviated Date is only evident when the typed date 
format is different. For example, using the same options, the Abbreviated format would be Mon, 
Aug 20, 2001 and the Long format would be Monday, August 20, 2001.

�    Prefix—Use this option to specify a prefix for your Long or Abbreviated Date. For example, you 
can type “on ” in the Prefix field so QuicKeys automatically types “on Saturday, May 10, 2003”.

�    None, Day, Month, Weekday, Year—You can choose a separator for each of the pop-up lists. 
Choose None when you do not want a field displayed.

�    Leading zero for day—Selecting this option inserts a zero in front of single-digit numbers. For 
example “1” would be typed as “01”.

�    Show century—Choose this option when you want the year to contain four digits rather than 
two. For example, the year will display as “2003” rather than “03” if you have this option 
selected.

FIGURE 113. The Date & Time Shortcut Type options
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Time

Create a Time Shortcut to insert the current time in your document. For example, you can use a 12-
hour clock format such as 12:34 AM.

�    24-hour clock—Choose this option to type military time in 24-hour increments. For exam-
ple, use a 24-hour clock format such as 19:32 PM.

�    12-hour clock—Choose this option to type the time in a standard 12-hour format. You can 
specify whether you want midnight to display as 0:00 or 12:00.

�    Include seconds—Choose this option to type the time in a format that includes seconds.

�    Before/After Noon indicators—Use this option to provide a designation for morning or 
afternoon.

�    Separator—Use this option to specify a separator, such as a slash or a colon for the time for-
mat.

�    Use leading zero for hour—Use this option to type a zero in front of a single-digit time. For 
example, 7:00 AM would be typed as 07:00 AM when this checkbox is selected. 

FIGURE 114. The Date & Time Shortcut Type options
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The Type Text Shortcut Type is useful when you want to type frequently-used text with a QuicKeys trig-
ger. For example, you can use this Shortcut to type your signature line in e-mail messages or to enter 
common information into databases. To open the Type Text Shortcut Editing window, select 
Create>Text>Type Text. The Shortcut Editing window appears with the Type Text options listed.

Type Text Options

When you create a Type Text Shortcut, you must provide the text you want QuicKeys to type in the text 
box. 

�    Check Spelling—Click the Check Spelling button if you want to check the spelling of the text you 
provided.

�    Insert Text—Select this option if you want QuicKeys to paste the entire block of text in the des-
tination document.

�    Make applications accept insert—Select this option to force an application to see that there is 
text to insert. Some applications do not notice when there has been a change to the System clip-
board, which can cause problems with the Insert Text Shortcut. Selecting this option enables the 
Insert Text Shortcut to function properly even if the targeted application does not recognize clip-
board changes.

�    Type Text—Select this option if you want QuicKeys to type the provided text instead of pasting 
it. 

❖Note: If you are experiencing difficulty with Type Text Shortcuts created using previous ver-
sions of QuicKeys X, check the Simulate keyboard when typing check box.

FIGURE 115. The “Type Text” Shortcut Type options
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�    Simulate keyboard when typing—Select this option when you want QuicKeys to simulate 
typing. This feature allows you to enter text in specific dialogs that don’t accept pasted text 
(such as Password fields and authentication dialogs). 

Drag-and-Drop Functionality

�    Drag-and-drop a text selection onto the QuicKeys Editor to create a Type Text Shortcut.

�    Drag-and-drop a text selection onto the Text to insert/type box in the Type Text Shortcut Editing 
window to create a Type Text Shortcut.
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Chapter 15: 
User Actions Tools
This chapter provides information on using the QuicKeys Shortcuts that are often the building blocks of Multi-
step Shortcuts and QuicKeys recordings.

Button
The Button Shortcut Type clicks dialog buttons in the frontmost window. For example, you can create a Shortcut 
that clicks the Cancel button in a dialog when you press Shift+Control+C. 

Find Button by Name

If you want to choose a button manually by name, choose Name from the Find button by pop-up list. You must also 
choose the variation of the name you want QuicKeys to locate. Choose to find the targeted button by selecting Is, 
Contains, Begins with or Ends with and then type the button name, or part of the button name, in the text field.

FIGURE 116. The Button Shortcut Type options
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Click the Ignore case checkbox if you want QuicKeys to ignore whether or not the button text 
contains upper or lower case letters. 

Click the counter arrow in the Which button if multiple matches field to indicate which button you 
want QuicKeys to click if multiple buttons meet the button criteria you specified. For most 
Shortcuts, “1” will remain the value of this field, but you may need to change the value if mul-
tiple buttons have similar names. For example, if you want QuicKeys to click a “Save” button 
and there is a dialog that has three buttons that say “Don't Save,” “Save” and “Cancel” you 
would need to change the number to 2 since you want the second button (Save) to be selected. 
This adjustment is necessary since there are two buttons in the same dialog that contain the 
word “Save.”

Find by Button by Location

If you want to set location coordinates, choose Location from the Find button by pop-up list. Choose a 
window corner as a basis for your coordinates and then type the horizontal and vertical coordinates 
for the button in respective coordinate fields. You can populate the coordinate fields using the Set 
Button option to get the general coordinates and then edit the numbers as needed. 

FIGURE 117. The “Find button by Name” options

FIGURE 118. The “Find Button by Location” options
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Press Button

Choose the conditions under which the Button Shortcut operates: Always, When button is on, or When but-
ton is off. 

�    Always—QuicKeys selects the designated button regardless of whether it is on or off.

�    When button is on—QuicKeys selects the designated button only when it is on.

�    When button is off—QuicKeys selects the designated button only when it is off.

Set Button

To automatically set the coordinates of the target button, click Set Button located at the bottom of the 
Shortcut Editing window. A Select Button dialog appears and each time your cursor hovers over a 
button, the button and accompanying text are highlighted. When the target button is highlighted, 
press the Caps Lock key to set the location and press the OK button in the Select Button dialog to 
save the button selection.

If the desired item does not register a name, you may need to use the Location option. 

FIGURE 119. The “Press button” options at the bottom of the Button Shortcut Editing window

FIGURE 120. The Select Button options
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Button Details - Window tab 

To further refine your Button Shortcut, click the Button Details button at the bottom of the Short-
cut Editing window. Choose the specifications for the window that will contain the target but-
ton.

Window Type

Use QuicKeys to specify which interface element must be present for a particular Shortcut 
to function properly.

�   Any Window—QuicKeys will make designated selections in any window.

�   Document Window—QuicKeys will only make designated selections in a document 
window. Document windows are typically application editing windows and Finder win-
dows that display folder contents. 

�   Palette Window—QuicKeys will only make designated selections in a palette window. A 
palette is a floating window or toolbar that contains tools. For example, the Show View 
Options in the Finder displays a palette window.

�   Sheet on Any Window—QuicKeys will only make designated selections in a sheet. 
Sheets slide down from the window title.

�   Sheet on Document Window—QuicKeys will only make designated selections on sheets 
that slide out from a document window.

�   Sheet on Palette Window—QuicKeys will only make designated selections on sheets 
that slide out from a palette. A palette is a floating window or toolbar. 

FIGURE 121. The Window tab
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�   Drawer on Any Window—QuicKeys will only make designated selections on drawers. A 
drawer is a window that is attached to, or slides out of, another window.

�   Drawer on Document Window—QuicKeys will only make designated selections on drawers 
that are attached to document windows. A drawer is a window that is attached to, or slides 
out of, another window.

�   Drawer on Palette Window—QuicKeys will only make designated selections on palettes. A 
drawer is a window that is attached to, or slides out of, another window and a palette is a 
floating window or toolbar.

Identify Window by 

�   Frontmost—If you choose Frontmost from the pop-up list, QuicKeys looks for the frontmost 
window on your screen.

�   Name—If you choose Name, you must specify the window title that contains the target button. 
Choose to find the targeted window by selecting Is, Contains, Begins with or Ends with and then type 
the window name, or part of the window name, in the text field.

�   Is— Select Is when you want QuicKeys to find an exact match for the window name you 
provide in the text field.

�   Contains— Select Contains when you want QuicKeys to find a window name that matches 
part of the window name you provide in the text field.

�   Begins with—Select Begins with when you want QuicKeys to find a window name that 
starts with the characters you provide in the text field.

�   Ends with— Select Ends with when you want QuicKeys to find a window name that ends 
with characters you provide in the text field.

�   Ignore case—Click the Ignore case checkbox if you want QuicKeys to ignore whether or 
not the window text contains upper or lower case characters.

�   Which window if multiple matches—Click the counter arrow in the Which window if multiple 
matches field to indicate which window you want QuicKeys to use if multiple windows 
meet the criteria you specified. For most Shortcuts, “1” will remain the value of this 
field, but you may need to change the value if multiple windows have similar names.

�   Level—QuicKeys identifies window level from front to back, so Level 1 would be the front-
most window. Depending upon the application and how it handles windows, you may have to 
tweak the window level when you use this Shortcut option. For example, Photoshop identi-
fies palettes as windows so you may need to experiment with window level for Photoshop 
Shortcuts. 
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Button Details - Options tab

To further refine your Button Shortcut, click the Button Details button at the bottom of the Short-
cut Editing window. Choose the specifications for the button click in the Options tab.

Tell Button to Click Itself

Select Tell Button to Click itself when you want QuicKeys to direct the actual button to perform 
a click instead of simulating a click. Buttons can perform actions on themselves instead of 
an application moving the mouse and telling the OS to click on that object. Using this 
method to complete button clicks is more reliable. For example, if the button is partially 
hidden by another window, using Tell Button to Click itself will still work because the obscured 
window doesn't care that the target button is partially covered. In contrast, if you try to 
simulate a click, the click might fail since it could click a button in the frontmost window 
instead of clicking the partially obscured target button.

Click Button

If the application you want to use does not support the Tell Button to Click itself, use the Click But-
ton option to simulate a click on the button. 

Modifiers

Select a modifier to press while clicking the target button. Modifiers allow clicks to per-
form different functions.

FIGURE 122. The Button Options tab
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Clicks
The Clicks Shortcut Type enables you to mimic a mouse click with a QuicKeys trigger. This Shortcut 
Type is especially helpful when there is no keyboard equivalent for the item you want to select.

There are two types of Clicks Shortcuts: Click and Multiple Clicks. Use Click to click once within a 
Shortcut or step and use Multiple Clicks to click multiple times in a Shortcut.

Click

A Click Shortcut enables you to mimic mouse actions with a QuicKeys trigger. This Shortcut Type is 
especially useful for items such as resizing a window (see page 49 for an example). 

To open the Click Shortcut Editing window, select Create>User Actions>Clicks>Click. The Shortcut Editing 
window appears with the Click options listed.

FIGURE 123. The Click Shortcut Type options
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Click Options

This section describes the Shortcut-specific options available with the Click Shortcut Type.

Click Location and Release Location

You can specify the horizontal and vertical coordinates where the Click Shortcut Type will 
click and release relative to the main display or a specific window. You can enter these 
coordinates manually or you can use the Set Location button to specify your coordinates.

Set Location

The Set Location button is used to auto-populate the coordinates of a Click Shortcut. Click 
the Set Location button to display the Set QuicKeys Click Location dialog. The target icon 
appears when the Set QuicKeys Location dialog is open. 

Position the circle where you want QuicKeys to click. When the circle is positioned where 
you want the click to occur, press the Caps Lock key to lock the Click target into place. 
Then, click the OK button in the Set QuicKeys Click Location dialog to save the Click 
location.

FIGURE 124. The Set QuicKeys Click Location window
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Choose from the following Click options:

�   Set Location for—Choose from Click & Release, Click, and Release. If you choose Click & 
Release, QuicKeys will click and release at the same coordinates. If you choose Click you 
must choose the Release coordinates separately.

�   Relative to—Choose from Display or Window. If you choose Display, coordinates are mea-
sured from a corner of the display. If you have multiple displays, the click location is set 
relative to the display in which the mouse is currently located. If you choose Window, 
coordinates are measured from a corner of the window. When a window is selected, the 
Click Shortcut that is created will only be effective in the specified window.

❖Note: Clicks relative to windows do not work in Classic applications.

�   Corner—Choose one of the four corners on the screen example to click relative to the 
display/window from the specified corner. By default, the coordinates are measured 
from the upper left corner of the display or window. In some cases, it may be preferable 
to set the coordinates relative to a different corner.

Details - Click and Release Tabs

Click the Details button in the Click Shortcut Editing window to further refine your Click Short-
cut. In the Click and Release tabs, you can fine-tune the Horizontal and Vertical coordinates of 
your click and choose whether the click will use the Display or the specified window as its ref-
erence for the defined coordinates.

FIGURE 125. The Click Details window
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�   Click relative to—Choose to have QuicKeys click relative to the Display, a specific 
window, or the most current Mouse location.

�   Click/Release Delay—If you want QuicKeys to pause after a click, specify how 
long you want the delay to last in the Click Delay area of the Click or Release tabs. 
This option slows QuicKeys down to adjust to the response time of your application 
or system.

�   Synchronize—Click the Set Same as Release button in the Synchronize area of the 
Clicks tab if you want to duplicate the settings you specified in the Release tab. 
Conversely, you can click the Set Same as Click in the Synchronize area of the Release 
tab if you want to duplicate the settings you specified in the Click tab.

Details - Options Tab

Choose how you want your clicks to operate using the Options tab.

�   Click with—Choose the mouse button the Click Shortcut will use when it is played. 
For example, if you have a multi-button mouse and you click the center mouse but-
ton to perform a specific function, defining a Center click in QuicKeys will mimic 
this action. Choose from Left, Center or Right mouse buttons.

FIGURE 126. The Options tab appears when you click the Details button.



133
�   Do not release—Choose the Left, Center, or Right checkboxes if you do not want QuicKeys 
to release the click. You may need to use this option when you want QuicKeys to release the 
Click under different coordinates. 

❖Note: If you use this option in a Multi-step Shortcut and you do not set up a special 
Shortcut for release coordinates, QuicKeys will reset your mouse so the Click is released 
for the next playback.

�   Modifiers—Modifiers allow clicks to perform different functions. Choose from any combi-
nation of the Command, Option, Shift and Control keys.

�   Clicks—The mouse will click a specified number of times in the same place. For example, 
you can use this option to mimic a double-click. If you only want to move the mouse without 
performing a click, set this option to 0.

�   Bring all windows to front for click—Selecting this option makes all open windows active 
for Click Shortcuts.

�   Restore mouse location after click—The cursor will move to the original location.

�   Drag duration—Specify the number of seconds between the click and release. This feature 
slows QuicKeys down to adjust to the response time of your application or system.

Multiple Clicks

The Multiple Clicks Shortcut Type creates a series of Click steps. A Multiple Clicks Shortcut is 
similar to a Mouse Recording Shortcut Type, except that each mouse action can be edited and 
clicks play back much faster with the Multiple Clicks Shortcut Type.

❖Note: Clicks relative to windows do not work in Classic applications.

To create a Shortcut for multiple clicks, select Create>User Actions>Clicks>Multiple Clicks. The Set QuicK-
eys Clicks Location window appears. Move your cursor to the click locations you want to set, 
pressing the Caps Lock key to set each location. A number appears, tracking the order of your click 
locations. Press the OK button in the Set QuicKeys Click Locations dialog to create a Multi-step 
Shortcut with multiple click steps defined. See Figure 127 for an illustration of the numbered 
clicks.
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❖Note: You can delete a target icon by Control+clicking it and selecting Delete Location.

FIGURE 127. The Set QuicKeys Clicks Locations window
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Menus
The Menus Shortcut Type is useful when you want to avoid using your mouse, or when you want to 
select a menu item that does not have a keyboard equivalent.

Menus Selection

When you select Create>User Actions>Menu Selection, the Menu Selection Shortcut Editing window appears. 
The Menu Selection Shortcut provides a quick way to select menu items in applications. The Menu or 
Menu Item names can be typed in manually, then you can click the corresponding Details button to fur-
ther refine your selection.

FIGURE 128. The Menu Selection Shortcut Type options
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Menu/Menu Item Details

For information on the options available to you when you click one of the Details buttons in 
the Menu Selection Shortcut Editing window, see “Identify Window by” on page 127.

If you select Position, you must indicate the number that represents the position of the target 
menu. For example, select 1 when you want QuicKeys to use the topmost menu item. 
Keep in mind that QuicKeys counts menu separators (shown as blank lines) in the position 
count. For example, in the QuicKeys File menu, there is a space above the Page Setup 
menu item. QuicKeys counts this space when seeking a menu item by position. For exam-
ple, “Page Setup” is in position eight in the QuicKeys File menu.

FIGURE 129. Menu/Menu Item details

FIGURE 130. Identify a menu by position or name
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Displaying Submenus

You can click the (+) button in the Menu Selection Shortcut Editing window if you want to 
specify submenus for your Shortcut. Click the (-) button to hide the submenu options.

Select Menu

Click the Select Menu button to display the Select Menu window. Choose an application from the 
pop-up list and select the menu item you want to use for your Select Menu Shortcut.

❖Note: Some applications may provide QuicKeys one set of menus when a Shortcut is created, 
but display another set upon playback. If this occurs, type the menu item’s name manually.

Show Menus While Performing Menu Action

Select the Show Menus While Performing Menu Action checkbox if you want QuicKeys to display the 
menus as it makes designated menu selections.

FIGURE 131. Click the (+) button to add Submenu fields.

FIGURE 132. Choose the application that contains the target menu.
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Menu Selection Errors

If QuicKeys encounters an error when trying to access a menu, the prompt in Figure 133 
appears. See the error dialog for specific information regarding the cause of the failure.

Menu Clicks

Menu Clicks Shortcuts select menus by making a series of clicks. To set up a Menu Clicks Short-
cut, follow these steps:

1. Select Create>User Actions>Menus>Menu Clicks. The Set QuicKeys Menu Click Locations window 
appears. 

2. Switch to the application that contains the menu item you want to select.

3. Click the menu title and hold down the mouse button.

4. Press the Caps Lock key to set the first click location. A target icon appears at the mouse loca-
tion.

5. Still holding down the mouse button, move the mouse to the menu item or submenu and press 
the Caps Lock key again. Another target icon appears at the second mouse location.

FIGURE 133. This sheet appears when menus cannot be shown.

FIGURE 134. The Set QuicKeys Menu Click Locations window
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6. Repeat this process until you select the desired menu item.

❖Note: You can move a target icon by clicking and dragging it. You can also delete a target icon 
by Control+clicking it and selecting Delete Location.

7. Press the OK button when you are finished. 

For each menu click location you set, a Click step is created. When you assign a trigger to this Shortcut, 
scope it to the application you selected.

FIGURE 135. Menu Click locations
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Mouse Recording
Mouse Recording is useful if you are building a Multi-step Shortcut and you need to select specific 
interface elements with mouse clicks. When you record a Mouse Recording Shortcut, a blinking 
microphone appears over the QuicKeys Dock icon.

To open the Mouse Recording Shortcut Editing window, select Create>User Actions>Mouse Recording. 
The Shortcut Editing window appears with the Mouse Recording options listed. 

Mouse Recording Options

This section describes the Shortcut-specific options available with the Mouse Recording Short-
cut.

Record

Click the Record button to display the Ready for Mouse Recording dialog. Press the Caps 
Lock key to begin mouse recording. When you are finished recording, press the Caps 
Lock key again. The Mouse Recording Shortcut Editing window appears. You can’t see 
information about your recording session, but you will see two buttons (Record More and 
Clear Recording) that only appear when a recording already exists.

FIGURE 136. The Mouse Recording Shortcut Type options

FIGURE 137. A recording prompt provides instructions for starting and stopping your recording.
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Record More and Clear Recording Buttons

Click the Record More button to add to your recording. Click Clear Recording to delete the recording 
you just made. These buttons are only enabled when you have already completed a mouse 
recording.

Pop-Up Menu
The Pop-up Menu Shortcut Type is useful for selecting pop-up menu items from various windows and 
dialogs. To open the Pop-up Menu Shortcut Editing window, select Create>User Actions>Pop-Up Menu. The 
Shortcut Editing window appears with the Pop-Up Menu options listed.

Find Pop-up Menu by

If you want information on setting up a Pop-Up Menu by name, see page 123. If you want informa-
tion on choosing a Pop-Up Menu by location, see page 124.

FIGURE 138. The Pop-up Menu Shortcut Type options
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Select Menu Item by

You can select Menu Items by Name or Position. If you want information on selecting a menu 
item by name, see page 123.

To choose a pop-up menu by location, select Position from the Select Menu Item by list. Then, 
choose the position for the Pop-Up Menu item. For example, in the QuicKeys File menu, there 
is a space above the Page Setup menu item. QuicKeys counts this space when seeking a menu 
item by position so “Page Setup” is in position eight in the QuicKeys File menu.

Click the Ignore case checkbox if you want QuicKeys to ignore whether or not the pop-up menu 
item’s name contains upper or lower case characters.

Click the counter arrow or type a number in the Which item if multiple matches field to indicate which 
pop-up menu you want QuicKeys to use if multiple menus meet the button criteria you speci-
fied. For most Shortcuts, “1” will remain the value of this field, but you may need to change 
the value if multiple menus have similar names.

Set Pop-up Menu button

To auto-populate the Pop-up Menu fields, click the Set Pop-up Menu button located at the bottom 
of the Shortcut Editing window. A Select Pop-Up Menu dialog appears and each time your cur-
sor nears a pop-up menu, the menu is highlighted. When the target menu is highlighted, press 
the Caps Lock key to set the location and press the OK button to save the Pop-up Menu selec-
tion.

For additional information on the Set Pop-up Menu options, see “Set Button” on page 125.

FIGURE 139. The Select Pop-up Menu options
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Pop-up Menu Details - Window tab 

To further refine your Pop-up Menu Shortcut, click the Pop-up Menu Details button. Choose the 
specifications for the window that will contain the target menu. You can choose document win-
dows, palettes, sheets and drawers from the Window Type pop-up list. See “Window Type” on 
page 126 for more information on the Window Type options.

For information on the options in the Identify Window by pop-up list, see “Identify Window by” on 
page 127.

Pop-up Menu Details - Options tab 

Use the Options tab to select a modifier to press while selecting the target pop-up menu. See “Mod-
ifiers” on page 128 for additional information on Modifier options.

FIGURE 140. The Pop-up Menu “Window” tab

FIGURE 141. The Pop-up Menu “Options” tab
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Scroll Wheel
The Scroll Wheel Shortcut Type enables you to create Shortcuts that simulate the scroll wheel on a 
mouse. If an application supports scroll wheel hardware, a Scroll Wheel Shortcut can control appli-
cation windows. For example, when you are trying to view a Web page that is too big for your 
screen, you can use a Scroll Wheel Shortcut to move the vertical scroll bar up/down.

Scroll Wheel Pop-up List

Most users will use Wheel 1 to simulate the scroll wheel commands. However, there are applications, 
such as CAD programs, that support multiple scroll wheels. Users who have up to three scroll 
wheels at their disposal can specify 1-3 scroll wheels when using the Scroll Wheel Shortcut.

Scroll Direction

Indicate whether you want the Scroll Wheel Shortcut to scroll Up/Left or Down/Right.

Scroll Speed

Use the slider bar to indicate how fast QuicKeys translates the speed of the scroll wheel actions 
for the application.

FIGURE 142. The Scroll Wheel Shortcut Type options
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Modifiers

Modifiers allow clicks to perform different functions. Choose from any combination of the Com-
mand, Option, Shift and Control keys. Select Shift/Horizontal Scroll when you want to scroll horizon-
tally (from left to right). See “Modifiers” on page 128 for additional information on modifiers.

Type Keystroke
To truly personalize your computer, you need to have the ability to choose how you interact with it. 
QuicKeys gives you this ability with the Type Keystroke Shortcut Type. This Shortcut Type provides a 
way to replace Hot Key assignments built into your applications with QuicKeys Hot Keys that make 
sense to you. To open the Type Keystroke Shortcut Editing window, select Create>User Actions>Type Key-
stroke. The Shortcut Editing window appears with the Type Keystroke options listed.

Type Keystroke Options

When you create a Type Keystroke Shortcut, the Keystroke field must be active to type a different key or 
key combination.

When the Keystroke field is active, all QuicKeys Hot Keys are turned off until you move your cursor off 
the Keystroke field. This functionality ensures that QuicKeys does not play a Shortcut while you are 
assigning a keystroke.

FIGURE 143. The “Type Keystroke” Shortcut Type options
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Windows
The Windows Shortcut Type is useful for controlling the appearance and behavior of the windows 
that appear on your screen. To create Windows Shortcuts, select Create>User Actions>Windows.

Window Action 

Choose an option from the Window Action pop-up list.

�    Close—The Close option will close the specified window.

�    Minimize—The Minimize option will collapse the specified window to the Dock. You can re-
open the window by selecting it from the Dock or by using an Unmiminize Windows Short-
cut.

�    Unminimize—The Unminimize option will display a window that has been minimized.

�    Zoom—The Zoom option changes the size of the specified window.

�    Toggle Toolbar—Use the Toggle Toolbar option to show/hide the toolbar of a window.

Window Details

To further refine your Windows Shortcut, click the Window Details button. You can choose 
options from the Window Type and Identify by pop-up menus, or the Window Action and Modifiers 
options.

Window Type

�   Any Window—QuicKeys will make designated selections in any type of window.

�   Document—QuicKeys will only make designated selections in a specific document win-
dow. Document windows are typically application editing windows and Finder windows 
that display folder content. 

FIGURE 144. The Windows Shortcut Type options
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�   Palette—QuicKeys will only make designated selections in a specific palette. A palette is a 
floating window or toolbar. For example, the Show View Options in the Finder displays a 
palette window.

Identify by

See “Identify Window by” on page 127 for information on the options in the Identify by pop-up 
list. 

Window Action

Select Tell Window to do action itself when you want QuicKeys to direct the window to perform the 
specified action instead of simulating the action. Using this method to complete window 
actions is more reliable. For example, if the window is partially hidden by another window, 
using Tell Window to do action itself will still work because it doesn’t matter that the window is par-
tially obscured. In contrast, if you try to simulate a click in a window action, it might fail since 
the button is partially obscured.

If you are trying to use the Windows Shortcut type and it doesn’t work, use the Click to perform 
action option to simulate the window commands.

Modifiers

Modifiers are the keys the Windows Shortcut can use in combination with window actions. See 
“Modifiers” on page 128 for more information.

FIGURE 145. The Windows Details options
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Appendix A:

PlayShortcut AppleScript Events
You have the ability to direct QuicKeys to play a QuicKeys Shortcut from an AppleScript script. For exam-
ple, if you have a QuicKeys Open Items Shortcut that launches the TextEdit application, you can call the 
Shortcut from a script rather than assigning a standard QuicKeys trigger to it.

Script Commands
The following three statements tell QuicKeys to play the “Launch TextEdit” Shortcut:

Tell Application “QuicKeys”

playshortcut named “Launch TextEdit”

End tell

The following statements perform various tasks in the TextEdit application, which was launched using the 
“Launch TextEdit” Shortcut:

Tell Application “TextEdit”

some commands

End tell
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Glossary
Carbon application —A Carbon application is an application that can be run in pre-OS X systems as 
well as Mac OS X.

Dialog—Part of the software interface that contains command buttons and various kinds of options 
through which you can carry out a particular command or task.

Dock—The Dock makes it easy to open applications, documents and other frequently-used items.

Drawer—A window that is attached to, or slides out of, another window.

Hot Key—The keystroke(s) used to play a QuicKeys Shortcut. When you assign several keys to a Hot 
Key (such as Shift+F1), those keys must be pressed simultaneously.

Multi-step Shortcuts—A Shortcut containing a collection of QuicKeys steps you can assemble to 
automate more complex tasks.

Palette—A floating window or toolbar.

QuicKeys Editor—The main component of the QuicKeys interface where you create and edit Short-
cuts and toolbars. 

QuicKeys Menu—The QuicKeys Menu is available whenever the QuicKeys application is running, 
as long as your preferences are set to display it. You can display the QuicKeys Menu by clicking the 
blue QuicKeys icon in the upper right corner of your screen. The Menu provides quick access to 
basic QuicKeys components.

QuicKeys Toolbars—The user-defined toolbars used to play Shortcuts.

Scope—The range of operation for a Shortcut. For example, you can create Shortcuts that only work 
when Microsoft Word is active or Shortcuts that work in any active application on your computer.

Sheet—Sheets (such as the Toolbar Editing sheet) slide out from the window title, and their translu-
cent quality makes them look as though they’re floating above the document.

Shortcut—The time-saving tools you create with QuicKeys to automate single-step or multi-step 
tasks.

Shortcut Editing Window—The window that appears when you create or edit QuicKeys Shortcuts.

Single-step Shortcuts—Shortcuts that automate a single task.
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Static Text—Text shown in a window that cannot be edited. For example, if you want to delete a 
Hot Key trigger, drag from the words “when” or “is pressed.” 

Steps Drawer—The drawer that appears at the bottom of Shortcut windows. Use the Steps 
Drawer to view the steps in a Multi-step Shortcut.

Step Results—The Step Results sheet displays when you click the Results column in the Steps 
Drawer. Use the Step Results sheet to choose how you want each step of your Shortcut to react 
to successes and failures using “If succeeds” or “If fails” conditions.

Sticky—An option you can select when setting up a Hot Key that enables you to combine two 
different Hot Key triggers. The Sticky option essentially extends the use of keystroke assign-
ments.

Sticky Hot Key—A Hot Key trigger that has the Sticky checkbox selected.

Toolbar—The graphical palettes you can use to trigger Shortcuts.

Trigger—Hot Keys, timed events, and QuicKeys Menu selections that signal QuicKeys to start a 
Shortcut. There are several types of QuicKeys triggers available in the Available Triggers 
Drawer: After Open, Day & Time, Hot Key, Repeat and System Menu. QuicKeys must be run-
ning for these triggers to work.

URL—Uniform Resource Locator. A reference to a resource on the Internet. For example, use 
http://www.cesoft.com/ for CE Software’s URL.
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