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CHAPTER 1

• • • • • •
WHAT’S NEW IN QUICKEYS 5.0

Welcome to QuicKeys! QuicKeys 5.0 represents the state of the 
art in personal productivity software. This version is a direct 
result of innovative engineering and support from dedicated 
QuicKeys enthusiasts. Spend just a few minutes with 
QuicKeys and you will soon wonder how you ever worked 
without it.

This addendum supplements the information in the Sixth 
Edition of the QuicKeys for Macintosh User Guide. Please refer 
to the larger User Guide for information that is not included in 
this addendum.

 ▲ IMPORTANT: For installation requirements, see the 
ReadMe file that accompanies your QuicKeys 5.0 
software.

This chapter highlights new features that are expanded upon 
in later chapters of this addendum and it also describes 
architectural enhancements and interface changes made to 
QuicKeys in version 5.0.

NEW FEATURES AND ENHANCEMENTS
QuicKeys 5.0 extends the power of QuicKeys with many new 
features: 

• Toolbars can now contain multiple tabs, each containing 
different Shortcuts.

• A new type of toolbar, called a Pop Out toolbar, hides on 
the edge of your screen until your mouse is positioned 
over it.

• Completely redesigned toolbars offer improved 
functionality via a new Toolbar Settings dialog, making it 
easier to create and edit toolbars. 

• QuicKeys can activate Shortcuts with the new Speech 
trigger.

• With the new Create/View Palette, you can create new 
Shortcuts and filter existing Shortcuts with a click of your 
mouse.

• Support for longer Shortcut names

• Mac OS 9 compatibility

• The ability to lock your computer screen while you are 
away from your desk enables you to obscure the data 
displayed on your screen.

• With Type Text Shortcuts you can now type up to 2,000 
characters.

• New Mousies options expand the power of Mousies 
Shortcuts.

• Timed triggers have more scheduling options that allow 
you to fine-tune when you want to activate Shortcuts.

• Web Launcher now supports launching without the “http” 
prefix.

• The Password Vault Shortcut can now be used outside of 
Sequences.

• A wider variety of Shortcuts can be created from the 
QuicKeys Setup Assistant. Audio CD Player, File Recall, 
PowerBook Specials, Scrap Ease, Sound, Web Launcher, 
and Project Saver are now available in the Setup Assistant.

• File Handler now supports copying files from one location 
to another.
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MAC OS 9 COMPATIBILITY
QuicKeys 5.0 is fully compatible with the multi-user 
environment available in Mac OS 9. Each registered 
“Normal,” “Limited,” and “Panels” user can maintain 
individual Shortcuts and preference settings on a shared 
computer running Mac OS 9.

 ▲ IMPORTANT: Some Shortcuts will not work for non-
owners unless the helper applications are specifically 
configured.

Mac OS 9 and Helper Applications
QuicKeys Shortcuts that require helper applications may not 
be available to Mac OS 9 Limited and Panels users because 
launching the applications requires special permissions.

To allow specific users to launch these helper applications the 
owner of the computer has to grant access to the helper 
applications:

1. Open the Multiple Users control panel.

2. Open the user’s account.

3. In the Setup Details area of the dialog, select the 
Applications tab and click the Add Other button.

4. Choose one of the helper applications from the System 
Folder:Application Support:QuicKeys 5:Plug-ins folder. 
The helper applications include Advanced Text Tools 
Helper, AppleScript Helper, File Handler Helper, File 
Recall Helper, Instant E-mail Helper, Lock Screen Helper, 
Message Helper, QK AppleEvent Helper, Scrap Ease 
Helper, and Web Launcher Helper.

5. Add the QuicKeys Backgrounder and the QuicKeys Setup 
Assistant applications.

6. Close the control panel when you are finished.

FIGURE 1: Use the Multiple Users control panel to set up 
permissions for other users.
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PLUG-INS AND SHORTCUT TYPES
The QuicKeys 4.0 User Guide makes a distinction between 
Standard and Built-in plug-ins that is no longer relevant in 
QuicKeys 5.0. Standard and Built-in plug-ins are now 
designed similarly and will simply be referred to as 
“Shortcuts” or “Shortcut types” in this addendum and future 
documentation. 

QuicKeys plug-ins can be turned on or off using the Plug-in 
Manager, which is discussed in the QuicKeys User Guide.

LONG SHORTCUT NAMES
In prior versions of QuicKeys, Shortcut names could only be 
15 characters long. In version 5.0, Shortcut names can be as 
long as 255 characters.

 ▲ IMPORTANT: Steps inside Sequences cannot have long 
names.

INTERFACE CHANGES
In QuicKeys 5.0, the QuicKeys Editor and the Shortcut 
Properties dialog have changed. Additionally, the Create/
View Palette, previously referred to as the Shortcuts Filter, has 
been redesigned.

THE QUICKEYS EDITOR
The QuicKeys Editor Keysets tab and Toolbars tab now have a 
new column for speech triggers. Information on how to use 
speech triggers is located on page 19. Additionally, QuicKeys 
offers a new Create/View Palette button and two new menu 
items in the Options menu: Show or Hide Create/View Palette and 
Configure Speech. These menu items are discussed in detail on 
the next page and on page 20, respectively.

THE SHORTCUT PROPERTIES DIALOG
The Shortcut Properties dialog, which appears each time you 
create a Shortcut, has been rearranged for improved usability. 
All non-specific controls are now displayed at the top of the 
dialog and all controls that are unique to the selected Shortcut 
type appear at the bottom of the dialog.

THE CREATE/VIEW PALETTE
The Shortcuts Filter has been moved from the bottom of the 
QuicKeys Editor to a floating palette. You can now use the 
palette to create Shortcuts and to choose which Shortcuts are 
visible in the QuicKeys Editor. The buttons in each palette tab 
are grouped by function the same way Shortcut types are 
grouped in QuicKeys’ Create menu. For example, the System 
Tools are grouped together and the Internet Tools are grouped 
together.

FIGURE 2: The redesigned Shortcut Properties dialog
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❖ NOTE: The palette’s Create tab is dimmed when the 
QuicKeys Editor Toolbars tab is active and there are 
no toolbars selected.

Showing and Hiding the Create/View Palette
To show or hide the palette, click the Show or Hide Create/View 
button in the QuicKeys Editor (shown in Figure 4) or select 
Show or Hide Create/View from the QuicKeys Editor Options menu. 
The palette only remains visible when the QuicKeys Editor is 
open.

❖ You can also press Command-H to show or hide the 
Create/View Palette.

Creating Shortcuts with the Palette
To create a Shortcut with the Create/View Palette:

1. In the Create/View palette, click the Create tab.

2. Click a button on the palette. For example, click the Type Text 
button.

3. Complete the Shortcut Properties dialog that appears and 
click OK. 

4. Close the QuicKeys Editor.

5. Trigger the Shortcut using the assigned keystroke, menu 
selection, timed trigger, toolbar button, or spoken 
command.

FIGURE 3: Create Shortcuts using the Create tab in the Create/View Palette.

FIGURE 4: The Show Create/View Palette button
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Filtering Shortcuts with the Palette
To alternately show or hide Shortcuts, click a button on the 
View tab of the palette. When buttons are darkened, or 
pressed, the Shortcuts represented by those buttons display in 
the QuicKeys Editor. When the buttons are not pressed, the 
Shortcuts represented by those buttons are hidden.

To press or release multiple palette buttons simultaneously, 
Option-click a palette button or click a label, such as Internet 
Tools. For example, in Figure 5 the Internet Tools label was 
clicked, so all the Web Launcher and Instant E-mail Shortcuts 
in the QuicKeys Editor are hidden.

Click the Show All button to show all the Shortcuts. Click the 
Show None button to hide all the Quickeys Shortcuts. 

If you used prior versions of QuicKeys, the palette may 
display Shortcut types that are no longer installed with 
version 5.0. Older Shortcuts are grouped by themselves in the 
Create/View Palette.

FIGURE 5: Filter Shortcuts displayed in the QuicKeys Editor using 
the Filter tab.
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QUICKEYS TOOLBARS

QuicKeys toolbars have been redesigned in QuicKeys 5.0. 
Both the functionality and the appearance of the toolbars have 
been changed to make them easier to use. For instance, 
QuicKeys toolbars now behave much like a QuicKeys keyset, 
with each toolbar containing its own Shortcuts. Consequently, 
a Shortcut created on a toolbar will only exist on that toolbar. 
it will not appear in any keyset unless you copy it from the 
toolbar.

THE TOOLBARS TAB
In the Toolbars tab, the Toolbar Options Pane has been 
replaced with a Settings button.

TOOLBAR SETTINGS
When you click the Settings button in the Toolbars tab, the 
QuicKeys Toolbar Settings dialog appears. Use the tabs in this 
dialog to specify the attributes for a new or existing toolbar. 

Always on top — The selected QuicKeys toolbar remains in 
the foreground, regardless of which application is active or 
how many windows are open.

FIGURE 6: The QuicKeys Editor Toolbars tab

FIGURE 7: Specify general toolbar settings in the Toolbar window.
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Show single tab — Hides the tab on single-tab toolbars in 
order to save space. Multiple tabbed toolbars ignore this 
option.

Show out of scope tabs —Displays all toolbar tabs even if one 
of the tabs is scoped to an application that isn’t currently the 
frontmost application.

Horizontal/Vertical Direction — Displays the toolbar 
horizontally or vertically.

Toolbar Tabs
This version of QuicKeys enables you to have multiple tabs on 
a QuicKeys toolbar. Each tab can be “scoped” to work with a 
specific application or with all of your applications.

If your toolbar has several tabs, you can scroll through them 
using arrow tabs that appear.

Adding Tabs
To add a tab to a toolbar:

1. Select the Toolbars tab in the QuicKeys Editor.

2. Select a toolbar.

3. Click the Settings button in the Toolbars tab.

4. Select Tabs in the Toolbar Settings dialog and click the Add 
Tab button. 

FIGURE 8: A single-tab toolbar with the “Show single tab” check 
box unchecked.

FIGURE 9: Toolbars can have multiple tabs.

FIGURE 10: Reduced-size toolbars have arrow tabs that can be 
used to scroll through toolbar tabs.

FIGURE 11: Specify the settings for individual toolbar tabs in the 
Tabs window.
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5. Type a name for the tab and click OK.

Removing Tabs
To remove a tab from a toolbar:

1. Select the Toolbars tab in the QuicKeys Editor.

2. Select a toolbar.

3. Click the Settings button in the Toolbars tab.

4. Select Tabs in the Toolbar Settings dialog.

5. Select the tab you want to remove from the Tabs pop-up 
menu and click the Remove Tab button. 

6. Click OK when you are finished.

Pop Out Toolbars
QuicKeys 5.0 also offers Pop Out toolbars in addition to 
Docked, Floating, and Click N Go toolbars. When you 
position your cursor over a hidden Pop Out toolbar, the 
toolbar pops up from the edge of the screen until it is entirely 
visible. The Pop Out toolbar remains visible until you move 
the cursor off the toolbar. See Figure 12.

ADDING SHORTCUTS TO TOOLBARS
You can add Shortcuts to toolbars by copying them from the 
QuicKeys Editor or from another toolbar and pasting them 
onto another toolbar using the toolbar’s contextual menu. To 
view the contextual menu, Control+click on the toolbar tab.

You can also Control+click a toolbar tab and click the Edit 
Toolbar option to add Shortcuts to your toolbars.

DELETING SHORTCUTS FROM TOOLBARS
You can delete a Shortcut from a toolbar by Control+clicking a 
toolbar button and selecting the Delete Button option. 

LAUNCHING TOOLBARS FROM TOOLBARS
With QuicKeys 5.0, you can place buttons on toolbars that 
launch other QuicKeys toolbars. Simply drag a toolbar from 
the QuicKeys Editor toolbar list to a toolbar displayed on your 
desktop.

FIGURE 12: Pop Out Toolbars only display when the cursor moves 
over them.

FIGURE 13: 
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QUICKEYS SHORTCUT TYPES

LOCK SCREEN
QuicKeys’ Lock Screen feature enables you to obscure the 
information on your computer screen when you leave your 
computer. When you trigger a Lock Screen Shortcut, a floating 
QuicKeys graphic moves around on your blackened screen. 
When you return to your computer, you can unlock your 
screen by typing your passphrase and pressing the Return or 
Enter key. 

❖ NOTE: All QuicKeys Shortcuts are disabled when 
your screen is locked.

SETTING UP A LOCK SCREEN SHORTCUT
You can create multiple Lock Screen Shortcuts, each with its 
own passphrase. 

Using the Shortcut Properties Dialog

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Lock Screen or press the Lock 
Screen button on the Create/View palette. The Shortcut 
Properties dialog appears.

3. Type a Passphrase to use when you want to unlock your 
screen.

4. Type a Hint Phrase that will help you remember your 
Passphrase. The Hint Phrase displays when you attempt to 
unlock your screen.

5. Type a name for the Shortcut in the Name box.

6. Position your cursor in the Keystroke box and press the 
keys you want to use to trigger this Shortcut.

7. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

8. Close the QuicKeys Editor.

FIGURE 14: The Lock Screen Shortcut Properties dialog
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LOCKING YOUR SCREEN
Use the trigger you assigned to your Lock Screen Shortcut. 
Your screen blackens and a QuicKeys graphic moves around 
the screen. Your screen is now obscured from wandering eyes. 

 ▲ IMPORTANT: The Lock Screen Shortcut only locks your 
screen; it does not lock your computer. Do not rely on 
the Lock Screen Shortcut as your sole means of security.

UNLOCKING YOUR SCREEN
When you want to unlock your screen:

1. Begin typing your passphrase. Your passphrase appears in 
bullets above your hint phrase.

2. Press the Return or Enter key. The Mac OS desktop 
reappears so you can resume your work. If there were any 
unsuccessful attempts to unlock your screen, a dialog 
appears indicating the number of incorrect passphrase 
entries that occurred while your screen was locked.

❖ NOTE: If you pause for more than 30 seconds 
between typing your passphrase and pressing the 
Return or Enter key, the computer screen returns to 
a locked state.

SPECIALS

CONTROLLING QUICKEYS SPEECH 
RECOGNITION

The Specials Shortcut now offers the ability to control 
QuicKeys speech recognition, which is discussed on page 19. 
You can set up Shortcuts to Turn On Speech, Turn Off Speech, or 
Toggle Speech. 

SHOWING/HIDING TOOLBARS
You can now create a Shortcut that shows or hides existing 
QuicKeys toolbars.

1. Open the QuicKeys Editor and select the Keysets tab.

FIGURE 15: The Specials Shortcut Properties dialog
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2. Select Create > System Tools > Specials to display the Shortcut 

Properties dialog.

3. Select a toolbars option from the Action menu.

• Show All Toolbars displays all universal and currently 
scoped toolbars.

•Hide All Toolbars hides all your QuicKeys toolbars.

• Toggle Toolbars hides all visible toolbars, then shows 
toolbars that were hidden by previous toggles.

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke or other trigger to the Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

Select the trigger you specified in step 5 to show or hide your 
QuicKeys toolbars.

TYPE DATE/TIME
The Type Date/Time Shortcut has now been divided into two 
separate Shortcut types that offer a larger variety of date and 
time formats. If you created Shortcuts with the Type Date/
Time Shortcut using previous versions of QuicKeys, the 
Shortcut is automatically converted to a Type Date or Type 
Time Shortcut the first time it is opened for editing.

TYPE DATE
To set up a Type Date Shortcut, you must first choose a date 
format from the Format pop-up menu. 

Long Date
When you choose Long Date, use the pop-up lists to choose the 
weekday, month, day, and year or select None to leave that 
particular field blank. Use the text boxes to specify what type 
of separator to use after the selected date field. For example, if 
you type a comma and a space in the Weekday field, a space in 
the Month field, and a comma and a space in the Day field, 
QuicKeys uses “Weekday, <space>Month<space>Day,” as the 
date format. 

Click the Leading zero for day check box to make all numbers two 
digits, such as 02 rather than 2. Click the Use abbreviation check 
box to abbreviate parts of the date, such as Mon for Monday. 
Finally, click the Show century check box to use four digits rather 
than two in the year field.

FIGURE 16: The Specials Shortcut Properties dialog
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Short Date
When you choose Short Date, you must specify the order of the 
month, the day, and the year. You must also choose a 
separator such as a slash or colon. Click the Leading zero for day 
and Leading zero for month check boxes to make all numbers two 
digits, such as 02 rather than 2. Click the Show century check box 
to use four digits rather than two in the year field.

TYPE TIME
When you set up a Type Time Shortcut, you must choose clock 
settings and a time format.

Clock Settings
To set up your clock settings, choose whether you want to use 
24 hour or 12 hour intervals. For example, if you want to type 
a meeting time of 3:00 PM, the 24 hour clock would convert 
3:00 PM to 15:00. When you select the 12 hour clock, you must 
choose whether you want noon and midnight represented by 
a zero or a 12. For example, 12:30 am would appear as 0:30 if 
you selected 0:00 and it would appear as 12:30 if you selected 
12:00.

Time Format
To set up your time format, choose how you want morning 
and afternoon indicated. By default, the Before noon option is set 
to AM and the After noon option is set to PM. You must also 
choose a separator such as a slash or colon. 

FIGURE 17: The Type Date Shortcut Properties dialog

FIGURE 18: The Type Time Shortcut Properties dialog
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TYPE TEXT

A QuicKeys 5.0 Type Text Shortcut can type up to 2,000 
characters. Previous versions of the Type Text Shortcut could 
only handle 255 characters.

FILE HANDLER
The File Handler Shortcut now offers an option to copy 
selected files from one location to another. 

SETTING UP A COPY SELECTED FILES SHORTCUT

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > File Tools > File Handler. The Shortcut Properties 
dialog displays.

3. Select Copy Selected Files from the Action pop-up menu.

FIGURE 19: The Type Text Shortcut Properties dialog

FIGURE 20: The File Handler Shortcut Properties dialog
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4. Choose where you want to copy the selected files. You can 
copy files to a folder you specify, to the Trash, to the 
desktop, up one folder level or out of all folders. When you 
choose Out of All Folders, QuicKeys moves the files to the top 
level of your hard drive.

5. Click the Replace existing files check box to replace duplicate 
files in the destination folder with files you are copying.

6. Type a name for the Shortcut in the Name box.

7. Assign a keystroke to the Shortcut.

8. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

9. Close the QuicKeys Editor.

10.Select the file(s) on your hard drive that you want to copy 
and press the keystroke or other trigger you assigned to 
this Shortcut. The files are immediately copied to the 
destination you specified.

MOVE SELECTED FILES
The Move Selected Files Shortcut Properties dialog now 
contains a check box that allows you to automatically replace 
existing files in the destination folder when you move files.

MOUSIES
The Mousies Shortcut now offers a Move to Next Scroll Bar option 
that enables QuicKeys to move the mouse to the next scroll 
bar it finds in the frontmost application. Plus, you can choose 
to use the scroll bar closest to your mouse option with other 
scroll bar Mousies Shortcuts.

You can also specify modifiers for the Close Window, Zoom Window, 
and Collapse Window options. Specifying modifiers with 
QuicKeys enables you to control all open windows for a 
particular application as if you were holding down a modifier 
key and clicking your mouse. For example, you can create a 

FIGURE 21: The Move Selected Files Shortcut Properties dialog
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Mousies Shortcut that would be like holding down the Option 
key and clicking the close box on an open window to close all 
windows in an application or you can Option-click the Zoom 
box to expand the window to cover the entire the screen.

WEB LAUNCHER
The QuicKeys 5.0 Web Launcher Shortcut no longer requires 
an “http” prefix to identify text as a Web URL. Consequently, 
you can now type www.cesoft.com in the Web Launcher dialog 
rather than http://www.cesoft.com.

PASSWORD VAULT
The Password Vault Shortcut has been modified so that it may 
now be used as a standalone Shortcut. Prior versions of 
QuicKeys only recognized Password Vault Shortcuts when 
they were part of a Sequence.

To open the Password Vault dialog, select Create > Text Tools > 
Password Vault.

JUMP
The Jump Shortcut now has the capability to jump to a specific 
step in a Sequence without having to meet a particular 
condition.

FIGURE 22: The Mousies Shortcut Properties dialog

FIGURE 23: The Password Vault Shortcut Properties dialog
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CHAPTER 4

• • • • • •
QUICKEYS TRIGGERS

SPEECH TRIGGERS
New in QuicKeys 5.0, speech triggers enable QuicKeys to 
listen and respond to voice commands. For speech triggers to 
function properly, you must have Speech Recognition 
installed. Speech Recognition is available in custom 
installations of Mac OS 8.5, 8.6 and 9.0. If you do not have the 
proper speech components installed, the speech column in the 
QuicKeys Editor is dimmed. 

❖ NOTE: Use the Mac OS Help system to learn more 
about how your computer listens for spoken 
commands.

THE DEFAULT KEYSET
There is a voice activated Shortcut in the default keyset that is 
installed with QuicKeys 5.0. To trigger the Shortcut, say the 
specified speech keyword (if any), then the words “Open 
QuicKeys.” If speech is configured properly and your 
microphone works, your computer will respond by opening 
the QuicKeys Editor. If your computer does not respond to 
your voice command, continue reading this chapter for more 
information about installing and setting up speech 
capabilities.

INSTALLING SPEECH CAPABILITIES
If you do not have Listening options available in your Speech 
control panel, you need to perform a custom installation of 
Mac OS 8.5, 8.6, or 9.0. 

1. Begin the Mac OS installation process.

2. If you are using a Mac OS 8.5 or 8.6 CD, select Customize in 
the Install Software screen. If you are using a Mac OS 9.0 
CD, click the Add/Remove button shown in Figure 24.

FIGURE 24: Click Add/Remove if you are using Mac OS 9.0
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3. Click the English Speech Recognition software installer check 
box and uncheck the other components. See Figure 25.

4. Click Start to install speech recognition capabilities.

5. Click Restart at the prompt. After your computer has 
restarted, the Speech Recognition window appears, 
indicating that QuicKeys is ready to listen for your spoken 
commands.

SETTING UP SPEECH TRIGGERS
To set up a speech trigger:

1. Open the Speech control panel and specify your Listening 
options. See Figure 27. 

2. Open the QuicKeys Editor.

3. Select Options > Configure Speech.

FIGURE 25: Select English Speech Recognition to install Mac OS 
listening capabilities.

FIGURE 26: The Speech Recognition feedback window appears 
whenever QuicKeys is ready to accept a speech trigger.

FIGURE 27: The Speech control panel
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4. Make sure QuicKeys Speech Recognition is turned on.

5. If you want to specify a keyword to be used with spoken 
commands, type a word or phrase in the text box.

6. Click OK to close the Configure Speech dialog.

7. Create a Shortcut and click the Speech button in the Shortcut 
Properties dialog. 

 

8. Choose how you want the speech trigger to function. You 
can use the Shortcut name as the trigger, you can type a 
special phrase in the text box to use as a trigger, or you can 
use either of the speech trigger options. 

9. Click OK to close the Speech Trigger dialog.

❖ NOTE: You can also set up a speech trigger by 
clicking in the speech column of the QuicKeys 
Editor. See Figure 31.

FIGURE 28: The Configure Speech dialog

FIGURE 29: The Speech button in the Shortcut Properties dialog.

FIGURE 30: The Speech Trigger dialog appears when you create or 
edit a speech trigger.
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USING SPEECH TRIGGERS
To trigger QuicKeys Shortcuts with speech triggers:

1. Hold down the key you specified in the Speech control 
panel. By default, the Mac OS uses the Esc key.

2. If you specified a word in the QuicKeys’ Configure Speech 
dialog, speak it now. For example, if you specified the 
word “QuicKeys,” say it while pressing the Esc key.

3. Speak the Shortcut name or phrase you specified when you 
created the Shortcut. The Speech Recognition feedback 
window displays your command and your Shortcut is 
immediately triggered.

 ▲ IMPORTANT: QuicKeys does not recognize speech 
triggers when the QuicKeys Editor is open.

DISABLING A SPEECH TRIGGER
To turn off a speech trigger for an individual Shortcut:

1. Open the QuicKeys Editor.

2. Click the cell in the Speech column that contains the speech 
trigger you want to disable.

3. Select Disable Speech from the pop-up menu that displays. 
The ear icon dims and the speech trigger is immediately 
disabled for that Shortcut.

TURNING OFF QUICKEYS SPEECH RECOGNITION
To turn off QuicKeys’ speech capabilities for all your 
Shortcuts:

1. Open the Quickeys Editor.

2. Select Options > Configure Speech. See Figure 28 on page 21.

3. Select Off and click OK. QuicKeys speech recognition is 
disabled until you return to the Configure Speech dialog 
and click On.

❖ NOTE: You can also set up a Shortcut to toggle 
QuicKeys speech recognition. See page 12.

FIGURE 31: Click in the Speech column to create, edit or delete 
speech triggers.
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TIMED TRIGGERS

Timed triggers automatically launch QuicKeys Shortcuts 
using a specific date, time of day, or repeating interval. In 
QuicKeys 5.0, timed triggers have been enhanced with new 
options and the ability to retain settings when a timer is 
disabled.

TIMER OPTIONS
Timed triggers now allow for day of week settings as well as 
time settings. For example, a timed trigger can now launch a 
specific Web site every Monday at 8:00 AM.

TIMER DATA
In prior versions of QuicKeys, when you deactivated a timed 
trigger for an existing Shortcut the timer data was lost. 
However, in version 5.0 QuicKeys retains values for timed 
triggers even if they have been deactivated. 

To check whether or not a particular QuicKeys Shortcut 
contains timer data, look at the Keysets tab in the QuicKeys 
Editor. If a timer icon is visible in the Timer column, the timer 
is turned on for that Shortcut. If the timer icon is visible but 
dimmed, the timer has been turned off. If there is no timer 
data for the Shortcut, the Timer column is empty.

FIGURE 32: The Timer Trigger dialog

FIGURE 33: Timer icons indicate whether the timed trigger for a 
selected Shortcut is turned on or off.
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You can change your timed triggers by clicking in the 
QuicKeys Editor Timer column and selecting an option from 
the pop-up menu that appears. Click Edit Timers to display the 
Timed Trigger dialog, click Enable Time & Day Timer to turn on the 
selected timed trigger, or click Clear Timers to delete the selected 
timed trigger.

FIGURE 34: The Timed Trigger pop-up menu
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QUICKEYS SCRIPTS

This appendix provides information about changes to the 
scripts installed with QuicKeys 5.0. 

❖ NOTE: The DateTime script keyword used in prior 
versions of QuicKeys is still recognized by 
QuicKeys 5.0.

TYPE DATE KEYWORDS AND SYNTAX

Old DateTime Date Keywords
The following keywords, originally used with the DateTime 
command, are recognized by the Type Date plug-in. When 
compiled, these old keywords will be converted to the new 
Type Date keywords. As with any QuicKeys script command, 
each Type Date command must begin with the keyword 
TypeDate to indicate that the remaining parameters on that 
line are for the Type Date plug-in.

Keyword Result

Short_Date 3/27/00

Long_Date Monday, March 27, 2000

Long_Date_Abbr Mon, Mar 27, 2000

Long_No_Day March 27, 2000

Short_No_Day Mar 27, 2000

Long_Alt 27 March 2000

Short_Alt 27 Mar 2000

YYMMDD 3/27/00

Long_No_Day_Short_Year March 27, 00

Short_No_Day_Short_Year Mar 27, 00

Long_Alt_Short_Year 27 March 00

Short_Alt_Short_Year 27 Mar 00

MDY 3/27/00

MMDDYY 3/27/00

Long_Day Monday, March 27, 2000

Short_Day Mon, Mar 27, 2000

Keyword Result
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New TypeDate Keywords

Following the Long keyword, the user may specify the order 
of the date parts, as well as the text that separates each date 
part from the next. The four date parts are:

Each date part may be used once in any order. A separator of 
up to four characters may be specified between each pair of 
date parts, in addition to a four-character prefix and suffix.

Long Date 
Keyword

Result

Long Varies according to the long date format 
specified in the Date & Time Control Panel.

Long Date Parts

Day

Weekday

Month

Year

Long Date Examples Result

TypeDate Long Weekday ", " 
Month " " Day ", " Year

Monday, March 27, 00

TypeDate Long Month " " Day 
", " Year

March 27, 00

TypeDate Long " * " Month " " 
Day " * " 

* March 27 * 

TypeDate Long Month Year March00

Long Date Options

LZD Display a leading zero for day.

Abbr Use abbreviation for weekday and month 
names.

Century Display the century with the year.

Long Date Option Examples Result

TypeDate Long Weekday ", " Month " " 
Day ", " Year Century

Saturday, April 
1, 2000

TypeDate Long Weekday ", " Month " " 
Day ", " Year LZD

Saturday, April 
01, 00

TypeDate Long Weekday ", " Month " " 
Day ", " Year Century LZD

Saturday, April 
01, 2000

TypeDate Long Weekday ", " Month " " 
Day ", " Year Abbr

Sat, Apr 1, 00

TypeDate Long Weekday ", " Month " " 
Day ", " Year Abbr LZD

Sat, Apr 01, 00

TypeDate Long Weekday ", " Month " " 
Day ", " Year Abbr LZD Century 

Sat, Apr 01, 
2000
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Following the Short keyword, the user may specify one short 
date format as well as a one character separator which will 
separate each of the three date parts. The Sep keyword 
followed by a single character in double-quotes will be used 
in place of the default date separator.

Short Date 
Keyword

Result

Short Varies according to the short date format 
specified in the Date & Time Control Panel.

Short Date Formats

DMY Day Month Year

DYM Day Year Month

MDY Month Day Year

MYD Month Year Day

YDM Year Day Month

YMD Year Month Day

Short Date Examples Result

TypeDate Short DMY 27/3/00

TypeDate Short DYM 27/00/3

TypeDate Short MDY 3/27/00

TypeDate Short MYD 3/00/27

TypeDate Short YDM 00/27/3

TypeDate Short YMD 00/3/27

TypeDate Short DMY Sep "|" 27|3|00

TypeDate Short DYM Sep "+" 27+00+3

TypeDate Short MDY Sep "-" 3-27-00

TypeDate Short MYD Sep "*" 3*00*27

TypeDate Short YDM Sep "$" 00$27$3

TypeDate Short YMD Sep "@" 00@3@27
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 TYPE TIME KEYWORDS AND SYNTAX

Old DateTime Time Keywords
The Type Time plug-in recognizes the following keywords, 
originally used with the DateTime command. When 
compiled, these old keywords will be converted to the new 
Type Time keywords. As with any QuicKeys script command, 
each Type Time command must begin with the keyword 
TypeTime to indicate that the remaining parameters on that 
line are for the Type Time plug-in.

New Type Time Keywords

Short Date Options

LZM Display a leading zero for months less than 
10.

LZD Display a leading zero for days less than 10.

Sep "X" Use the specified separator character 
between the date parts.

Short Date Option Examples Result

TypeDate Short DMY 27/3/00

TypeDate Short DMY LZM 27/03/00

TypeDate Short DMY Sep "-" 27-3-00

TypeDate Short DMY LZM Sep "-" 27-03-00

Keyword Result

Short_Time 3:33

Long_Time 3:33 PM

TwentyFourHr 15:33

Keyword Result

TwelveHr Noon and midnight 
expressed as 12:00.

TwentyFourHr Noon and midnight 
expressed as 0:00.

Time Examples AM Result PM Result

TypeTime Short_Time 12:34 4:56

TypeTime Long_Time 12:34 AM 4:56 PM

TypeTime Twenty-
FourHR sep “:”

0:34 16:56

TypeTime TwelveHr sep 
“:”

12:34 AM 4:56 PM

TypeTime ZeroHr sep “:” 0:34 AM 4:56 PM



29• • • •

Optional Time Keywords
The following optional keywords may be used with the new 
Type Time keywords to further extend their capabilities. Use 
with the DateTime keywords will result in syntax errors when 
compiling.

QUICKEYS SPECIALS
The following keywords have been added to the Specials 
Shortcut:

• Toggle_Speech

• Show_All_Toolbars

• Hide_All_Toolbars

• Toggle_Toolbars

• Turn_On_Speech

• Turn_Off_Speech

Type Time 
Options

Sep “X” Use the specified separator between time 
designations.

AM_Str Specify a custom string of up to four charac-
ters to be appended before noon. When 
omitted, the suffix defined in the Date & 
Time Control Panel will be used.

PM_Str Specify a custom string of up to four charac-
ters to be appended after noon. When 
omitted, the suffix defined in the Date & 
Time Control Panel will be used.

LZH Display a leading zero for hours less than 
ten.

Seconds Display seconds.

Type Time Option 
Examples

AM Result PM Result

TypeTime TwelveHr 
AM_Str " am" PM_Str 
"pm" sep “:”

12:34 am 4:56 pm

TypeTime TwelveHr 
AM_Str"" LZH sep “:”

00:34 04:56 PM

TypeTime ZeroHr LZH 
Seconds “:”

0:34:45 AM 4:56:12 PM

Type Time Option 
Examples

AM Result PM Result
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